Bug 85872 - [EDITING] Crash when trying to remove marker [LS] from Entries tab in TOC dialog
Summary: [EDITING] Crash when trying to remove marker [LS] from Entries tab in TOC dialog
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha1
Hardware: x86 (IA32) Linux (All)
: medium critical
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:4.4.0 target:5.1.0
Keywords: regression
Depends on:
Blocks:
 
Reported: 2014-11-04 19:21 UTC by Cor Nouws
Modified: 2016-10-25 19:24 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
for convenience, my test document (8.94 KB, application/vnd.oasis.opendocument.text)
2014-11-04 19:22 UTC, Cor Nouws
Details
bt (3.53 KB, text/plain)
2014-11-06 18:13 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2014-11-04 19:21:40 UTC
Writer document
paragraph Heading one - type BladieBla
enter enter
paragraph Heading two - type BladieBla

Insert > Indexes and Tables
Tab Entries
Select position LS
Try to delete that with DEL
 > Crash

Items E# can be removed without trouble (Didn't try the rest).
Comment 1 Cor Nouws 2014-11-04 19:22:44 UTC
Created attachment 108912 [details]
for convenience, my test document
Comment 2 Urmas 2014-11-04 20:57:54 UTC
Error message:

ToxLinkProcessor: More calls for CloseLink() than open links exist.
Comment 3 Julien Nabet 2014-11-05 22:04:16 UTC
On pc Debian x86-64 with master sources updated yesterday, I don't reproduce this.
Comment 4 Cor Nouws 2014-11-05 23:12:59 UTC
Ah well, another 32bits issue :)
Comment 5 Julien Nabet 2014-11-06 07:26:27 UTC
On Virtualbox Ubuntu 14.10 with master sources updated 1 week ago, I reproduced the crash.
I don't have a bt but retrieved this:

C  [libvcllo.so+0x22dd06]  vcl::Window::ImplCalcOverlapRegionOverlaps(vcl::Region const&, vcl::Region&)+0x40

Cor: could you retrieve a bt with symbols?
(since as for me, Virtualbox is quite slow)
Comment 6 Julien Nabet 2014-11-06 18:13:13 UTC
Created attachment 109057 [details]
bt

It seems the bt doesn't come from the original problem but from the call to FatalError so I don't know if it will be helpful.
Comment 7 Julien Nabet 2014-11-06 22:29:15 UTC
Now I reproduce this with master sources updated today on pc Debian x86-64 ...
Comment 8 Julien Nabet 2014-11-17 20:36:42 UTC
Forgot to add this from console:
warn:fwk:14235:1:framework/source/fwi/threadhelp/transactionmanager.cxx:265: TransactionManager...: Owner instance stand in close method. Call was rejected!

Chris/Caolan: one for you? (bt includes vcl part)
Comment 9 Michael Stahl (CIB) 2014-11-19 23:02:16 UTC
fixed on master
Comment 10 Commit Notification 2014-11-19 23:02:50 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6b9ab853b6a5fa71c0b6c594ed0e6e6016d13a3b

fdo#85872: sw: fix crash in insert index dialog

It will be available in 4.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2015-08-13 07:01:46 UTC
Tobias Lippert committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5d81c9f24fbe48a0717640c1ba6bcf882b9358e2

tdf#85872 ToxLinkProcessor correct header and tests

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.