Download it now!
Bug 85875 - [EDITING] properties of controls cannot be selected in the normal manner
Summary: [EDITING] properties of controls cannot be selected in the normal manner
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha1
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:4.5.0
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2014-11-04 20:42 UTC by Cor Nouws
Modified: 2015-12-17 08:38 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2014-11-04 20:42:06 UTC
Open the Basic IDE
Add a dialog
Add a control
Now in the properties panel, left for me, try to select e.g. the text for label
  > Dragging the mouse over the text tries to move the whole panel
  the text can be selected by hovering over the text :)

Annoying. 
One can also not select the text my key board.
Comment 1 Cor Nouws 2014-11-05 08:25:12 UTC
TODO: find out when it changed..
Comment 2 Matthew Francis 2014-12-20 14:21:36 UTC
It has always been like that since the property browser became dockable

It's probably not very helpful in relation to fixing it, but the commit which introduced the docked browser (and the bug) was this one:

commit 7d5911e40855ac6234590e008927c9b819084ad0
Author: Uray M. János <uray.janos@gmail.com>
Date:   Fri Aug 31 12:44:47 2012 +0200

    Basic IDE: Docking property browser under object catalog
Comment 3 Cor Nouws 2014-12-21 10:30:52 UTC
@matthew: thanks for noticing this

@caolán: can we ask you advise here pls?
Comment 4 Caolán McNamara 2014-12-22 13:05:57 UTC
Its receiving buttons downs, but not button ups for some reason. Presumably a parent window is filtering out some events getting to it.
Comment 5 Caolán McNamara 2014-12-22 13:48:49 UTC
These MultiLine edits pass mouse-up/down events to their parents, while "normal" edits don't. I feel the multilines should act like non-multi lines and swallow the events also and not pass them on.
Comment 6 Commit Notification 2014-12-22 13:57:49 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1fab56683a9e98d9252e5680d1eb509942b2dd95

Resolves: fdo#85875 MultiLineEdit like Edit should not forward mouse-[down|up]

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Robinson Tryon (qubit) 2015-12-17 08:38:35 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]