Bug 85943 - bold activates by itself
Summary: bold activates by itself
Status: RESOLVED DUPLICATE of bug 85876
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2014-11-05 22:10 UTC by Tim Lloyd
Modified: 2015-12-15 10:49 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Lloyd 2014-11-05 22:10:37 UTC
A bug has been highlighted on the LO users list:

http://nabble.documentfoundation.org/LibreOffice-Writer-Bold-activates-by-itself-td4127860.html

I have tried a few old versions on Fedora and I can see that the problem occurs between 4.2.3 and 4.2.4

This can be achieved with a blank writer document.

This problem has been recreated on Linux (Fedora, Ubuntu, Debian) but not on windows.

1. Turn on Bold either by Ctr+B or by toolbar button.
2. Type some text in bold font.
3. Before pressing Enter, Type Ctl+B to turn bold off.
4. Press Enter two times.
5. Press the Up arrow one time.
6. Look at the Bold toolbar button, Bold will be back on. 

In 4.2.3 step 6 will not activate Bold
Comment 1 V Stuart Foote 2014-11-05 23:24:26 UTC
Confirming as NEW.

Issue does also occurs on Windows builds
current master
Version: 4.4.0.0.alpha1+
Build ID: 3c58f0768049718fae3d47d5ebfa6c7485ad52b1
TinderBox: Win-x86@39, Branch:master, Time: 2014-11-05_06:43:51

was not present for the 4.1 branch.

Looking at the resulting ODF archive if the file is saved, the content.xml does show a P1 style from the first line also being assigned to the second blank paragraph. The P1 style is being created with the text weight for the style set bold. And on cursor up from the third line which gets a P2 style assignment, the line picks up the P1 style--including the bold weight. 

That automatic style assignment is done in while document is in LO buffers and is not correct.
Comment 2 V Stuart Foote 2014-11-05 23:38:44 UTC
Extracts from content.xml for two saved ODF document archives.

This is the correct XML from 4.1.7, note T1 style for 2nd line.

<text:p text:style-name="P1">Bold<text:span text:style-name="T1"> turned off now</text:span></text:p><text:p text:style-name="P1"><text:span text:style-name="T1">one line up, bold remains off</text:span></text:p><text:p text:style-name="P1"><text:span text:style-name="T1">two lines down, bold is off</text:span></text:p></office:text>

This is the incorrect XML from 4.4.0, note P1 style for 2nd line
<text:p text:style-name="P1">BOLD<text:span text:style-name="T1"> turned off here</text:span></text:p><text:p text:style-name="P1">one cursor up, bold is on</text:p><text:p text:style-name="P1"><text:span text:style-name="T1">two lines down, bold is off</text:span></text:p>
Comment 3 Urmas 2014-11-06 03:37:41 UTC

*** This bug has been marked as a duplicate of bug 85876 ***
Comment 4 Robinson Tryon (qubit) 2015-12-15 10:49:16 UTC
Migrating Whiteboard tags to Keywords: (regression)
[NinjaEdit]