Bug Hunting Session
Bug 85979 - Crash: data text to columns
Summary: Crash: data text to columns
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: All All
: high critical
Assignee: Eike Rathke
URL:
Whiteboard: target:5.1.0 target:4.4.6 target:5.0....
Keywords: bibisected, bisected, haveBacktrace, regression
: 94168 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-11-06 23:31 UTC by stuart.jagger99
Modified: 2018-05-07 04:30 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
spread sheet , just before action to cause error (54.82 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-11-09 22:54 UTC, stuart.jagger99
Details
screen print of the text to column options (238.03 KB, application/vnd.oasis.opendocument.text)
2014-11-09 22:55 UTC, stuart.jagger99
Details
backtrace (7.80 KB, text/plain)
2014-11-11 18:13 UTC, raal
Details
bt with debug symbols (9.44 KB, text/plain)
2015-02-08 16:46 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description stuart.jagger99 2014-11-06 23:31:37 UTC
select 210 rows of a single column (f) the cells actually contained the trim function e.g cell f1 contains 
=trim(e1)
then i tried to split by selecting  'space'separator the module crashed with 'an unexpected error' message. and the recovery process started.

the data in cell e1 looked like " 23 45 56 76 "
and in  E2 "98 54 65 21"
I needed to have 23 AND 98 in column f,and  45 AND 54 in column g.
Comment 1 raal 2014-11-07 18:18:57 UTC Comment hidden (obsolete)
Comment 2 stuart.jagger99 2014-11-09 22:54:31 UTC
Created attachment 109177 [details]
spread sheet , just before action to cause error
Comment 3 stuart.jagger99 2014-11-09 22:55:19 UTC
Created attachment 109178 [details]
screen print of the text to column options
Comment 4 stuart.jagger99 2014-11-09 22:57:52 UTC
attached spread sheet just before action creating the issue. screen print of the text to column options selected
Comment 5 raal 2014-11-10 19:58:53 UTC
I can reproduce crash with Version: 4.4.0.0.alpha1+
Build ID: 04ea7b24ec1b5a027efa0b850f2bc3ac7116c52e
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2014-11-06_00:02:40
I can reproduce crash with version 4.2.7

I can not reproduce with LO 3.5, regression.
Comment 6 Xisco Faulí 2014-11-11 17:46:28 UTC
crash bibisected:

There are only 'skip'ped commits left to test.
The first bad commit could be any of:
ccbf29a52688534e5b3af5041c87e6eec9021a39
5c95a5c8caeeb347ef97f337a237d66c35261710
We cannot bisect more!

# bad: [423a84c4f7068853974887d98442bc2a2d0cc91b] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# good: [e02439a3d6297a1f5334fa558ddec5ef4212c574] source-hash-6b8393474974d2af7a2cb3c47b3d5c081b550bdb
git bisect good e02439a3d6297a1f5334fa558ddec5ef4212c574
# bad: [4850941efe43ae800be5c76e1102ab80ac2c085d] source-hash-980a6e552502f02f12c15bfb1c9f8e6269499f4b
git bisect bad 4850941efe43ae800be5c76e1102ab80ac2c085d
# skip: [a043626b542eb8314218d7439534dce2fc325304] source-hash-9379a922c07df3cdb7d567cc88dfaaa39ead3681
git bisect skip a043626b542eb8314218d7439534dce2fc325304
# skip: [aba65c3e4c0df07e4909aeefb758cdb688242bf6] source-hash-827524abfb4b577d08276fde40929a9adfb7ff1a
git bisect skip aba65c3e4c0df07e4909aeefb758cdb688242bf6
# skip: [aba65c3e4c0df07e4909aeefb758cdb688242bf6] source-hash-827524abfb4b577d08276fde40929a9adfb7ff1a
git bisect skip aba65c3e4c0df07e4909aeefb758cdb688242bf6
# bad: [c81a8a0dcfc1ed095a80e4485c89dd0fcaf73f31] source-hash-c69ed33628ec0b7abf6296539cf280d6c4265930
git bisect bad c81a8a0dcfc1ed095a80e4485c89dd0fcaf73f31
# bad: [c81a8a0dcfc1ed095a80e4485c89dd0fcaf73f31] source-hash-c69ed33628ec0b7abf6296539cf280d6c4265930
git bisect bad c81a8a0dcfc1ed095a80e4485c89dd0fcaf73f31
# good: [1d4980621741d3050a5fe61b247c157d769988f2] source-hash-89d01a7d8028ddb765e02c116d202a2435894217
git bisect good 1d4980621741d3050a5fe61b247c157d769988f2
# skip: [89110ca258fa7a15dfc546acfb39e76fc3eb2a44] source-hash-e450a2c506ac7cd4433b0f93fc750a89919bc03c
git bisect skip 89110ca258fa7a15dfc546acfb39e76fc3eb2a44
# good: [1cca92a409385d9288c28a54d5e3008e56728bc0] source-hash-7be7824bbbdeee6fa998b950e6046ab37fe690cb
git bisect good 1cca92a409385d9288c28a54d5e3008e56728bc0
# skip: [5fa28ce2931a35ae64ae08d3904cfb76d24459d8] source-hash-2304beaca33c63b94df99cb827716f00ce259f9a
git bisect skip 5fa28ce2931a35ae64ae08d3904cfb76d24459d8
# good: [2a9ff869c5638dc5c3aa387d0fe55c3291c86288] source-hash-01b7e04172889cbc9e4ac404b105e18ddc062d6f
git bisect good 2a9ff869c5638dc5c3aa387d0fe55c3291c86288
# good: [387dd1052972d27a3065a249b357e50e0a29829b] source-hash-35836f350861b33a0c28307a413eff76d0433d1e
git bisect good 387dd1052972d27a3065a249b357e50e0a29829b
# good: [387dd1052972d27a3065a249b357e50e0a29829b] source-hash-35836f350861b33a0c28307a413eff76d0433d1e
git bisect good 387dd1052972d27a3065a249b357e50e0a29829b
# bad: [09fe6d4400fefeaa099d0deb9b77c77992ab897b] source-hash-56364430108893afbcf5d2b51c5aaa37e393e7cc
git bisect bad 09fe6d4400fefeaa099d0deb9b77c77992ab897b
# bad: [09fe6d4400fefeaa099d0deb9b77c77992ab897b] source-hash-56364430108893afbcf5d2b51c5aaa37e393e7cc
git bisect bad 09fe6d4400fefeaa099d0deb9b77c77992ab897b
# bad: [5c95a5c8caeeb347ef97f337a237d66c35261710] source-hash-a6d89e17995987549db36695f3ea490a18f30ba4
git bisect bad 5c95a5c8caeeb347ef97f337a237d66c35261710
# bad: [5c95a5c8caeeb347ef97f337a237d66c35261710] source-hash-a6d89e17995987549db36695f3ea490a18f30ba4
git bisect bad 5c95a5c8caeeb347ef97f337a237d66c35261710
# good: [82c920939b3518277ba70c800018130ea9b027e7] source-hash-8f0ecf253531963144d3d1c9ee5c12a6cda99c4e
git bisect good 82c920939b3518277ba70c800018130ea9b027e7
# good: [82c920939b3518277ba70c800018130ea9b027e7] source-hash-8f0ecf253531963144d3d1c9ee5c12a6cda99c4e
git bisect good 82c920939b3518277ba70c800018130ea9b027e7
# skip: [ccbf29a52688534e5b3af5041c87e6eec9021a39] source-hash-97c62ed88419f7288ce1b365474c65038253608e
git bisect skip ccbf29a52688534e5b3af5041c87e6eec9021a39
# only skipped commits left to test
# possible first bad commit: [5c95a5c8caeeb347ef97f337a237d66c35261710] source-hash-a6d89e17995987549db36695f3ea490a18f30ba4
# possible first bad commit: [ccbf29a52688534e5b3af5041c87e6eec9021a39] source-hash-97c62ed88419f7288ce1b365474c65038253608e
Comment 7 raal 2014-11-11 18:13:58 UTC
Created attachment 109295 [details]
backtrace
Comment 8 Markus Mohrhard 2014-12-07 09:01:11 UTC
The problem here is the use of ScDocumentImport outside of the import code. I have an idea for a possible fix.
Comment 9 Julien Nabet 2015-02-08 16:46:25 UTC
Created attachment 113233 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated yesterday, I could reproduce this.
(I selected C1 to C5, then Text to Columns, unselected "Tab" and selected "Space")
Comment 10 Julien Nabet 2015-02-08 16:47:55 UTC
Increase the importance since crash + regression
Comment 11 Markus Mohrhard 2015-03-27 22:34:20 UTC
Fixed by bf97980c8d5d5fbc63a08b8834c10fe903152b75
Comment 12 raal 2015-03-28 05:32:10 UTC
Still crash  with Version: 4.5.0.0.alpha0+
Build ID: 28c61871e876e6a2cac47439f768504b1a4c94a0
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-03-27_06:30:21

Setting back to new.
Comment 13 Matthew Francis 2015-09-06 05:43:34 UTC
Still present on recent 5.1 master. This was originally introduced by:

commit 93959db4d8846cfdfb87ab647c4d457fb09bb869
Author: Markus Mohrhard <markus.mohrhard@googlemail.com>
Date:   Tue Oct 29 02:31:22 2013 +0100

    use DocumentImport for csv import, related fdo#69006
    
    Change-Id: Ib904510b6e897feb787497a4c8ff4204387cf6a4
Comment 14 Julien Nabet 2015-09-13 14:23:27 UTC
*** Bug 94168 has been marked as a duplicate of this bug. ***
Comment 15 Julien Nabet 2015-09-13 15:48:53 UTC
Eike: thought you might be interested in this one.
Comment 16 Eike Rathke 2015-09-17 14:55:07 UTC
Taking.
Comment 17 Commit Notification 2015-09-17 15:16:23 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=624ab2e5a52e9b8aa139bae4cd1436d23b80bf8c

Resolves: tdf#85979 TextToColumns is overwriting, so set at ScImportExport

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 18 Eike Rathke 2015-09-17 15:49:28 UTC
Pending review
https://gerrit.libreoffice.org/18664 for 5-0
https://gerrit.libreoffice.org/18665 for 5-0-2
https://gerrit.libreoffice.org/18666 for 4-4
Comment 19 Julien Nabet 2015-09-17 18:34:56 UTC
Eike: I don't reproduce the crash neither for this one, nor for tdf#94168
But tdf#94168 gives strange results:
Initial state : A1 empty, A2, A3, ... A30 equal "=1"
If I select column A, then "text to columns", select column in Dialog then Text (instead of Standard), A1 until A29 contain 1 in text format, A30 contain 1 in number format.
Side effect of the fix or should I open a new bugtracker?
Comment 20 Eike Rathke 2015-09-17 19:37:20 UTC
@Julien:
That's something different. It's not even necessarily a bug, you get what you ask for ;-) Note that if you select the entire column (or A1:A30 for that matter) insertion of data starts at the top left selected cell, here A1. But data starts at A2. What effectively happens is the data from A2:A30 overwrites A1:A29 and A30 stays untouched. Note that with the original description of bug 94168 it is not a number 1 but a formula =1 and that is left intact.

It is debatable whether leading blank cells should be included in the transformation or not. Maybe they should.
Comment 21 Julien Nabet 2015-09-17 19:39:04 UTC
Ok then :-)
Comment 22 Commit Notification 2015-09-27 09:19:51 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b37eda64cfdad7d60319b08fc8307a2237a724f6&h=libreoffice-4-4

Resolves: tdf#85979 TextToColumns is overwriting, so set at ScImportExport

It will be available in 4.4.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 23 Commit Notification 2015-09-27 20:14:06 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=00adc13618d7957da43318a69559da82fbbb53a7&h=libreoffice-5-0

Resolves: tdf#85979 TextToColumns is overwriting, so set at ScImportExport

It will be available in 5.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 24 Robinson Tryon (qubit) 2015-12-17 08:38:51 UTC Comment hidden (obsolete)
Comment 25 Commit Notification 2018-05-07 04:30:52 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a019ee36a37f3761d5ba2e90973c6a9cbc9399c9

uitest for bug tdf#85979

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.