Bug Hunting Session
Bug 85984 - View selection / web layout/ print layout - not clearly indicated
Summary: View selection / web layout/ print layout - not clearly indicated
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Web-Layout
  Show dependency treegraph
 
Reported: 2014-11-07 02:38 UTC by Karl Schmidt
Modified: 2016-10-17 22:19 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
print mode selected - can you tell? (5.02 KB, image/png)
2014-11-07 02:38 UTC, Karl Schmidt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Karl Schmidt 2014-11-07 02:38:51 UTC
Created attachment 109072 [details]
print mode selected - can you tell?

This appears to have been reported before in 39511 - but perhaps not well communicated. 39511 should be reopened. 

Under View/Print layout  or View/Web layout - both do the same thing. They toggle between each other. The GUI interface fails to clearly show which mode one is in - I did not realize the view mode was indicated at all until I was detailing this bug. This is because there is a a very faint out-line that can hardly be seen around the icon in the view menu - thus the confusion I see in several bug reports. Could be OS or desktop dependent? 

I've attached screen shots - this probably effects other settings as well.  Fixing the selected icon display will greatly improve the value of the bug reports. 


(for the record running KDE on a Debian box)

- this detail provides context to many of the bug reports about view selection.

I have caused documents to become modified by changing the view - anchors shift. Do not shift back. I was hoping to find information in the bug reports, but because the mode status is not clear - the bug reports are not useful. 

The first step in fixing this is to provide a better indication of which mode one is in. 

The documentation is also wrong it states:
"Changing document views
Writer has three ways to view a document: Print Layout, Web Layout, and Full Screen. To change the view, go to the View menu and click on the required view."

This is not correct - there are 4 modes: web, print, web-fullscreen, print-fullscreen.
Comment 1 A (Andy) 2014-11-08 12:09:47 UTC
For me not reproducible with LO 4.3.3.2, Win 8.1.

As mentioned in https://help.libreoffice.org/Writer/View "Print Layout" displays how the document looks when you would print it and "Web Layout" displays the document as seen in a Web browser.  For me it is shown as expected.  The current selected view is also shown in the menu with a blue square around (as expected).
Is this therefore maybe a Linux only issue?

Regarding the second documentation issue: There are three basic view options with "Print Layout", "Web Layout" and "Full Screen".  But the full screen is only a mode of the "Print Layout" and "Web Layout".
The text you mentioned is taken from the "Writer Guide 4.0" from Smith et. al on page 25?  If yes, I don't think this is a mistake, because if you go a few paragraphs down you get the information "In Full Screen view, the document is displayed using the zoom and layout settings previously selected" and this could be the Print or Web Layout and is therefore from my point of view correct.
Comment 2 sophie 2014-11-27 15:47:53 UTC
Hi, the workaround for you is to not display icons in the menus, you'll have a check in front of the chosen option. I have this issue sometime depending on the Gnome theme I use. Sophie
Comment 3 Karl Schmidt 2014-11-27 18:47:49 UTC
@Andy 

Non the less, the text is still factually wrong and not well written - If you give me an email, the link to the current text, I can rewrite it so it is clear - I write documentation for a living. 

@Sophie 
Thanks - (not finding where to set such an option?)  Still important to fix the underlying issue as it is generating useless bug reports.
Comment 4 sophie 2014-12-01 15:05:51 UTC
Hi, to remove the icons go to Tools > Options > View > Menu area and select Hide in the drop down list in front of Icons in Menu. 
Reading the description of bug #39511, I set this one to New and Enhancement - Sophie