Bug Hunting Session
Bug 85995 - LibreOffice Spreadsheet Crashes when I delete multiple tabs at the same time.
Summary: LibreOffice Spreadsheet Crashes when I delete multiple tabs at the same time.
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-07 06:28 UTC by klsu
Modified: 2015-06-10 05:28 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description klsu 2014-11-07 06:28:32 UTC
If I select 4 sheets in a 19 sheet workbook, right click and select Delete Sheet... and then select YES, Calc crashes. I have no idea what the limits are, because if I manually delete all sheets singly until there are only 4 sheets left and then try to delete 2 simultaneously, they are deleted without a crash.
Comment 1 klsu 2014-11-07 14:42:46 UTC
Update, I cannot consistently reproduce this problem, except on the original unchanged workbook. If I manually delete 14 sheets, and try to reproduce the problem using the resulting 5 sheet workbook, sometimes it crashes, sometimes it doesn't, even doing exactly the same thing on the same, unchanged 5 sheet workbook. I suspect the problem may have something to do with how Calc handles deleting worksheets when there are references to other workbooks or macros in the document, regardless of whether those references involve any of the sheets left in the workbook.

So, there is clearly a bug, but it may have to remain until something reproducible shows up.
Comment 2 Julien Nabet 2014-11-08 16:26:35 UTC
On which env are you? (Windows, Linux, MacOs)
Could you give a try to last stable LO version 4.3.3?
Comment 3 QA Administrators 2015-06-08 14:29:07 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least
6 months. Please provide the requested information as soon as
possible and mark the bug as UNCONFIRMED. Due to regular bug
tracker maintenance, if the bug is still in NEEDINFO status with
no change in 30 days the QA team will close the bug as INVALID
due to lack of needed information.

For more information about our NEEDINFO policy please read the
wiki located here:
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Status/NEEDINFO

If you have already provided the requested information, please
mark the bug as UNCONFIRMED so that the QA team knows that the
bug is ready to be confirmed.
 
Thank you for helping us make LibreOffice even better for everyone!

This NEEDINFO Message was generated on: 2015-06-08

Warm Regards,
QA Team
Comment 4 klsu 2015-06-09 23:14:05 UTC
Sorry, I apparently didn't get an email telling me there was a question. I am using Linux. At the time that I found the bug, I was running Mint Petra; however, having no use for a Linux that cannot but upgraded to a new distribution, I switched to Xubuntu. I think the problem occurred in the last LTS version of LO Calc before Version 4.4.2.2.

Unfortunately, during the first few hours of trying LO Calc, I discovered (MOD() and DATE()) bugs that result in random incorrect answers caused by improper handling of significant digits. When I reported them, I was informed that these functions require the user to make sure the input to the functions are of a specific format, and that they are therefore not bugs. This means that I must read about the limitations of every function use and keep notes I can refer to every time I want to use a function. Since computers are supposed to work for users, and not users for computers, this is unacceptable.

In addition, in certain professions, random incorrect answers are worse than crashes or not having the functions at all, because lives or property could be lost. For this reason, I see no reason to bother with LibreOffice Calc for serious work. Excel doesn't have these problems. Too bad everyone working on Linux wants to have their own version instead of making one version that works correctly.

You might as well close this bug and wait for someone who is forced to use LibreOffice Calc to find it. I cannot afford to spend time helping programmers fix something that I can't use.