Bug Hunting Session
Bug 86013 - strange symbols replaced brackets and other signs in formula (4.3.3.2)
Summary: strange symbols replaced brackets and other signs in formula (4.3.3.2)
Status: RESOLVED DUPLICATE of bug 76239
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
4.3.3.1 rc
Hardware: x86 (IA32) Windows (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 86014 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-11-07 17:32 UTC by respirorosso
Modified: 2014-11-08 17:25 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
the messed up formula examples page (8.64 KB, image/png)
2014-11-07 17:32 UTC, respirorosso
Details
a messed up formula (4.26 KB, image/png)
2014-11-07 18:06 UTC, respirorosso
Details
the difference at first sight (100.01 KB, image/jpeg)
2014-11-07 18:13 UTC, respirorosso
Details
odf formula file with examples of wrong characters (14.93 KB, application/vnd.oasis.opendocument.formula)
2014-11-08 08:11 UTC, respirorosso
Details

Note You need to log in before you can comment on or make changes to this bug.
Description respirorosso 2014-11-07 17:32:54 UTC
Created attachment 109097 [details]
the messed up formula examples page

Problem description: 

(actually version 4.3.3.2 but not listed, so I selected 4.3.3.1 rc)

the formula rendering now shows strange symbols instead of brackets and other signs. I made a screenshot

Steps to reproduce:
1. open new formula document.

Current behavior:
letter icon instead of +
mailbox icon instead of /
arrows instead of multiplication and division
telephone icons instead of brackets () 
...
and so on


Expected behavior:
you got the idea. see the screenshot.
Comment 1 Julien Nabet 2014-11-07 17:56:38 UTC
*** Bug 86014 has been marked as a duplicate of this bug. ***
Comment 2 Julien Nabet 2014-11-07 17:58:06 UTC
Would it be possible you attach the original file so we can reproduce quickly the problem by using this link https://bugs.freedesktop.org/attachment.cgi?bugid=86013&action=enter?
(have in mind that any attachment is automatically made public so remove any confidential/private part).
Comment 3 respirorosso 2014-11-07 18:05:17 UTC
what do you mean by "original file"?

open a new formula document with libreoffice 4.3.3.2 and look at the "Elements Dock", 

you will see like the png image I have attached to this report, else it would be strange..
Comment 4 respirorosso 2014-11-07 18:06:30 UTC
Created attachment 109102 [details]
a messed up formula
Comment 5 respirorosso 2014-11-07 18:13:46 UTC
Created attachment 109103 [details]
the difference at first sight
Comment 6 Regina Henschel 2014-11-07 22:58:30 UTC
Please tell us your operating system. And in case of a Linux system, what distribution and whether you have got LibreOffice via this distribution.

It looks as if a wrong font is used. Please write a formula in a pure formula document (.odf), which shows this wrong characters and attach the file here. While writing the formula look into Format > Fonts which fonts are listed there and add that information. Please look, whether these fonts are actually installed on your PC.
Comment 7 Urmas 2014-11-08 01:08:56 UTC
Do you have the "OpenSymbol" font installed?
Comment 8 respirorosso 2014-11-08 08:11:45 UTC
Created attachment 109125 [details]
odf formula file with examples of wrong characters
Comment 9 respirorosso 2014-11-08 08:13:19 UTC
OS: Windows 7 64bit

FONT: Cambria. But I tried various others. They are installed. 

Note that the screenshot "the difference at first sight" is made with LibreOfficePortable 4.3.2.2 on the left, and LibreOffice 4.3.3.2 on the right, on the same operating system.
Comment 10 respirorosso 2014-11-08 08:19:44 UTC
Problem apparently solved: i have installed the "OpenSymbol" font, now the formulas in all my odt documents are rendered correctly.

Thanks Urmas!
Comment 11 Julien Nabet 2014-11-08 09:20:21 UTC
respirosso: great your problem is solved! :-)

Andras: could OpenSymbol be included in LO package or could it be a prerequisite for Windows install?
Comment 12 Maxim Monastirsky 2014-11-08 17:25:19 UTC

*** This bug has been marked as a duplicate of bug 76239 ***