Bug 86040 - SIDEBAR: Renaming 'Gallery' to 'Clip Art Gallery' in tooltip and pane title
Summary: SIDEBAR: Renaming 'Gallery' to 'Clip Art Gallery' in tooltip and pane title
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha1
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:4.4.0
Keywords:
Depends on:
Blocks: Gallery
  Show dependency treegraph
 
Reported: 2014-11-08 18:07 UTC by Yousuf Philips (jay) (retired)
Modified: 2016-10-24 12:17 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-11-08 18:07:44 UTC
Gallery was changed to Clip Art Gallery in the menu, so it would be good to also change it in the sidebar.
Comment 1 Julien Nabet 2014-11-08 23:21:23 UTC
With this, it's ok:
diff --git a/officecfg/registry/data/org/openoffice/Office/UI/Sidebar.xcu b/officecfg/registry/data/org/openoffice/Office/UI/Sidebar.xcu
index 0b3cf4d..9874dcb 100644
--- a/officecfg/registry/data/org/openoffice/Office/UI/Sidebar.xcu
+++ b/officecfg/registry/data/org/openoffice/Office/UI/Sidebar.xcu
@@ -43,7 +43,7 @@
 
       <node oor:name="GalleryDeck" oor:op="replace">
         <prop oor:name="Title" oor:type="xs:string">
-          <value xml:lang="en-US">Gallery</value>
+          <value xml:lang="en-US">Clip Art Gallery</value>
         </prop>
         <prop oor:name="Id" oor:type="xs:string">
           <value>GalleryDeck</value>

But there's also this one:
    374       <node oor:name="GalleryPanel" oor:op="replace">
    375         <prop oor:name="Title" oor:type="xs:string">
    376           <value xml:lang="en-US">Gallery</value>
    377         </prop>

Should both be replaced?
Comment 2 Yousuf Philips (jay) (retired) 2014-11-09 02:20:24 UTC
Yes i believe both do need to be replaced.
Comment 3 Julien Nabet 2014-11-09 07:57:55 UTC
Thank you for your feedback.
Comment 4 Commit Notification 2014-11-09 07:59:33 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=393ef5c8800835fdefb81bc0062ab30cd1bba140

Resolves fdo#86040 Renaming 'Gallery' to 'Clip Art Gallery'

It will be available in 4.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Yousuf Philips (jay) (retired) 2014-11-09 16:55:07 UTC
Thinking about this more, i think this might not have been the correct idea, as the gallery does include more than just clip art, like sound clips as well.
Comment 6 Julien Nabet 2014-11-09 17:01:37 UTC
I thought you had talked about this with ux team...

However if it's wrong, just open a brand new bug and try to discuss with ux team this time :-)
Comment 7 Yousuf Philips (jay) (retired) 2014-11-09 17:45:55 UTC
Will do. Sorry about that. I will change it back if so. :D
Comment 8 Commit Notification 2014-11-18 09:30:29 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=18db9ba9891df7c909dc1f67bbfe9ef25620f816

revert change made in fdo#86040 as agreed on by design team

It will be available in 4.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Adolfo Jayme 2014-11-18 10:19:47 UTC
(In reply to Jay Philips from comment #5)
> Thinking about this more, i think this might not have been the correct idea,
> as the gallery does include more than just clip art, like sound clips as
> well.

-_-