Bug 86124 - FORMATTING: Double-click background colour should close formatting dialog
Summary: FORMATTING: Double-click background colour should close formatting dialog
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.2.2 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Area-Fill-Tab
  Show dependency treegraph
 
Reported: 2014-11-10 18:55 UTC by Francis
Modified: 2021-06-28 14:08 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Francis 2014-11-10 18:55:13 UTC
Problem description: Double-clicking a background colour in the Format dialog should automatically close the dialog

Steps to reproduce:
1. Highlight some text
2. Click Format > Character
3. Click Background tab
4. Double-click a colour

Current behavior: The dialog does not automatically close

Expected behavior: The dialog should automatically close
Comment 1 Alex Thurgood 2014-11-12 10:19:55 UTC
Confirming the behaviour on

Version: 4.4.0.0.alpha2+
Build ID: 269b0b40814defe0241e8c79c1834e488ea13bc5


However, this is the default behaviour with LibreOffice.

Is the behaviour you desire the default in other applications ? At best, this might be a request for enhancement.
Comment 2 Francis 2014-11-12 14:02:06 UTC
Thanks very much for your reply.

First, let me say I'm a huge fan of LibreOffice. With recent versions it's become a really good piece of software.

This was just something that bugged me slightly when using Writer to create a document just recently. I was doing a lot of highlighting text and changing the background over and over, and the extra click was slowing down the process a lot. It would feel a lot more natural (in my opinion!) and certainly speed up my particular use-case if a double-click would close the dialog.

What's more, at the moment a double-click does nothing (right?) So adding this behaviour just for a double-click shouldn't conflict with current usage patterns.

I've changed this to an enhancement request - thanks again, keep up the great work!
Comment 3 Alex Thurgood 2014-11-12 14:48:51 UTC
Seems fair enough to me, but I'm only a QA triager ;-)
Confirming request for enhancement.
Comment 4 Thomas Lendo 2018-10-04 11:45:07 UTC
Adding needsUXEval to discuss that.

Is 'Mac OS X' intended or should this changed to 'All' OS?

I find it an interesting enhancement request and I would expand it to all area fill tab options (color, gradient, bitmap, pattern, hatch) and not only color. Double-clicking at a selected color/bitmap/hatch/... field should select and activate that fill option and close the whole dialog instead of clicking 'OK' so that the user can continue to work smoothly.

The problem I see is:
- That's a behavior that is not available in other dialogs.
- Many people don't make a distinction between single and double click. (I often see people double-clicking at symbols and menu items although a single click would be sufficient. These people will maybe surprised that the dialog has closed.)
Comment 5 Heiko Tietze 2021-06-28 11:28:43 UTC
(In reply to Thomas Lendo from comment #4)
> I find it an interesting enhancement request and I would expand it to all
> area fill tab options...

That's my point of voting for WF. It's not just the area tab but also other attributes. And what if the user wants to set many attributes such as weight, size, position, and color. You always have to reopen the dialog, which is much more annoying than one click on Okay.
Comment 6 Francis 2021-06-28 11:46:58 UTC
(In reply to Heiko Tietze from comment #5)
> (In reply to Thomas Lendo from comment #4)
> > I find it an interesting enhancement request and I would expand it to all
> > area fill tab options...
> 
> That's my point of voting for WF. It's not just the area tab but also other
> attributes. And what if the user wants to set many attributes such as
> weight, size, position, and color. You always have to reopen the dialog,
> which is much more annoying than one click on Okay.

A single-click on a colour would not close the dialog, allowing the user to continue choosing weight, size, position etc.

This enhancement request only applies to a double-click on a colour.
Comment 7 Heiko Tietze 2021-06-28 14:08:55 UTC
(In reply to Francis from comment #6)
> A single-click on a colour would not close the dialog, allowing the user to
> continue choosing weight, size, position etc.
> 
> This enhancement request only applies to a double-click on a colour.

Hm, this solve one of my concerns. But you save one click by cost of inconsistency. Users would expect this hidden feature everywhere a simple selection is the goal. 

Feel free to reopen if you disagree, I wont close those tickets again.