Bug 86176 - Inserted image gets the wrong PPI
Summary: Inserted image gets the wrong PPI
Status: RESOLVED DUPLICATE of bug 107703
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Images
  Show dependency treegraph
 
Reported: 2014-11-12 01:21 UTC by sworddragon2
Modified: 2017-05-30 19:45 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Test image (681 bytes, image/png)
2014-11-12 01:21 UTC, sworddragon2
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sworddragon2 2014-11-12 01:21:11 UTC
Created attachment 109311 [details]
Test image

I have noticed that inserted images are looking sometimes pixelated on their borders and on analyzing this it seems some images are getting always the wrong PPI on inserting while others are getting always the correct PPI on inserting. In the attachments is an image that gets on my system always the wrong PPI. Here are the reproduction steps:

1. Start Writer and set the zoom level to 100%.
2. Go to the menu bar -> Insert -> Image -> "From File..." and choose the test image.
3. On comparing the inserted image with the original image (for example in an image viewer with a zoom level of 100%) the inserted image looks bigger. Also the borders are looking really pixelated likely due to upscaling.
4. Make a right clik on the image and go to Picture... -> Crop.
5. The image shows 72 PPI but probably it should be 96 PPI.
Comment 1 Buovjaga 2014-11-16 19:43:43 UTC
I see what you mean, but in Irfanview, the DPI info is 72 as well. If I open the .png in GIMP, it is totally transparent.
Where did the image come from?
Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the information.

Win 7 64-bit Version: 4.4.0.0.alpha2+
Build ID: b021b5983c62e266b82d9f0c5c6d8d8900553827
TinderBox: Win-x86@39, Branch:master, Time: 2014-11-12_01:10:08
Comment 2 sworddragon2 2014-11-17 04:21:23 UTC
> If I open the .png in GIMP, it is totally transparent.

This is probably a bug in GIMP: https://bugzilla.gnome.org/show_bug.cgi?id=740234


> Where did the image come from?

It was created with GIMP and optimized with OptiPNG.


But maybe the PPI isn't wrong and just another error occured but I can't say it. Also this is not the only image there I'm seeing this issue. If somebody wants to try to reproduce this:

1. Open GIMP.
2. Go to the menu bar -> File -> New..., select a width and height of 100px and click on OK.
3. Select the "Ellipse Select Tool".
4. Select the complete image with it.
5. Select the "Bucket Fill Tool".
6. Choose any color for example blue.
7. Set the opacity to 50.
8. Go to the menu bar -> File -> "Export As...".
9. Click "Export" and then again "Export".
10. Continue with the steps from the startpost.
Comment 3 Robinson Tryon (qubit) 2015-01-03 20:24:33 UTC
TESTING with LO 4.4.0.1 on Ubuntu 14.04

(In reply to sworddragon2 from comment #0)
> wrong PPI. Here are the reproduction steps:
> 
> 1. Start Writer and set the zoom level to 100%.
> 2. Go to the menu bar -> Insert -> Image -> "From File..." and choose the
> test image (attachment 109311 [details]).
> 3. On comparing the inserted image with the original image (for example in
> an image viewer with a zoom level of 100%) the inserted image looks bigger.
> Also the borders are looking really pixelated likely due to upscaling.

CONFIRMED: jaggy edges here, and larger physically than it appears in Firefox 34.0

> 4. Make a right clik on the image and go to Picture... -> Crop.
> 5. The image shows 72 PPI but probably it should be 96 PPI.

CONFIRMED: PPI is 72

Status -> NEW

(In reply to sworddragon2 from comment #2)
> https://bugzilla.gnome.org/show_bug.cgi?id=740234

From that bug report:
"This is an indexed file with an alpha channel. GIMP doesn't support this yet.
If you switch the image mode to RGB, it should show up as intended."

So maybe LibreOffice is having problems with an indexed file + alpha channel as well?
Comment 4 QA Administrators 2016-01-17 20:05:12 UTC Comment hidden (obsolete)
Comment 5 QA Administrators 2017-03-06 14:37:06 UTC Comment hidden (obsolete)
Comment 6 Yousuf Philips (jay) (retired) 2017-05-30 19:45:59 UTC

*** This bug has been marked as a duplicate of bug 107703 ***