Download it now!
Bug 86307 - is SOLARIS workaround #i64273# in vcl/unx/generic/app/wmadaptor.cxx still necessary?
Summary: is SOLARIS workaround #i64273# in vcl/unx/generic/app/wmadaptor.cxx still ne...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.3.2.2 release
Hardware: x86 (IA32) Solaris
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:4.4.0
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-15 06:07 UTC by Richard PALO
Modified: 2014-11-16 09:36 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Richard PALO 2014-11-15 06:07:31 UTC
I've been running some time now with this patch effectivly bypassing the workaround cited in the subject line:

--- vcl/unx/generic/app/wmadaptor.cxx.orig	2014-01-27 21:35:34.000000000 +0
000
+++ vcl/unx/generic/app/wmadaptor.cxx
@@ -999,7 +999,7 @@ void WMAdaptor::setWMName( X11SalFrame*
     }
 
     static bool bTrustXmb = true;
-    #ifdef SOLARIS
+    #ifdef xSOLARIS
     /* #i64273# there are some weird cases when using IIIMP on Solaris
     *  where for unknown reasons XmbTextListToTextProperty results in
     *  garbage. Test one string once to ensure safety.


perhaps justification should be found to keep this around.
Comment 1 Julien Nabet 2014-11-15 23:51:15 UTC
After running "git log --follow -S '64273' vcl/unx/generic/app/wmadaptor.cxx, I just had this:

commit bce2500b5bc06296f106f758e221efc08a36305f
Author: Rüdiger Timm <rt@openoffice.org>
Date:   Fri May 5 08:04:05 2006 +0000

    INTEGRATION: CWS vcl57 (1.59.116); FILE MERGED
    2006/04/12 16:59:47 pl 1.59.116.2: #i64273# workaround a weird XmbTextListToTextProperty problem
    2006/03/29 14:01:22 pl 1.59.116.1: #i62139# workaround tarantella problem

but git history begins only with 5d463c719bb2881d63da68d0752e4086c265876d, 2011-01-24.

Caolan/Chris: since there's no SOLARIS expert quoted here: https://wiki.documentfoundation.org/FindTheExpert, I thought you might give some hints as vcl expert.

Meanwhile putting at NEW, since this block is indeed present in master sources.
Comment 2 Chris Sherlock 2014-11-16 08:05:26 UTC
It was a bug found in 2006 on Solaris only when using IIIMP - the coder seems to be running some sort of test, but not sure why because he says he couldn't reproduce the issue!

Without seeing what's going on, hard to tell. 

https://issues.apache.org/ooo/show_bug.cgi?id=64273

Does anyone have a Solaris network computer that uses IIIMP? Are we at all concerned?
Comment 3 Chris Sherlock 2014-11-16 08:37:24 UTC
I'm pretty certain this was spotted before then also:

https://issues.apache.org/ooo/show_bug.cgi?id=6759

An example of what it looks like is here:

https://issues.apache.org/ooo/attachment.cgi?id=2436
Comment 4 Chris Sherlock 2014-11-16 08:58:23 UTC
There are a few places that I think shows we don't need this:

Commit by Caolan: "ditch obsolete XvaOpenIM stuff"

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4d6dab2cde759551ceee7e6aaec89fa5235b1ecc

and then later:

"These multi-lingual IMs have been always disabled for Linux

Where not-Linux was in practice solaris. We can be pretty sure that the
ismultlingual path is effectively unused. so following that chain of logic
quite a bit can go."

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8b0287543d87659fd4bfde5edb6725ee5da5f80e
Comment 5 Commit Notification 2014-11-16 09:33:54 UTC
Chris Sherlock committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=29dd297739405eb1e2c6217795ca1bce3ac4f952

vcl: fdo#86307 removed Solaris workaround from #i64273#

It will be available in 4.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Chris Sherlock 2014-11-16 09:36:45 UTC
I've removed the obsolete/pointless code. Thanks for reporting this Richard.