Bug 86404 - use Ctrl+TAB to switch between tabs/sheets
Summary: use Ctrl+TAB to switch between tabs/sheets
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Heiko Tietze
URL:
Whiteboard: target:6.1.0
Keywords:
Depends on:
Blocks: Sheet-Tabs-Bar
  Show dependency treegraph
 
Reported: 2014-11-17 18:14 UTC by Magalaan
Modified: 2018-09-16 16:54 UTC (History)
12 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Magalaan 2014-11-17 18:14:25 UTC
use Ctrl+TAB to switch between tabs/sheets

When using Calc with multiple sheets I often switch between sheets to check results. For instance switch between a week/month/year and a total sheet, or between a data and graph sheet. Or sometimes to repeatedly copy content fromn one sheet to another. 

Crl+TAB would allow to quickly go to the last used tab/sheet (and back), in a similar way as Alt+TAB switches between applications. 

At this moment: 
there is no function to switch to last used sheet/tab. 
Nor can the TAB-key be assigned to any function or Macro
CTRL+TAB is used in dialop Windows as next tab key

I think switching to last tab is a very natural use of Ctrl+TAB in programs withj tabs. In firefox it is now built in though not yet activated by default. (goto about:config, search: "ctrl", Double-click browser.ctrlTab.previews to set its value to true). The advantage of Ctrl+Tab is you can easily operate it with one hand, without letting go of the mouse. 


A VARIATION: 
Ctrl+TAB switches between last used Libre documents, or between last used tab sheets within a Libre document, whatever was done last. 

(In Libre Office there are no keys to switch documents at the time. But you can switch to another LO document with the Window-menu.) 

A slight limitation is this would not work within a writer table as ctrl+tab is used in tables to insert a tabspace (use ctrl+shift+tab here instead). Stil it is nice to be able to switch between libre documents independently of Alt+Tab which was originally meant for switching applications not documents. In an OS like Ubuntu it is somewhat cumbersome to get it to switch between documents as it has not taskbar and Alt+tab swithes to the next application rahter than the next document. 

If LO ever goes to implement document tabs like Lotus Symphony (I love those) this would be even more logical.
Comment 1 Cor Nouws 2014-11-17 18:52:54 UTC
(In reply to Magalaan from comment #0)
> use Ctrl+TAB to switch between tabs/sheets

Hi Magalaan,
pls try Ctrl+PgUp/Down :)
Cor
Comment 2 Magalaan 2014-11-20 01:01:51 UTC
Hi Cor, 

I think I have not made myself sufficiently clear. I am well aware of ctr+pgup/pgdn. (I am a MS office Professional) But that will only do if two sheet are next to each other. In Firefox too you can also use these keys to go up and down the chain of tabs. But often the tabs/sheets are not adjacent. So ctrl-pgup/pgdn do not work well. 

With ctrl+tab you can change between tabs thoughtlessly using one and the same key. I use it all the time in the Firefox, and it is a delight. In MS-Office I write some code in spreadsheets to do the same.

I think small changes like this one could give LO some edge over MSO. LO needs USP's of her own, otherwise it will always fall short in direct comparison with MSO. There is still plenty of room for improvement upon MSO. Lots of great features in Lotus for Windows were never adopted by MS after they won the Market. I know because I used to teach all these programs. 

And I wonder what is the point in asking suggestions if they are shot down that easily? Don't you have a system for collecting them and evaluating them groupwise? If you regard it more as a nuisance please say so.
Comment 3 Cor Nouws 2014-11-20 09:51:35 UTC
Hi Magalaan,

(In reply to Magalaan from comment #2)

> I think I have not made myself sufficiently clear. I am well aware of

Apparently yes :) Sorry that I didn't read that from your text.
Still I do not really get the difference with the current keys.
It's just that you can use the TAB key that one may be used to because of using Alt+Tab?

(Note that Ctrl+Tab is used to cycle through various text autofil choices when entering data. But I guess codewise it's no problem to serve both.)

Cheers,
Cor
Comment 4 Magalaan 2014-11-24 01:23:34 UTC
Hi Cor,

The advantage may mot be evident if you work with a fewer tab spreadsheets. But I often work with spreatsheets with losts of tabs for weeks, months, customers, emplyees, costs, etc that are totalized in another sheet. Then you are constantly shifting, making changes and checking the result. Try ctrl+PgUp/PgDn if you have fifty or so tabs and need to go forward and backward between two sheets, then the advantage will quickly become apparent. 

I think this should not be underestimated. The spreadsheet is something of a workhorse especially in smaller companies in which people stuff a lot of data that they might better put in a real database, but they do not know how to create databases, but they do know spreadsheets.
Comment 5 Buovjaga 2014-11-27 13:07:53 UTC
Should be UNCONFIRMED as information was provided.
Comment 6 Robinson Tryon (qubit) 2014-12-21 17:51:02 UTC
One for the UX Team...
Comment 7 Cor Nouws 2014-12-21 18:57:04 UTC
Anyone willing to work on this, pls note:

(In reply to Cor Nouws from comment #3)

> (Note that Ctrl+Tab is used to cycle through various text autofil choices
> when entering data. But I guess codewise it's no problem to serve both.)
Comment 8 Alex Thurgood 2015-01-03 17:40:07 UTC Comment hidden (no-value)
Comment 9 Robinson Tryon (qubit) 2016-08-25 04:21:34 UTC Comment hidden (obsolete)
Comment 10 Heiko Tietze 2017-11-07 12:58:04 UTC
The change request relevant without any doubt. Default shortcut to switch between tabs is ctr+tab. And users obviously comprehend sheets as tabs.

Guess it's a very simple change in officecfg/registry/data/org/openoffice/Office/ 

Should work for JumpToPrevTable as well as JumpToNextTableSel (Edit > Select > Select to next/previous sheet)- including shift in this case.
Comment 11 Cor Nouws 2017-11-29 10:44:49 UTC
(In reply to Heiko Tietze from comment #10)
> The change request relevant without any doubt. Default shortcut to switch
> between tabs is ctr+tab. And users obviously comprehend sheets as tabs.


Ctrl+PageUp/PageDown is the current shortcut.

No direct objection against Ctrl+Tab, but mind it is used in edit mode of a cell: when multiple auto-complete options are available, Ctrl+Tab goes from one to another.

Incidentally I was thinking about this subject some days ago.
In the Browser, Alt+1 ... 8 opens the respective tab page, and Alt+9 the last one. Not fully similar to the request, but maybe nice too?
Comment 12 Magalaan 2017-11-30 20:11:13 UTC
(In reply to Cor Nouws from comment #11)
> (In reply to Heiko Tietze from comment #10)
> > The change request relevant without any doubt. Default shortcut to switch
> > between tabs is ctr+tab. And users obviously comprehend sheets as tabs.
> 
> 
> Ctrl+PageUp/PageDown is the current shortcut.
> 
> No direct objection against Ctrl+Tab, but mind it is used in edit mode of a
> cell: when multiple auto-complete options are available, Ctrl+Tab goes from
> one to another.
> 
> Incidentally I was thinking about this subject some days ago.
> In the Browser, Alt+1 ... 8 opens the respective tab page, and Alt+9 the
> last one. Not fully similar to the request, but maybe nice too?

Frankly I never use Alt+1 ... 8 in the browser. Why? because you have to pause and think what number the tab is. You simply do not do that. 

Also it does not solve the problem. We need Ctrl+TAB most when we have lots of sheets. For me that is daily practice. I have sheets with products, weeks, clients etc that can be up to a hundred tabs. I want to be able to switch quickly between a particular week, product, client and another sheet. This can be total sheet, but also related sheet, that you are copying from. 

Now it is really cumbersome. You have browse through the tabs as the tab you want to go is often not visible. 

Ctrl+Tab is all I need.
Comment 13 Heiko Tietze 2017-11-30 22:03:29 UTC
(In reply to Magalaan from comment #12)
> Now it is really cumbersome. You have browse through the tabs as the tab you
> want to go is often not visible. 

You are likely aware of the shortcut that we have today, ctrl+page up/down. The annoyance here is that you have to move your fingers to an unusual place, like grabbing the mouse in other cases. Ctr+tab is just a few millimeter away from the resting position. And it's standard.
Comment 14 Alex Thurgood 2017-12-01 10:09:38 UTC Comment hidden (obsolete)
Comment 15 Alex Thurgood 2017-12-01 10:16:31 UTC Comment hidden (obsolete)
Comment 16 Alex Thurgood 2017-12-01 10:20:38 UTC
(In reply to Cor Nouws from comment #7)
> Anyone willing to work on this, pls note:
> 
> (In reply to Cor Nouws from comment #3)
> 
> > (Note that Ctrl+Tab is used to cycle through various text autofil choices
> > when entering data. But I guess codewise it's no problem to serve both.)

Not on MacOS, this doesn't work.
Comment 17 Cor Nouws 2017-12-05 09:56:17 UTC
(In reply to Magalaan from comment #12)

> Now it is really cumbersome. You have browse through the tabs as the tab you
> want to go is often not visible. 
> 
> Ctrl+Tab is all I need.

For the moment (and not only in this case) use the Navigator.
Comment 18 Stephen 2018-02-15 11:03:26 UTC
Was looking for this feature for a while, and found this bug report.
It totally makes sense to have a Ctrl+Tab shortcut for those who uses calc with many sheets!
I add myself to list of interested parties that would like this enhancement.
Comment 19 Heiko Tietze 2018-04-04 14:33:59 UTC
TAB_MOD1 was a shortcut for .uno:NextMark and TAB_SHIFT_MOD1 for .uno:PrevMark (Math: Edit > Next/Previous Marker), both were using the alternatives F4, Shift+F4 which is still available. Tab wasn't defined as a possible shortcut, so these shortcut never worked.

The patch allows to assign ctrl+tab and shift+ctrl+tab (or cmd for macOS) to functions and assigns it by default to next/previous sheet in Calc. Kept ctrl+page_up/down as alternative (both work now) for users who are familiar with it.

Patch at https://gerrit.libreoffice.org/#/c/52392/
Comment 20 Commit Notification 2018-04-06 11:10:21 UTC
heiko tietze committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=49a2ca259287173d86a303b5c75d25ce52a9e26c

tdf#86404 - use Ctrl+TAB to switch between tabs/sheets

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 21 Cor Nouws 2018-04-09 10:50:09 UTC
works in master.
And what is IMHO even better: that Ctrl+Tab is still functioning to cycle through various text autofil choices when entering data (see comment #3 - same as in Writer with Autocorrect/Wordcompletion)

Thanks!

In Version: 6.1.0.0.alpha0+
Build ID: b1009e095180ae0c24e5ec65dba6b459180d3869
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-04-09_00:08:48
Locale: nl-NL (nl_NL.UTF-8); Calc: grou
Comment 22 Stephen 2018-04-09 11:10:45 UTC
Fantastic!
Great work, thank you!
Comment 23 Heiko Tietze 2018-04-09 11:18:04 UTC
(In reply to Stephen from comment #22)
> Fantastic!
> Great work, thank you!

Thanks, that's why we all do this work :-)
Comment 24 Phil Krylov 2018-08-09 10:48:21 UTC
Please note that Cmd-Tab and Cmd-Shift-Tab on Mac are system shortcuts for switching between applications.
Comment 25 Heiko Tietze 2018-08-16 11:16:48 UTC
(In reply to Phil Krylov from comment #24)
> Please note that Cmd-Tab and Cmd-Shift-Tab on Mac are system shortcuts for
> switching between applications.

If you think the solution as implemented in 6.2 is not working correctly please file another ticket. And feel free to CC me :-).
Comment 26 Alex Thurgood 2018-08-21 15:17:37 UTC
(In reply to Heiko Tietze from comment #25)
> (In reply to Phil Krylov from comment #24)
> > Please note that Cmd-Tab and Cmd-Shift-Tab on Mac are system shortcuts for
> > switching between applications.
> 
> If you think the solution as implemented in 6.2 is not working correctly
> please file another ticket. And feel free to CC me :-).

Seriously, what kind of response is that ? Making deliberates change to a shortcut knowing that it won't work in MacOS and then expecting users to file a separate bug report after the fact ?

It might be fixed for Linux, or Windows, but this is certainly not fixed for MacOS, re-opening.
Comment 27 V Stuart Foote 2018-08-21 16:00:11 UTC
(In reply to Alex Thurgood from comment #26)
> 
> Seriously, what kind of response is that ? Making deliberates change to a
> shortcut knowing that it won't work in MacOS and then expecting users to
> file a separate bug report after the fact ?
> 
> It might be fixed for Linux, or Windows, but this is certainly not fixed for
> MacOS, re-opening.

On macOS we probably should make use of the MOD3 with TAB/Shift-TAB for the .uno:JumpToNextTable / .uno:JumpToPrevTable

As done for bug 114858 for the QUOTELEFT_MOD1 assigned to uno:ToggleFormula [1].

But agree with Heiko, needs a new BZ issue unique to macOS as it requires a simple hack but then testing.

=-ref-=
[1] https://opengrok.libreoffice.org/xref/core/officecfg/registry/data/org/openoffice/Office/Accelerators.xcu#1115
Comment 28 Xisco Faulí 2018-08-22 13:31:18 UTC
@Tor Lillqvist, I thought you could be interested in this issue...
Comment 29 Heiko Tietze 2018-08-22 16:49:07 UTC
Follow-up in bug 119425.
Comment 30 BogdanB 2018-09-16 16:54:31 UTC
Working on:
Version: 6.2.0.0.alpha0+
Build ID: e005ab5d40d358adb75a64e140d46f4bf605647d
CPU threads: 4; OS: Linux 4.15; UI render: GL; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-09-15_02:08:38
Locale: ro-RO (ro_RO.UTF-8); Calc: threaded