Bug 86412 - Print Preview causing Writer to Crash
Summary: Print Preview causing Writer to Crash
Status: VERIFIED DUPLICATE of bug 86298
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha2
Hardware: Other All
: high critical
Assignee: Chris Sherlock
URL:
Whiteboard:
Keywords: haveBacktrace, regression
Depends on:
Blocks:
 
Reported: 2014-11-17 21:28 UTC by Luke
Modified: 2014-11-19 21:36 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
bt with debug symbols (10.38 KB, text/plain)
2014-11-18 21:04 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2014-11-17 21:28:09 UTC
Steps to reproduce:
1. Start a recent build of writer
2. File->Print Preview

Results:
Writer will crash

Version: 4.4.0.0.alpha2+
Build ID: 8a68c3fecde9f688e07784e79ae661f821654453 Locale: en_US

$ lsb_release -rcd; uname -rm
Description:	Ubuntu 14.04.1 LTS
3.13.0-39-generic i686
Comment 1 Julien Nabet 2014-11-18 21:04:32 UTC
Created attachment 109691 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated today (cc02d84421182c70f1efbb24d1bda749b1f5e422), I could reproduce the crash.
I attached bt with symbols.
Comment 2 Julien Nabet 2014-11-18 21:06:42 UTC
Chris/Caolan: one for you? (I attached bt, it shows vcl part with free(): invalid pointer)
Comment 3 Chris Sherlock 2014-11-19 06:20:50 UTC
I'll try and have a look tonight. It looks like it's trying to free a bitmap twice though... but that's just an initial thought from looking at the backtrace.
Comment 4 Michael Stahl (CIB) 2014-11-19 14:24:07 UTC
was fixed by commit f857358d83e7c105271eb0e2c43f0b036f14f284

*** This bug has been marked as a duplicate of bug 86298 ***
Comment 5 Julien Nabet 2014-11-19 21:36:29 UTC
Again, thank you Michael! :-)