Bug Hunting Session
Bug 86416 - middle click paste truncates [Hard to reproduce]
Summary: middle click paste truncates [Hard to reproduce]
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: Other All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: needsClipIt
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-17 23:01 UTC by Todd
Modified: 2016-02-21 09:26 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Todd 2014-11-17 23:01:03 UTC
Dear LibreOffice,

Scientific Linux 6.6, x64
Xfce 4.8.1
LibreOffice_4.3.4_Linux_x86-64_rpm.tar.gz

This bug makes it a pain in the neck to paste into an xterm, which does not use <ctr><x,c,v>.

I can not longer highlight text in Writer and center click on my mouse to copy the highlighted text somewhere else without the text being truncated.  This happens in no other programs.  And what gets pasted seems to have a life of it own.

For instance, when I highlight the following in Writer
     Service detection performed. Please report any incorrect results

What I get is
     Serv

Or
     Microsoft Windows RPC

I get		
     Microsoft Windows R


Or
     Testing 1234567890 times

I get
     T

I can not highlight and center click paste any highlighted text from LO Writer to LO Writer.

The font I am using in LO is DejaVu Sans Mono, 10 pitch

Many thanks,
-T
Comment 1 tommy27 2014-12-14 18:17:15 UTC
Hi Todd, you reported the bug against LibO 4.3.0.4
have you ever tried to upgrade to current LibO 4.3.4.1 and see if the issue persists?
Comment 2 Todd 2014-12-14 21:51:22 UTC
(In reply to tommy27 from comment #1)
> Hi Todd, you reported the bug against LibO 4.3.0.4
> have you ever tried to upgrade to current LibO 4.3.4.1 and see if the issue
> persists?

LibreOffice_4.3.4_Linux_x86-64_rpm.tar.gz

"Over the month of November 2014" middle click pasted as "Over the mont"

No symptom change
Comment 3 Buovjaga 2014-12-16 13:02:49 UTC
Unable to repro with xterm and Ubuntu.

Ubuntu 14.10 64-bit Version: 4.5.0.0.alpha0+
Build ID: f92183833fa569006602ac7e93c906d2094e0d4d
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2014-12-14_00:21:45
Comment 4 Todd 2014-12-16 18:12:29 UTC
(In reply to Beluga from comment #3)
> Unable to repro with xterm and Ubuntu.
> 
> Ubuntu 14.10 64-bit Version: 4.5.0.0.alpha0+
> Build ID: f92183833fa569006602ac7e93c906d2094e0d4d
> TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time:
> 2014-12-14_00:21:45

What version of Xfce did you use?
Comment 5 Buovjaga 2014-12-16 19:05:26 UTC
Sorry, I did not use Xfce, simply a regular Ubuntu desktop.
Btw., doesn't ctrl-shift-x,c,v work for you in xterm for cut, copy & paste?
Comment 6 Todd 2014-12-16 19:22:14 UTC
(In reply to Beluga from comment #5)
> doesn't ctrl-shift-x,c,v work for you in xterm for cut, copy & paste?

That only works in "Terminal".  Xterm is devoid of that.  The closest you can come is 

xterm -fn 8x16 -fg darkgreen -bg white -bdc -cc "33:48,37:48,45-47:48,38:48"  -geometry 140x25 -xrm '*VT100*translations: #override \n Shift Ctrl <Key>C:select-end(PRIMARY, CLIPBOARD, CUT_BUFFER0) \n Shift Ctrl <Key>V:insert-selection(PRIMARY, CUT_BUFFER0)'

but that doesn't work all that well.  And, no one except die hard xterm'ers like myself are going to go through that effort.

What you wind up doing is having a Leafpad open, copy and pasting from LO to Leafpad, then highlighting and right clicking from Leafpad to your Xterm.

Also, I don't know if I emphasized it or not, but LO is the only program I am having the problem with.

-T
Comment 7 Buovjaga 2014-12-17 07:58:20 UTC
Asked on #xfce and one person could not reproduce, LibO 4.2.7, xterm-297, Ubuntu with Xfce.
I'm going away for the holidays, so can't continue asking around. You should hop on #xfce and #xubuntu and try to get independent confirmation (or maybe an Xfce dev can solve it).
Comment 8 Todd 2014-12-17 18:41:16 UTC
(In reply to Beluga from comment #7)
> Asked on #xfce and one person could not reproduce, LibO 4.2.7, xterm-297,
> Ubuntu with Xfce.
> I'm going away for the holidays, so can't continue asking around. You should
> hop on #xfce and #xubuntu and try to get independent confirmation (or maybe
> an Xfce dev can solve it).

What version of Xfce?

I asked the Xfce Mailing list if anyone else can reproduce it
Comment 9 Todd 2014-12-18 19:23:19 UTC
(In reply to Todd from comment #8)

> I asked the Xfce Mailing list if anyone else can reproduce it

Got one response back so far and he was able to reproduce it
Comment 10 Todd 2014-12-18 20:27:05 UTC
problem persists in 4.3.5
Comment 11 Buovjaga 2014-12-20 12:24:39 UTC
(In reply to Todd from comment #9)
> (In reply to Todd from comment #8)
> 
> > I asked the Xfce Mailing list if anyone else can reproduce it
> 
> Got one response back so far and he was able to reproduce it

https://mail.xfce.org/pipermail/xfce/2014-December/033990.html
Quoting:
if you mean with "highlight" a triple-click on the line, my LO 4.2.7.2 
gives me:
Service detection performed. Please report any incorrect results
=>
Service detection performed.
The other eamples are o. k. The result of the first example contradicts 
with every experience, or better convention.
Copying from LO to Lo works.
(end quote)

I guess that counts as reproducing, although it's not very consistent. I don't know, why he is talking about triple-clicking.
Let's set to NEW anyway.
Severity lowered per https://wiki.documentfoundation.org/images/0/06/Prioritizing_Bugs_Flowchart.jpg
Comment 12 Todd 2014-12-20 21:51:07 UTC
Okay.  I have no idea where the triple clicking came from.

By "highlight", I mean, position your mouse at the start of the text you want to copy, press down the left mouse button , leave it down and sweep across the text your want to copy, then let go.

By middle click, I mean the center roller on a two button mouse with a center roller.  This can be simulated on a two button only mouse (no roller) by simultaneously clicking the right and left buttons together.

After you have highlighted your text (leave it highlighted), go to and xterm or a leafpad and center click to paste the highlighted text.  You should only see a fragment of what you highlighted.

The only program with this behavior is LO
Comment 13 Buovjaga 2015-01-09 07:55:25 UTC
Installed Scientific Linux 7 64-bit on a VM. Installed Xfce 4.10 and xterm-295-3.
Could not reproduce the problem with these:

Version: 4.1.4.2
Build ID: 4.1.4.2-3.el7

Version: 4.5.0.0.alpha0+
Build ID: 9763b55eb946cf425220d26dab91bf220890b180
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2015-01-08_12:56:53

I could not get 4.3 to work, so was not able to test.

Please test on Xfce 4.10.
Comment 14 Todd 2015-01-09 18:06:02 UTC
(In reply to Beluga from comment #13)
> Installed Scientific Linux 7 64-bit on a VM. Installed Xfce 4.10 and
> xterm-295-3.
> Could not reproduce the problem with these:
> 
> Version: 4.1.4.2
> Build ID: 4.1.4.2-3.el7
> 
> Version: 4.5.0.0.alpha0+
> Build ID: 9763b55eb946cf425220d26dab91bf220890b180
> TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time:
> 2015-01-08_12:56:53
> 
> I could not get 4.3 to work, so was not able to test.
> 
> Please test on Xfce 4.10.

Hi Beluga,

Good.  You have access to VM's.

Xfce 4.10 does run on Scientific Linux 6.6.  

Would you please create a new VM with SL 6.6 and load Xfce 4.8 and LO 4.3.4 on it to trouble this problem?   LO 4.3.4 is the ONLY program manifesting this issue.

Many thanks,
-T
Comment 15 Buovjaga 2015-01-13 06:41:06 UTC
(In reply to Todd from comment #14)
> Hi Beluga,
> 
> Good.  You have access to VM's.
> 
> Xfce 4.10 does run on Scientific Linux 6.6.  
> 
> Would you please create a new VM with SL 6.6 and load Xfce 4.8 and LO 4.3.4
> on it to trouble this problem?   LO 4.3.4 is the ONLY program manifesting
> this issue.
> 
> Many thanks,
> -T

Anyone with access to a computer has access to VMs.

Why do you want to run Xfce 4.8? How would I even install Xfce 4.8 64-bit on SL 6.6, if I don't want to build from source? This thread is relevant: http://scientificlinuxforum.org/index.php?showtopic=364

I did download SL 6.6, but I won't install it, before I get a reply from you.

LibreOffice might be the only program manifesting the issue in your setup, but it still seems like it's not a LibreOffice bug and this report could be closed, if you updated to Xfce 4.10. The reproduction on the mailing list sounds like there might have been a misunderstanding.
Comment 16 Todd 2015-01-13 18:40:49 UTC
(In reply to Beluga from comment #15)
> (In reply to Todd from comment #14)
> > Hi Beluga,
> > 
> > Good.  You have access to VM's.
> > 
> > Xfce 4.10 does run on Scientific Linux 6.6.  
> > 
> > Would you please create a new VM with SL 6.6 and load Xfce 4.8 and LO 4.3.4
> > on it to trouble this problem?   LO 4.3.4 is the ONLY program manifesting
> > this issue.
> > 
> > Many thanks,
> > -T
> 
> Anyone with access to a computer has access to VMs.
> 
> Why do you want to run Xfce 4.8?

I don't.  I have no choice.  4.10 is not supported under SL 6.x

> How would I even install Xfce 4.8 64-bit on
> SL 6.6

yum install http://mirror.pnl.gov/epel/6/x86_64/epel-release-6-8.noarch.rpm
yum --enablerepo=epel* groupinstall xfce-desktop
Comment 17 Buovjaga 2015-01-14 07:55:00 UTC
Middle-click paste from LibreOffice doesn't truncate with this setup either:
SL 6.6 64-bit.
Xfce 4.8
Xterm 253-1
LibreOffice 4.3.4

Can you please reply to the person on the Xfce mailing list and try to clarify the reproduction steps?
You could also try SL 7 in a VM, installing Xfce 4.10 from EPEL 7.
Comment 18 Todd 2015-01-14 18:37:03 UTC
(In reply to Beluga from comment #17)
> Middle-click paste from LibreOffice doesn't truncate with this setup either:
> SL 6.6 64-bit.
> Xfce 4.8
> Xterm 253-1
> LibreOffice 4.3.4


Install and activate Clip It to reproduce.

$ rpm -qa \*clipit\*
clipit-1.4.2-6.el6.x86_64

You can start it from the command line or

--> applications menu
  --> settings
    --> session and start up
      --> autostart (tab)
        --> check off "clipit (Clipboard manager) "
           --> logout and back on. 

A clipboard should appear in the upper right of your task bar (panel 1).  You can right click and quit for testing purposes


> Can you please reply to the person on the Xfce mailing list and try to
> clarify the reproduction steps?

What are you looking for?

> You could also try SL 7 in a VM, installing Xfce 4.10 from EPEL 7.

That would be a bit of an undertaking.  I will do it if you think it necessary after your test with clipit.

This has to do with LO's interaction with clipit.  (Note that LO is the ONLY program with this issue.)

RHEL7/SL7 does not support 32 bit apps, meaning that 32 bit Wine is not supported, making RHEL/SL7 a bad choice for a workstation.  Why the curiosity for a platform that is pretty much useless as a workstation?

If you have SL7 in a VM, maybe you could trying starting clipit and see if it reproduced there as well?
Comment 19 Buovjaga 2015-01-15 10:11:55 UTC
(In reply to Todd from comment #18)
> Install and activate Clip It to reproduce.
> 
> $ rpm -qa \*clipit\*
> clipit-1.4.2-6.el6.x86_64
> 
> You can start it from the command line or
> 
> --> applications menu
>   --> settings
>     --> session and start up
>       --> autostart (tab)
>         --> check off "clipit (Clipboard manager) "
>            --> logout and back on. 
> 
> A clipboard should appear in the upper right of your task bar (panel 1). 
> You can right click and quit for testing purposes
> 

Ok obviously this changes everything. This should be unconfirmed, but I will keep as NEW until I can test.

rpm -qa \*clipit\* doesn't do anything. How can I install clipit (on SL 6.6)? From what I read, it should be in EPEL 6, but is not found in the software selection.
Comment 20 Todd 2015-01-15 16:59:42 UTC
(In reply to Beluga from comment #19)
> rpm -qa \*clipit\* doesn't do anything. How can I install clipit (on SL
> 6.6)? From what I read, it should be in EPEL 6, but is not found in the
> software selection.

Hi Beluga,

#=root; $=user

To find "clipit":
$ su
# yum --enablerepo=epel* whatprovides clipit
...
clipit-1.4.2-6.el6.x86_64 : A lightweight, fully featured GTK+ clipboard manager
Repo        : epel


Once found, to install (still as root):
# yum --enablerepo=epel* install clipit


To test, fire it up from the command line as a user:
$ clipit &


-T
Comment 21 Buovjaga 2015-01-16 07:17:31 UTC
(In reply to Todd from comment #20)
> To test, fire it up from the command line as a user:
> $ clipit &

Thanks for the steps.
EPEL 7 apparently doesn't have clipit, so I only tested on SL 6.6.
I could not reproduce the truncation, so I'm setting back to unconfirmed.
Comment 22 Todd 2015-01-17 18:11:37 UTC
(In reply to Beluga from comment #21)
> (In reply to Todd from comment #20)
> > To test, fire it up from the command line as a user:
> > $ clipit &
> 
> Thanks for the steps.
> EPEL 7 apparently doesn't have clipit, so I only tested on SL 6.6.
> I could not reproduce the truncation, so I'm setting back to unconfirmed.

Verify clipit is running:

$ ps ax | grep -i clipit | grep -v grep
Comment 23 Buovjaga 2015-01-19 09:43:24 UTC
(In reply to Todd from comment #22)
> Verify clipit is running:
> 
> $ ps ax | grep -i clipit | grep -v grep

Ok, it seems clipit wasn't running the last time I tried! Now I got the truncated result.

Yet, ClipIt seems to be abandoned:
http://sourceforge.net/p/gtkclipit/code/ci/master/tree/
http://www.linuxgator.org/gnome/forum/viewtopic.php?p=24913
"Developer switched to KDE; says he cant handle working with Gnome 3."

I don't see an easy solution as the developer doesn't want to work on it anymore.

ClipIt forked from Parcellite, but Parcellite has been in active development during the past couple of years:
http://parcellite.sourceforge.net/

Would you like to try Parcellite or some other manager:
https://wiki.archlinux.org/index.php/clipboard#List_of_clipboard_managers

Btw., I found your discussion about wine32 and SL 7.
I tried this "HOWTO build wine 32bit on CentOS 7":
https://www.centos.org/forums/viewtopic.php?f=48&t=49542
But my wine build failed because of a symbolic link issue (I posted to the thread).
Comment 24 Todd 2015-01-19 20:56:13 UTC
(In reply to Beluga from comment #23)

> Yet, ClipIt seems to be abandoned:

I will just keep the Source RPM around so I can recompile it.

> Would you like to try Parcellite or some other manager:
> https://wiki.archlinux.org/index.php/clipboard#List_of_clipboard_managers

Parcellite (or the version that runs under SL 6.x) won't allow for the coping and pasting of images.  Sigh.

You have a favorite replacement?

> 
> Btw., I found your discussion about wine32 and SL 7.
> I tried this "HOWTO build wine 32bit on CentOS 7":
> https://www.centos.org/forums/viewtopic.php?f=48&t=49542
> But my wine build failed because of a symbolic link issue (I posted to the
> thread).

Wow!  What a tremendous amount of work!  And in Step 1, he made no mention of where he is getting all those i686 packages from.  I book marked it, just in case I ever have a free week with nothing else to do and decide to try compiling it again.
Comment 25 Buovjaga 2015-01-20 08:44:52 UTC
(In reply to Todd from comment #24)
> Parcellite (or the version that runs under SL 6.x) won't allow for the
> coping and pasting of images.  Sigh.
> 
> You have a favorite replacement?
> 

Sorry, I don't use clipboard managers myself. CopyQ looks hot, but it requires Qt, which might be a deal-breaker for you.

I could reproduce the truncation with these old versions, too:

LibreOffice 3.5.0rc3 
Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735

Version 4.0.4.2 (Build ID: 4.0.4.2-14.el6)

So this isn't a regression we could bibisect :(

> Wow!  What a tremendous amount of work!  And in Step 1, he made no mention
> of where he is getting all those i686 packages from.  I book marked it, just
> in case I ever have a free week with nothing else to do and decide to try
> compiling it again.

Here are my notes:

step 2:
had to tweak this:
yum localinstall rpmbuild/RPMS/i686/chrpath-0.13-14.el7.centos.i686.rpm

to this:
yum localinstall rpmbuild/RPMS/i686/chrpath-0.13-14.el7.i686.rpm

Installed cmake from package manager.

had to tweak this:
yum localinstall rpmbuild/RPMS/i686/openal-soft{,-devel}-1.16.0-2.el7.centos.i686.rpm

to this:
yum localinstall rpmbuild/RPMS/i686/openal-soft{,-devel}-1.16.0-2.el7.i686.rpm

For editing:
http://www.lagmonster.org/docs/vi.html
http://www.cs.colostate.edu/helpdocs/vi.html

dd delete line
a Append after cursor (press ESC to complete)
/string    Search forward for string
?string    Search back for string
n    Search for next instance of string
N    Search for previous instance of string
ZZ save and exit
Comment 26 QA Administrators 2016-02-21 08:36:23 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice 
   (5.0.5 or 5.1.0)  https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and 
   your operating system, and any changes you see in the bug behavior
 
   If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave 
   a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
   appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2016-02-21
Comment 27 Todd 2016-02-21 09:26:37 UTC
Hi All,

The problem does not exist in 5.1.0.3 (LibreOffice_5.1.0_Linux_x86-64_rpm.tar.gz).  Yipee!  Thank you guys so much!

-T