Bug 86456 - Libre Office corrupts boolean columns importing xlsx file
Summary: Libre Office corrupts boolean columns importing xlsx file
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.4.1 release
Hardware: x86 (IA32) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-19 06:08 UTC by John Mount
Modified: 2018-09-19 10:35 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
test xlsx file (31.67 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2014-11-19 10:29 UTC, Alex Thurgood
Details
XLSX file showing the problem (31.67 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2014-11-19 16:10 UTC, John Mount
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John Mount 2014-11-19 06:08:05 UTC
On importing an Excel .xlsx file that has columns which are TRUE/FALSE (which is encoded is 0/1 by Excel) eventually Libre Office starts mis-interpreting arbitrary cells as being empty.  See: http://www.win-vector.com/blog/2014/11/excel-spreadsheets-are-hard-to-get-right/
Comment 1 Smruti 2014-11-19 06:09:47 UTC
*** Bug 86455 has been marked as a duplicate of this bug. ***
Comment 2 Alex Thurgood 2014-11-19 10:26:45 UTC
Confirming

Version: 4.4.0.0.alpha2+
Build ID: 60d34e1c840d2c317bb7d0a5b14f4602c22b3fcc
Locale: fr_
Comment 3 Alex Thurgood 2014-11-19 10:29:12 UTC
Created attachment 109721 [details]
test xlsx file
Comment 4 John Mount 2014-11-19 16:09:31 UTC
It may be a presentation problem as examining individual cells shows “=TRUE()” and “=FALSE()” as the contents of the affected cells (and apparently in the correct positions independent of what is being displayed).
Comment 5 John Mount 2014-11-19 16:10:45 UTC
Created attachment 109739 [details]
XLSX file showing the problem
Comment 6 John Mount 2014-11-19 16:18:59 UTC
If examine the cells you see int the formula bar that the TRUE/FALSE cells have been changed to =TRUE()/=FALSE(), and you get an “inconsistent formulas” warning. So the sheet has been damaged, but is likely in a regular patten that is repairable. So it looks like a combination of a bad transformation on load plus a presentation layer bug.
Comment 7 QA Administrators 2016-09-20 09:31:56 UTC Comment hidden (obsolete)
Comment 8 eisa01 2017-08-26 23:10:13 UTC
The third row is no longer corrupted, but LibreOffice shows 0/1 with =FALSE()/TRUE(), so this may just be a presentation issue now?

This is both present on Mac and Windows

It could be a duplicate of bug 81350

Version: 5.4.0.3
Build ID: 7556cbc6811c9d992f4064ab9287069087d7f62c
CPU threads: 2; OS: Mac OS X 10.12.6; UI render: default; 
Locale: en-US (en_US.UTF-8); Calc: group

Version: 5.4.0.3 (x64)
Build ID: 7556cbc6811c9d992f4064ab9287069087d7f62c
CPU threads: 1; OS: Windows 6.1; UI render: default; 
Locale: en-US (en_US); Calc: group
Comment 9 QA Administrators 2018-08-27 02:35:48 UTC Comment hidden (obsolete)
Comment 10 Alex Thurgood 2018-09-19 10:35:58 UTC
This is WFM with

Version: 6.1.1.2
Build ID: 5d19a1bfa650b796764388cd8b33a5af1f5baa1b
Threads CPU : 8; OS : Mac OS X 10.13.6; UI Render : par défaut; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group threaded

although the cell values display 1 and 0 for True/False respectively, they can be formatted as "logical values" to show true/false instead.