Download it now!
Bug 86496 - No caret in editing area of new Writer document created from cmd line
Summary: No caret in editing area of new Writer document created from cmd line
Status: RESOLVED DUPLICATE of bug 49684
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: Other All
: low normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, regression
Depends on:
Blocks:
 
Reported: 2014-11-20 19:27 UTC by Terrence Enger
Modified: 2015-12-15 11:03 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Terrence Enger 2014-11-20 19:27:26 UTC
STR

(1) Run LibreOffice with command line option --writer.

    Program action expected:  To display window "Untitled 1" with a
    caret at the upper left corner of the document area.

    Program action observed:  Window "Untitled 1" has no caret.

(2) Type "A".

    Program action expected:  To show the A in the document area.

    Program action observed:  The document area remains empty.

Note, funnily enough, continuing on:

(*) File > New > "Text Document" opened "Untitled 2" without a caret.

(*) I closed document "Untitled 1", and then from the Start Center,
    typed <Ctrl>+D.  The program opened the new "Untitled 1" *with* a
    caret, and typing inserted text exactly as expected.

(*) File > New > "Text Document" now opened "Untitled 2" *with* a
    caret.


The workaround for this problem is to click within the document area.
Because of the obvious workaround, I am assigning priority low.

The problem is absent from 

    Version: 4.4.0.0.alpha2+
    Build ID: 4f18bd405831c31cd49190046f7bafd805a47d7d
    TinderBox: Win-x86@39, Branch:master, Time: 2014-11-20_09:39:04
    Locale: en_CA


Working in the daily dbgutil bibisect repository, I see from `git
bisect good`:

    6fdb0b6634965682dfc7bd799479a0df5ee828e6 is the first bad commit
    commit 6fdb0b6634965682dfc7bd799479a0df5ee828e6
    Author: Miklos Vajna <vmiklos@collabora.co.uk>
    Date:   Wed Jun 11 08:31:24 2014 +0200

        2014-06-11

    :100644 100644 9547b990b6ad77f5f1618fa38c41a473d40a8bfe 02e2c5f29ce83b106549b08cf4ddac9860756b94 M	build-info.txt
    :040000 040000 44276a6e8f9d5eb7f1e4855e557169e3bc3a22f6 733e12c89a83e2722f209712b2ee6c814dbf900d M	opt

and from `git bisect log`:

    # bad: [05f4c71d4862a02ab81f09fcdd536c0cc6dfb128] 2014-11-20: source-hash-d273a60bfdbf9bb7623bed38667ec0647753157c
    # good: [b3130c846de5cf1b4be48b48dfc780bb369549fa] 2014-05-21
    git bisect start 'origin/master' 'oldest'
    # bad: [364ba817b97ce3b1d9ce53a2b51235cdb82d6864] 2014-08-21
    git bisect bad 364ba817b97ce3b1d9ce53a2b51235cdb82d6864
    # bad: [479f8e7126777715c2ce39bb89483b88696f747e] 2014-07-05
    git bisect bad 479f8e7126777715c2ce39bb89483b88696f747e
    # bad: [10b4496584ecc392a40239e3f3c7ee455d83bfb4] 2014-06-12
    git bisect bad 10b4496584ecc392a40239e3f3c7ee455d83bfb4
    # good: [c93bc261b780c67e84015965e5e351e11586109a] 2014-06-01
    git bisect good c93bc261b780c67e84015965e5e351e11586109a
    # good: [c575bbb17a524aa4146032154316a8695b9a176e] 2014-06-06
    git bisect good c575bbb17a524aa4146032154316a8695b9a176e
    # good: [a029f530c32986a5629522fd320834a6df0505ac] 2014-06-09
    git bisect good a029f530c32986a5629522fd320834a6df0505ac
    # bad: [6fdb0b6634965682dfc7bd799479a0df5ee828e6] 2014-06-11
    git bisect bad 6fdb0b6634965682dfc7bd799479a0df5ee828e6
    # good: [71f45055280ce7f7be51a85a6dfe489644dbe88b] 2014-06-10
    git bisect good 71f45055280ce7f7be51a85a6dfe489644dbe88b
    # first bad commit: [6fdb0b6634965682dfc7bd799479a0df5ee828e6] 2014-06-11
    
Looking into the respective build-info.txt:

    status  commit               s-h
    good    71f4505  2014-06-10  32ac015
    bad     6fdb0b6  2014-06-11  7d10da2
Comment 1 Urmas 2014-12-12 01:59:12 UTC
In my case the focus is in the Navigator window. Confirming on Windows too.
Comment 2 Terrence Enger 2014-12-12 21:13:08 UTC
Urmas,

I just tried versions 

    Version: 4.5.0.0.alpha0+
    Build ID: 842848cb6d6c88fcf2c2b17d5e933458fa5d2ece
    TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2014-12-12_01:49:49
    Locale: en_CA

and

    Version: 4.5.0.0.alpha0+
    Build ID: 170616e9f2d30c1302bbb5a7a4b588bc05cd5cc9
    TinderBox: Win-x86@39, Branch:master, Time: 2014-12-12_01:58:46
    Locale: en_CA

without seeing the problem.  What versions did you test?


I think this report is heading for WORKSFORME, unless your versions
are new enough to make it hard to believe that that a change slipped
in between yours and mine.  What do you think?


Terry.
Comment 3 Urmas 2014-12-14 07:21:23 UTC
170616e9f2d30c1302bbb5a7a4b588bc05cd5cc9 still has this issue.
Comment 4 Matthew Francis 2014-12-24 00:53:29 UTC
(Commented during a sweep of bibisected but not source bisected bugs)

Could not reproduce, and therefore unfortunately I cannot bisect this issue further.
Comment 5 Urmas 2015-01-21 01:26:19 UTC

*** This bug has been marked as a duplicate of bug 49684 ***
Comment 6 Robinson Tryon (qubit) 2015-12-15 11:03:23 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]