Bug 86498 - No accelerator key for Tools > "AutoCorrect Options..."
Summary: No accelerator key for Tools > "AutoCorrect Options..."
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: ux-advise (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: Other All
: low normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2014-11-20 20:33 UTC by Terrence Enger
Modified: 2015-12-15 11:03 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Tools Menu screenshot (20.45 KB, image/png)
2014-11-23 16:23 UTC, tommy27
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Terrence Enger 2014-11-20 20:33:00 UTC
In the Tools menu of Writer, "AutoCorrect Options..." advertises
shortcut "A" (by underscoring the first A), but in this menu <Ctrl>+A
and simply "A" cycle between only "Autmatic Spell Checking" and
"Address Book Source...".  My expectation is that the cycle should
include "AutoCorrect Options...".

Setting O/S All, as I see the problem on Windows Vist with LibreOffice
    Version: 4.4.0.0.alpha2+
    Build ID: 4f18bd405831c31cd49190046f7bafd805a47d7d
    TinderBox: Win-x86@39, Branch:master, Time: 2014-11-20_09:39:04
    Locale: en_CA



This seems to have started on the same day that "Automatic Spell
Checking" was added to the Tools menu.  Working in the daily dbgutil bibisect repository, I see from `git bisect bad`:

    20f8211459e610cdd62e533c6ef541324f18627e is the first bad commit
    commit 20f8211459e610cdd62e533c6ef541324f18627e
    Author: Miklos Vajna <vmiklos@collabora.co.uk>
    Date:   Thu Sep 4 11:16:55 2014 +0000

        2014-09-04

    :100644 100644 caa1ee985dc01e2171416d1b06b91f9fdb873618 27d1e5acf0f01860c9fa370b0eb9648249d6cab7 M	build-info.txt
    :040000 040000 09ad6430e55219cbde0483b49b81cc08792e20c4 a9133e9c72dba83048dda89ed73d81934f177129 M	opt

and from `git bisect log`:

    # bad: [05f4c71d4862a02ab81f09fcdd536c0cc6dfb128] 2014-11-20: source-hash-d273a60bfdbf9bb7623bed38667ec0647753157c
    # good: [b3130c846de5cf1b4be48b48dfc780bb369549fa] 2014-05-21
    git bisect start 'origin/master' 'oldest'
    # good: [364ba817b97ce3b1d9ce53a2b51235cdb82d6864] 2014-08-21
    git bisect good 364ba817b97ce3b1d9ce53a2b51235cdb82d6864
    # bad: [3bd90766c05c07c4a39e36cb1d3106b0016983d4] 2014-10-05
    git bisect bad 3bd90766c05c07c4a39e36cb1d3106b0016983d4
    # bad: [20e1f895cd2c8446dbedef564d15e3e511d7c4b2] 2014-09-12
    git bisect bad 20e1f895cd2c8446dbedef564d15e3e511d7c4b2
    # good: [8c0ffaa3f2ace1b3a8e8e1db44b11ba083637e4d] 2014-09-01
    git bisect good 8c0ffaa3f2ace1b3a8e8e1db44b11ba083637e4d
    # bad: [827afd643c75bdea4680bfee7b131286c0bdedba] 2014-09-06
    git bisect bad 827afd643c75bdea4680bfee7b131286c0bdedba
    # good: [6b5fccfe3a189781502a674a4d6e10a627ddbabc] 2014-09-03
    git bisect good 6b5fccfe3a189781502a674a4d6e10a627ddbabcc
    # bad: [bc8fe1433f6f3c946571d2c65d2d58553efbd9c6] 2014-09-05
    git bisect bad bc8fe1433f6f3c946571d2c65d2d58553efbd9c6
    # bad: [20f8211459e610cdd62e533c6ef541324f18627e] 2014-09-04
    git bisect bad 20f8211459e610cdd62e533c6ef541324f18627e
    # first bad commit: [20f8211459e610cdd62e533c6ef541324f18627e] 2014-09-04

and from the respective files build-info.txt:

    result  commit               s-h
    good    6b5fccf  2014-09-03  527462c
    bad     20f8211  2014-09-04  3e83515
Comment 1 tommy27 2014-11-23 16:23:26 UTC
Created attachment 109904 [details]
Tools Menu screenshot

I confirm issue under Win8.1x64 using LibO 4.5.0.0.alpha0+
Build ID: 84a6d8eeaab540e5b2ea3baffd919903dff8c247
TinderBox: Win-x86@39, Branch:master, Time: 2014-11-22_23:41:04
Locale: it_IT
Comment 2 Michael Stahl (CIB) 2014-11-25 22:40:16 UTC
changed by:

commit f83274a2579553efc347c1080d19f0734b0d4358
Author:     Samuel Mehrbrodt <s.mehrbrodt@gmail.com>
AuthorDate: Sat Aug 30 11:16:44 2014 +0200
Commit:     Thomas Arnhold <thomas@arnhold.org>
CommitDate: Wed Sep 3 02:10:07 2014 -0500

    fdo#82969 Add AutoSpellcheck to tools menu


is it a bug or a feature?
Comment 3 Terrence Enger 2014-11-25 23:34:17 UTC
Michael Stahl asked:  bug or feature?

The back-and-forth in fdo#82969 is about a shortcut key, which would
be effective whenever the user is editing her text.  The current report
is about navigation within the tools menu when the menu is already
open.

I am inclined to think that there is a bug here because the
underscored "A" in "AutoCorrect Options..." tells the user that focus
will go to this option after typing enough A's.  It is a matter of
taste whether one sees the bug in the underscore or in the progression
of focus.  Each other option in that menu advertises a shortcut key,
and all of the these which are enabled in my currently open document
honour the advertisement.

Terry.
Comment 4 Björn Michaelsen 2015-01-27 17:56:40 UTC
Comment 2 still seems to need a well defined expected behavior for both this bug and fdo#82969.
Comment 5 QA Administrators 2015-09-04 02:56:00 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team

This NEEDINFO message was generated on: 2015-09-03
Comment 6 Terrence Enger 2015-09-04 13:14:11 UTC
The problem is gone by daily dbgutil bibisect version 2015-09-03:
AutoCorrect options are moved one level down in the menu hierarchy and
the daily is reachable by shortcut keys.

I am setting status RESOLVED WORKSFORME.

Terry.
Comment 7 Robinson Tryon (qubit) 2015-12-15 11:03:20 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]