Download it now!
Bug 86519 - Problems with LibreOffice Calc
Summary: Problems with LibreOffice Calc
Status: RESOLVED DUPLICATE of bug 79441
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.7.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-21 11:06 UTC by c.hakeem.smith.iii
Modified: 2014-12-07 03:17 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description c.hakeem.smith.iii 2014-11-21 11:06:37 UTC
LibreOffice Calc has issues with formulas in cells, multiple sheets, and sorting. The formula problem is that, when there are formulas in cells that are getting information from cells on separate sheets, the formula will randomly update with the cells from the current sheet. For example: A formula entered on Sheet 2 that reads =SUM('Sheet 1'.A1:A20) changes to =SUM(A1:20). The problem with having multiple sheets is usually that the information will not display correctly. For example: Two random cells will have borders. Finally, the sorting issue is with formulas that are sorted point to random cells instead of the correct cells in the row or column they belong to. An example is with a simple SUM formula: Rows 1 - 10 will have data in columns A through J and column K will have the formula =(SUM A1:J1), likewise for rows B through J. However, when the data in column K is sorted in ascending or descending order, the formula in column K will not contain the correct row number (e.g. =SUM(A2:J2) for row 10 instead of the correct =SUM(A10:J10).
Comment 1 raal 2014-11-21 13:48:58 UTC
(In reply to c.hakeem.smith.iii from comment #0)
> LibreOffice Calc has issues with formulas in cells, multiple sheets, and
> sorting. The formula problem is that, when there are formulas in cells that
> are getting information from cells on separate sheets, the formula will
> randomly update with the cells from the current sheet. For example: A
> formula entered on Sheet 2 that reads =SUM('Sheet 1'.A1:A20) changes to
> =SUM(A1:20). 

Can you provide steps how to reproduce this? I can not reproduce. Is it corresponding with sorting? 


The problem with having multiple sheets is usually that the
> information will not display correctly. For example: Two random cells will
> have borders. 

Can you provide steps how to reproduce this? I don't understand.

Finally, the sorting issue is with formulas that are sorted
> point to random cells instead of the correct cells in the row or column they
> belong to. An example is with a simple SUM formula: Rows 1 - 10 will have
> data in columns A through J and column K will have the formula =(SUM A1:J1),
> likewise for rows B through J. However, when the data in column K is sorted
> in ascending or descending order, the formula in column K will not contain
> the correct row number (e.g. =SUM(A2:J2) for row 10 instead of the correct
> =SUM(A10:J10).

This is duplicate of Bug 85490.

btw. 1 problem = 1 bugreport
Thank you
Comment 2 Robinson Tryon (qubit) 2014-11-21 21:57:14 UTC
(In reply to raal from comment #1)
> Can you provide steps how to reproduce this? I can not reproduce. Is it
> corresponding with sorting? 

Status -> NEEDINFO

(c.hakeem -- please change the status back to 'UNCONFIRMED' after you've provided repro steps. Thanks!)
Comment 3 V Stuart Foote 2014-12-07 03:17:56 UTC
Resolved fixed on 4.2.8 patch release with http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-4-2&id=094b19c2759c8ecc88b38d37047e9ac2de9b68ee

@c.hakeem.smith.iii, please go ahead and verify function with any current build 4.2.8, 4.3.5, 4.4.0 beta2 or a current master.

*** This bug has been marked as a duplicate of bug 79441 ***