Download it now!
Bug 86528 - FILEOPEN: File Services dialog does not offer Server Type OneDrive
Summary: FILEOPEN: File Services dialog does not offer Server Type OneDrive
Status: RESOLVED DUPLICATE of bug 62437
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-21 16:14 UTC by Terrence Enger
Modified: 2014-12-02 21:22 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
image of dropdown list "Server Type" (33.56 KB, image/png)
2014-11-21 16:16 UTC, Terrence Enger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Terrence Enger 2014-11-21 16:14:42 UTC
This is my first attempt at connecting to OneDrive.  Be alert for user
error.

I started at
<https://wiki.documentfoundation.org/ReleaseNotes/4.4#Connection_to_SharePoint_and_OneDrive>
and was trying to make my screen look like linked image
<https://wiki.documentfoundation.org/File:Rsz_1.png>.

(1) Use LibreOffice dialogs:  menu options Tools > Options >
    LibreOfficeDev > General > "Open/Save Dialogs" and select "Use
    LibreOfficeDev dialogs".
(2) Menu options File > Open.  Program presents dialog Open.
(3) Click <Servers...>.  Program presents dialog "File Services".
(4) In drop-down list "File Service" > Type, select CMIS as per
    <https://wiki.documentfoundation.org/File:Rsz_1.png>.
(5) Open the dropdown list "Server Details" > "Server Type".
    Expectation :  That the list should include OneDrive.
    Actual      :  The list does not offer OneDrive.  Screen image
                   coming soon.

The behaviour is essentially the same in daily dbgutil bibisect
version 2014-11-20 and Windows tinderbox version from 2014-11-21,
except that the Windows version did not offer Google Drive.
Comment 1 Terrence Enger 2014-11-21 16:16:06 UTC
Created attachment 109804 [details]
image of dropdown list "Server Type"
Comment 2 Maxim Monastirsky 2014-11-24 15:33:26 UTC
According to Bug 62437 comment 5 this feature is still in a branch, and wasn't merged to master.
Comment 3 Julien Nabet 2014-12-02 21:22:15 UTC
So dup following Maxim's comment.

*** This bug has been marked as a duplicate of bug 62437 ***