Bug 86553 - "Document Recovery" dialog is up when a new document saved then closing Writer
Summary: "Document Recovery" dialog is up when a new document saved then closing Writer
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha2
Hardware: x86-64 (AMD64) Windows (All)
: high major
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-22 07:08 UTC by Naruhiko Ogasawara
Modified: 2016-05-05 10:26 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
"LibreOfficeDev Document Recovery" dialog (37.35 KB, image/png)
2014-11-22 07:08 UTC, Naruhiko Ogasawara
Details
Runtime error on Windows Server 2012 R2 (8.16 KB, image/png)
2014-11-28 01:10 UTC, Naruhiko Ogasawara
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Naruhiko Ogasawara 2014-11-22 07:08:41 UTC
Created attachment 109835 [details]
"LibreOfficeDev Document Recovery" dialog

Step 1. Open LibreOffice 4.4.0.0 beta1
Step 2. Create new writer document with File > New > Text Document
Step 3. Edit something
Step 4. Save the file with File > Save
Step 5. Close LibreOffice (both; click window close button, or File > Close)

We expected that just close LibreOffice, but we sometimes see "LibreOfficeDev Document Recovery" dialog (see attached screenshot) is up.

NOTE: Saving before closing seems OK, the saved file is correct.
Comment 1 Alexandr 2014-11-22 20:25:57 UTC
I see the the dialog even if I do not save the new document (LibreOffice 4.4.0.0beta1 on Windows 7).
Comment 2 A (Andy) 2014-11-25 18:39:49 UTC
Thank you very much for your effort and bug report.

I tried to reproduce it and I experienced a strange issue, even if I do not get exactly the same error message, but I suppose it is probably linked to it.

-> Reproducible with LO 4.4.0.0.beta1, Win 8.1

Steps Done:
1. Open LibreOffice 4.4.0.0.beta1
2. In the start window go to FILE -> NEW -> TEXT DOCUMENT or select WRITER DOCUMENT in the left sidebar
3. Write "test" and press the Enter key for a line break (Attention: it is important that you press the Enter key, only with this it was for me several times in a row reproducible, and don't have any other LO application open at the same time)
4. Go to FILE -> SAVE and select any name and save it as an odt file
5. Close WRITER with the X in the top right

Result: WRITER closed with an error message:
"Runtime Error!
Program: C:\...\LibreOfficeDev 4\program\soffice.bin
R6025
- pure virtual function call"


-> I increased the importance


@Naruhiko: If you follow exactly my steps mentioned above, do you get the same error message?
Comment 3 Naruhiko Ogasawara 2014-11-28 00:18:18 UTC
@Andy,

Thank you to check the issue.

I tried it again, and

> Result: WRITER closed with an error message:
> "Runtime Error!
> Program: C:\...\LibreOfficeDev 4\program\soffice.bin
> R6025
> - pure virtual function call"

I can't see the error message with my Windows 7 64bit (Ja) environment.



> 3. Write "test" and press the Enter key for a line break (Attention: it is important that you press the Enter key, only with this it was for me several times in a row reproducible, and don't have any other LO application open at the same time)

This step is really important.  Without a line break, I couldn't reproduce it.
Comment 4 Naruhiko Ogasawara 2014-11-28 01:08:50 UTC
I can reproduce the issue on Windows Server 2012R2(EN) and I can see the error message mentioned commend #2.  See attached screenshot.
Comment 5 Naruhiko Ogasawara 2014-11-28 01:10:06 UTC
Created attachment 110152 [details]
Runtime error on Windows Server 2012 R2
Comment 6 tommy27 2015-07-23 10:50:25 UTC
@Naruhiko
are you still seeing this bug with recent LibO releases?

would you please look at 
Bug 92807 - Runtime error! R6025 - pure virtual function call after exiting Writer

do you think you are describing the same issue?
Comment 7 Julien Nabet 2016-05-05 10:26:18 UTC
Since there's no feedback after several months, let's put this to RESOLVED/INSUFFICIENTDATA.

Naruhiko/Andy: don't hesitate to reopen this tracker if you can still reproduce this with last stable LO version (5.1.2) + brand new profile (see https://wiki.documentfoundation.org/UserProfile#Windows)