Bug Hunting Session
Bug 86564 - New colour selector: Addition to the standard formatting dialogs
Summary: New colour selector: Addition to the standard formatting dialogs
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
: 88533 (view as bug list)
Depends on:
Blocks: Color-Picker-Widget
  Show dependency treegraph
 
Reported: 2014-11-22 09:56 UTC by A (Andy)
Modified: 2017-02-18 10:16 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description A (Andy) 2014-11-22 09:56:59 UTC
I like this new colour selector already very much.  But could it also be possible to add it to the standard formatting dialogue boxes?

Steps to Reproduce:

1. Open WRITER

2. 
Go to FORMAT -> CHARACTER -> tab FONT EFFECTS -> FONT COLOUR
Go to FORMAT -> CHARACTER -> tab BACKGROUND
Go to FORMAT -> PARAGRAPH -> tab AREA


Result: In all these places it is not possible to access the new colour selector.


Reproduced with LO 4.4.0.0.beta1, Win 8.1.
Comment 1 V Stuart Foote 2014-11-22 18:31:29 UTC
Yup, needs UX-Advise agreement, but enhancement should probably be done as the color picker conversions continue.

Setting New.
Comment 2 Yousuf Philips (jay) (retired) 2014-11-23 00:00:40 UTC
Hi Andy,

Stuart mentioned this recommendation in bug 84267 comment 7 saying, "It would be a very useful enhancement to configure the new color picker GUI to open and manipulate the color values across all tabs of the Area dialog."
Comment 3 A (Andy) 2014-11-23 07:51:50 UTC
Hi Stuart and Jay: 

Thank you very much for your fast replies and comments.

/Andy
Comment 4 Adolfo Jayme 2015-01-17 13:46:01 UTC
*** Bug 88533 has been marked as a duplicate of this bug. ***
Comment 5 Cor Nouws 2015-01-18 11:44:11 UTC
Hi all,

Me too like the new color dialog.
However, the current drop downs have an advantage to: navigating with key board is fast and easy. down, page down, and the start letter of a color all work.
So when that can be included, I'm all for the idea.

What do others think about that?
Cor
Comment 6 Yousuf Philips (jay) (retired) 2015-01-19 20:53:53 UTC
(In reply to Cor Nouws from comment #5)
> However, the current drop downs have an advantage to: navigating with key
> board is fast and easy. down, page down, and the start letter of a color all
> work.

Unfortunately i dont see the drop down being very fast or easy as the colors are not sorted by alphabet or gradient and there are way to many colors (167+) to choose from.
Comment 7 Robinson Tryon (qubit) 2016-08-25 04:21:33 UTC Comment hidden (obsolete)
Comment 8 Heiko Tietze 2017-02-18 10:16:35 UTC
This issue has been fixed for most places. Remaining dialogs are handled in bug 105225.