Bug 105225 - Color palette cannot be chosen in various places
Summary: Color palette cannot be chosen in various places
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard: target:6.1.0 target:6.2.0
Keywords:
: 99806 104172 106244 106741 107842 108527 108900 116232 118151 (view as bug list)
Depends on: 31205 49177 99693
Blocks: Color-Picker-Widget Unify-Across-Apps Color-Palettes UX Area-Fill-Tab-Color
  Show dependency treegraph
 
Reported: 2017-01-09 21:30 UTC by Cor Nouws
Modified: 2018-08-22 07:09 UTC (History)
24 users (show)

See Also:
Crash report or crash signature:


Attachments
Calc - Header&Footer - Background Color UI (54.39 KB, image/png)
2017-11-14 14:45 UTC, Peter Lairo
Details
new highlight tab page for character dialog (52.51 KB, image/png)
2018-01-30 17:36 UTC, Jim Raykowski
Details
new background tab page for Table Properties dialog (187.50 KB, image/png)
2018-01-30 17:38 UTC, Jim Raykowski
Details
Backtrace for crash after Enter for OK (38.59 KB, text/x-log)
2018-07-05 12:01 UTC, Eike Rathke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2017-01-09 21:30:00 UTC
Writer:
 Table > Properties > Background
 Format > Color > Highlighting
 Insert > Section > Background

Calc:
 Format > Cells > Background
 Format > Page > Background

On the positive side (apart from the nice palette (handling) improvements in 5.3): in these cases the palette can be selected in the properties panel in the side bar.
Comment 1 Regina Henschel 2017-01-10 00:56:00 UTC
And another one: Tools > Options > Charts > Default Colors
Comment 2 Heiko Tietze 2017-01-10 13:48:12 UTC
Definitely, those dialogs should provide access to the color palettes (no UX advice needed). But I expect that a ticket has been filed. Jay is usually faster than us.

(In reply to Cor Nouws from comment #0)
> Writer:
>  Format > Color > Highlighting

What format?
Comment 3 Cor Nouws 2017-01-10 14:57:41 UTC
(In reply to Heiko Tietze from comment #2)

> > Writer:
> >  Format > Color > Highlighting
> 
> What format?

Color with the c of Character :D - sorry
Comment 4 Yousuf Philips (jay) (retired) 2017-01-12 09:47:31 UTC
Yes the intent of the new single area tab was to replace all the background and highlighting tabs and disabling various tabs within it when applicable (e.g. we would only need the color tab for Format > Color > Highlighting). Of course the table background would be the trickiest, as you can change the background color of a cell or the table.

Possible duplicate of bug 86564.
Comment 5 Cor Nouws 2017-01-12 14:39:25 UTC
(In reply to Yousuf Philips (jay) from comment #4)

> Possible duplicate of bug 86564.

Sort of, in any case related. But that bug doesn't mention the palette selector as such? And it does not reflect the tremendous and, from what I see, nearly finished work here.
Comment 6 Cor Nouws 2017-01-12 14:42:02 UTC
(In reply to Regina Henschel from comment #1)
> And another one: Tools > Options > Charts > Default Colors

And another one: Calc: context menu on sheet tab .. > Tab Color
Comment 7 Mark Bourne 2017-02-19 14:05:57 UTC
The style editors, as opposed to direct formatting dialogs, also seem to be affected. Perhaps these are based on the same dialogs so, for example, a fix for Format > Cells > Background would also fix the "Background" tab of Calc's Cell Style editor, but thought I'd mention it in case not.

However, the workaround to use the "properties" panel doesn't seem to be an option for editing styles...
Comment 8 Heiko Tietze 2017-03-02 00:23:28 UTC
Raising priority since many users are affected.
Comment 9 Heiko Tietze 2017-03-02 00:28:35 UTC
*** Bug 106244 has been marked as a duplicate of this bug. ***
Comment 10 Heiko Tietze 2017-03-09 13:20:48 UTC
*** Bug 104172 has been marked as a duplicate of this bug. ***
Comment 11 Heiko Tietze 2017-03-09 13:21:09 UTC
*** Bug 99806 has been marked as a duplicate of this bug. ***
Comment 12 Heiko Tietze 2017-03-09 13:21:26 UTC
*** Bug 105740 has been marked as a duplicate of this bug. ***
Comment 13 Aron Budea 2017-03-11 17:30:33 UTC
Heiko, bug 105740 seems to be different (a regression), and not related to this.
Comment 14 Xisco Faulí 2017-03-14 15:05:48 UTC
*** Bug 106534 has been marked as a duplicate of this bug. ***
Comment 15 Thomas Lendo 2017-03-15 15:00:47 UTC
Another places in LibO 5.3.0.3:

Impress:
 Format > Character > Highlighting

Draw:
 Format > Character > Highlighting
Comment 16 Thomas Lendo 2017-03-23 22:12:39 UTC
Another place in LibO 5.3.1.2:

Writer:
 Edit > Find & Replace > Format > Highlighting
Comment 17 Xisco Faulí 2017-03-24 09:39:24 UTC
*** Bug 106741 has been marked as a duplicate of this bug. ***
Comment 18 Telesto 2017-05-14 10:29:13 UTC
*** Bug 107842 has been marked as a duplicate of this bug. ***
Comment 19 Buovjaga 2017-06-18 11:01:59 UTC
*** Bug 108527 has been marked as a duplicate of this bug. ***
Comment 20 Buovjaga 2017-07-04 04:33:22 UTC
*** Bug 108900 has been marked as a duplicate of this bug. ***
Comment 21 Kenneth Hanson 2017-10-29 13:35:57 UTC
How difficult is this to fix?

As a stopgap, could the broken tabs be changed to have just a single dropdown button (the one used in the toolbars, sidebard, and some dialogs)? This might not be ideal, but surely it's better to at least have something functional.
Comment 22 Heiko Tietze 2017-10-29 21:01:21 UTC
(In reply to Kenneth Hanson from comment #21)
> How difficult is this to fix?

Forwarding this question to Jim. Is it in your capabilities?
Comment 23 Jim Raykowski 2017-11-05 19:01:23 UTC
Hi All,

It may take awhile but it is within my capabilities.
Comment 24 Jim Raykowski 2017-11-11 01:57:03 UTC
(In reply to Yousuf Philips (jay) from comment #4)
> Yes the intent of the new single area tab was to replace all the background
> and highlighting tabs and disabling various tabs within it when applicable
> (e.g. we would only need the color tab for Format > Color > Highlighting).
> Of course the table background would be the trickiest, as you can change the
> background color of a cell or the table.
> 
> Possible duplicate of bug 86564.

This was a big help. Been making good progress. Format > Color > Highlighting has been adapted.
Comment 25 Peter Lairo 2017-11-14 14:18:43 UTC
Here's another place another color palette cannot be selected (LibreOffice 5.3.1.2):

Calc:
  Format > Page > Header (or Footer) > More > Background
Comment 26 Peter Lairo 2017-11-14 14:45:23 UTC
Created attachment 137749 [details]
Calc - Header&Footer - Background Color UI
Comment 27 Jim Raykowski 2017-11-19 18:28:23 UTC
Here is a patch that uses the Area tab with relevant buttons displayed according to background needs. Character, Sections, and Table for Writer are functional in this patch. 

The Edit Sections Options still has the bug of not displaying current background in the tab after a document has been closed and reopened. This is a bug in the sections code itself.

Table background is only by cell. A workaround for the 'by cell, row or table' drop down in the old background tab is to select rows, columns, or entire table and then apply background.

https://gerrit.libreoffice.org/#/c/44929/
Comment 28 Yousuf Philips (jay) (retired) 2018-01-25 16:14:20 UTC
(In reply to Jim Raykowski from comment #27)
> Table background is only by cell. A workaround for the 'by cell, row or
> table' drop down in the old background tab is to select rows, columns, or
> entire table and then apply background.

If the row or table is selected, would it be setting the color at the row and table level? What is the intended fix for this temporary workaround? If there isnt an intended fix for this, then table background should be left out of the fix.
Comment 29 Jim Raykowski 2018-01-26 04:58:28 UTC
(In reply to Yousuf Philips (jay) from comment #28)
> (In reply to Jim Raykowski from comment #27)
> > Table background is only by cell. A workaround for the 'by cell, row or
> > table' drop down in the old background tab is to select rows, columns, or
> > entire table and then apply background.
> 
> If the row or table is selected, would it be setting the color at the row
> and table level? What is the intended fix for this temporary workaround? If
> there isnt an intended fix for this, then table background should be left
> out of the fix.

Hi Jay, 

It has been a while since I've looked at this.

Table background is work in progress. In addition to not being able to set table background by row, or table there is the problem of after setting a bitmap background the image is not selected in the bitmap list when the table properties dialog is reopened. This can cause no image to be set if the OK button is pressed without first clicking on a bitmap in the list. It has to do with the new background tab needing loext:graphic-properties to reselect the image. At this time it is beyond my knowledge of how to do this. 

Maybe the best thing would be to abort the current patch and make separate commits under this bug report for each reported place that will use the new background tab? Using the new background tab for character highlighting is the only place that I feel is ready at this time.
Comment 30 Mike Kaganski 2018-01-26 06:34:05 UTC
(In reply to Jim Raykowski from comment #29)
> Maybe the best thing would be to abort the current patch and make separate
> commits under this bug report for each reported place that will use the new
> background tab? Using the new background tab for character highlighting is
> the only place that I feel is ready at this time.

Please do this! :) This would allow for incremental progress, and also for parallelism in implementing that for different areas (if others would like, they could coordinate their work here with you).
Comment 31 Yousuf Philips (jay) (retired) 2018-01-28 14:06:06 UTC
(In reply to Jim Raykowski from comment #29)
> Maybe the best thing would be to abort the current patch and make separate
> commits under this bug report for each reported place that will use the new
> background tab? Using the new background tab for character highlighting is
> the only place that I feel is ready at this time.

+1
Comment 32 Jim Raykowski 2018-01-28 19:02:46 UTC
Here is a link to a patch for the table properties background tab page based on the area tab page with set by cell, row, table.

https://gerrit.libreoffice.org/#/c/48797/
Comment 33 Regina Henschel 2018-01-28 19:41:45 UTC
(In reply to Jim Raykowski from comment #32)
> Here is a link to a patch for the table properties background tab page based
> on the area tab page with set by cell, row, table.
> 
> https://gerrit.libreoffice.org/#/c/48797/

Please notice the discussion in bug 103602. For page exists a consensus to use <style:drawing-page-properties>. But for the other cases, e.g. tables, a consensus how and where to put the information in file format is still missing. 

Your proposal misses save and load totally.


(In reply to Jim Raykowski from comment #29)
> Using the new background tab for character highlighting is
> the only place that I feel is ready at this time.

I disagree. There exists not even a consensus, whether gradient, image, or hatch should be allowed for characters.
Comment 34 Thomas Lendo 2018-01-29 08:32:58 UTC
(In reply to Regina Henschel from comment #33)
> (In reply to Jim Raykowski from comment #29)
> > Using the new background tab for character highlighting is
> > the only place that I feel is ready at this time.
> I disagree. There exists not even a consensus, whether gradient, image, or
> hatch should be allowed for characters.
I support this to enhance the highlighting possibilities, but I assume this is the right place for it? We would flood this bug with discussions about a half dozen of different places where some want more filling options than before. It's better to only coordinate/collect the implementation here.
Comment 35 Thomas Lendo 2018-01-29 11:39:33 UTC
(In reply to Thomas Lendo from comment #34)
> I support this to enhance the highlighting possibilities, but I assume this
> is the right place for it? We would flood this bug with discussions about a
> half dozen of different places where some want more filling options than
> before. It's better to only coordinate/collect the implementation here.
... this is _not_ the right place ...
Comment 36 Jim Raykowski 2018-01-30 17:36:25 UTC
Created attachment 139448 [details]
new highlight tab page for character dialog
Comment 37 Jim Raykowski 2018-01-30 17:38:24 UTC
Created attachment 139449 [details]
new background tab page for Table Properties dialog
Comment 38 Jim Raykowski 2018-01-30 17:51:25 UTC
Hi All,

As Jay noted in comment 4 the Area background tab page can be used as a base for the highlight and background tab pages by disabling various tabs within it (hatch, pattern, bitmap, etc).

Attached are screen shots that show the purposed highlight tab page for the character dialog and background tab page for the table properties dialog.
Comment 39 Cor Nouws 2018-02-04 22:27:23 UTC
(In reply to Jim Raykowski from comment #38)

> Attached are screen shots that show the purposed highlight tab page for the
> character dialog and background tab page for the table properties dialog.

Look good & clear to me - thanks so far!

(Tend to agree with Thomas in principle comment #34 - but since we are so far with these two ones... for practical reasons..)
Comment 40 Jay 2018-02-06 20:09:19 UTC Comment hidden (obsolete)
Comment 41 Aaron Digulla 2018-02-12 19:37:14 UTC
Will this make it into of the next releases? I'm currently editing colors using the fodt format and a text editor ... (I need to change the background for a character style).
Comment 42 V Stuart Foote 2018-03-06 17:07:47 UTC
*** Bug 116232 has been marked as a duplicate of this bug. ***
Comment 43 Commit Notification 2018-04-09 07:15:07 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=41f1a38b9e8b5e0567bf642d3e14a549e82ee0d9

tdf#105225 A table properties background tab page

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 44 Commit Notification 2018-04-12 08:21:29 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cac80ccacf917e7e80f75c3574cc2a300f1d775a

tdf#105225 A character highlighting tab page based on the area tab page

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 45 Xisco Faulí 2018-05-29 09:25:47 UTC
A polite ping to Jim Raykowski:
Is this bug fixed? if so, could you please close it as RESOLVED FIXED ? Otherwise, Could you please explain what's missing?
Thanks
Comment 46 Jim Raykowski 2018-05-30 06:34:39 UTC
(In reply to Xisco Faulí from comment #45)
> A polite ping to Jim Raykowski:
> Is this bug fixed? if so, could you please close it as RESOLVED FIXED ?
> Otherwise, Could you please explain what's missing?
> Thanks

Only Writer table properties background and character highlighting have been done.

 Remaining requests gathered from comments are:

Writer:
 Insert > Section > Background
 Edit > Find & Replace > Format > Highlighting
 
Calc:
 Format > Cells > Background
 Format > Page > Background
 Format > Page > Header (or Footer) > More > Background
 Sheet > Sheet Tab Color

Impress:
 Format > Character > Highlighting

Draw:
 Format > Character > Highlighting

All:
 Tools > Options > Charts > Default Colors
Comment 47 Jim Raykowski 2018-05-31 23:49:40 UTC
Here is a patch for

Writer:
 Insert > Section > Background
and
 Section context menu > Edit Section...

https://gerrit.libreoffice.org/#/c/55149/
Comment 48 Jim Raykowski 2018-06-01 04:31:52 UTC
Hi All,

I came across another place in Writer for this:

 Insert > Table of Contents and Index > Table of Contents, Index or Bibliography... > Background

and

 Table of Contents context menu > Edit Index > Background

Here is a patch to use the new Background tab for these:
https://gerrit.libreoffice.org/#/c/55151/
Comment 49 Commit Notification 2018-06-01 22:52:15 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=94cb2ac3cb5f2c951f70c3bf6b28aad9e2c0bdb7

tdf#105225 A section background tab page based on the area tab page

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 50 Commit Notification 2018-06-01 22:52:26 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6a4db3a7a57926d586bb4e43ae2d77ea29847fcd

tdf#105225 A TOX background tab page based on the area tab page

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 51 V Stuart Foote 2018-06-14 18:51:10 UTC
*** Bug 118151 has been marked as a duplicate of this bug. ***
Comment 52 Jim Raykowski 2018-06-21 07:26:32 UTC
Here is a patch to use the new background tab page in the Calc Page Style dialog:

https://gerrit.libreoffice.org/#/c/56218/
Comment 53 Jim Raykowski 2018-06-21 07:37:05 UTC
I forgot to post a patch made a while back that uses the new background tab page in Calc Format Cells dialog:

https://gerrit.libreoffice.org/#/c/55357/
Comment 54 Commit Notification 2018-06-24 23:13:21 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=76d9d6c9bf0167d4203d7e2f6867254687915caa

tdf#105225 new background tab page for Calc Format Cells dialog

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 55 Jim Raykowski 2018-06-28 06:10:10 UTC
This patch is for Draw/Impress Highlighting tab page in the Character dialog

https://gerrit.libreoffice.org/#/c/56574/
Comment 56 Eike Rathke 2018-07-04 14:33:40 UTC
@Jim:
With that change in Calc the old "No Fill" selection seems to have been replaced by the None button, but selecting that None and OK applies some blueish background instead of none/nofill.
Comment 57 Eike Rathke 2018-07-04 14:42:45 UTC
And invoked on a not-filled cell the Active colour shouldn't be represented as White.
Comment 58 Jim Raykowski 2018-07-05 03:52:38 UTC
Hi Eike, 

I'm at bit of a loss how that got by me. Need the XATTR_FILLSTYLE attribute in the passed itemset here to let the area tab page know what background/area sub tab page to select on invocation. Thanks for letting me know.

Here is the patch:
https://gerrit.libreoffice.org/#/c/56983/
Comment 59 Commit Notification 2018-07-05 10:48:02 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f432d96eb30c91578f11491778a7c3fb823f166a

tdf#105225 fix new background tab page in calc format cells dialog

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 60 Eike Rathke 2018-07-05 12:01:03 UTC
Created attachment 143317 [details]
Backtrace for crash after Enter for OK

Thanks.

There's a crash though:

1. invoke dialog on not-filled cell
2. None is selected (nice)
3. click Color button
4. click a color
5. hit Enter for OK => crash
   does not happen when clicking OK

Same happens in Writer for a table cell or page background, so looks like a generic problem of this dialog tabpage, apparently a widget is notified too late after disposed.
Crash is deep down in weld::CustomWeld::DoLoseFocus(), see attached backtrace.
Comment 61 Xisco Faulí 2018-07-05 12:07:23 UTC Comment hidden (obsolete)
Comment 62 Xisco Faulí 2018-07-05 12:13:50 UTC Comment hidden (obsolete)
Comment 63 Xisco Faulí 2018-07-05 12:28:42 UTC
Crash reported in comment 60 reported in bug 118549
Comment 64 Jim Raykowski 2018-07-07 03:25:50 UTC
Hi All,

I've sent in a patch that replaces the old background tab page with the new background tab page for all uses except a couple I found in the Report code that I don't know how to test or what it is.

Here is the patch:
https://gerrit.libreoffice.org/#/c/57102/
Comment 65 HKR 2018-08-21 13:17:56 UTC
In Calc still the selection of palettes is missing under

MainMenu > cells > Background > Background Color

Version: 6.1.0.3 (x64)
Build-ID: efb621ed25068d70781dc026f7e9c5187a4decd1
Comment 66 Jim Raykowski 2018-08-22 07:09:05 UTC
(In reply to HKR from comment #65)
> In Calc still the selection of palettes is missing under
> 
> MainMenu > cells > Background > Background Color
> 
> Version: 6.1.0.3 (x64)
> Build-ID: efb621ed25068d70781dc026f7e9c5187a4decd1

As of now this won't be available until 6.2.0