Bug 122977 - CRASH: "Tools"->"Options" "LibreOfficeDev"->"Charts"->"Default Colors"
Summary: CRASH: "Tools"->"Options" "LibreOfficeDev"->"Charts"->"Default Colors"
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+ Master
Hardware: All Windows (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.3.0 target:6.2.1
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Options-Dialog
  Show dependency treegraph
 
Reported: 2019-01-25 18:27 UTC by himajin100000
Modified: 2019-01-30 12:48 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description himajin100000 2019-01-25 18:27:38 UTC
Description:
see steps to reproduce

Steps to Reproduce:
1. "Tools"->"Options"
2. "LibreOfficeDev"->"Charts"->"Default Colors"

Actual Results:
CRASH

Expected Results:
NO CRASH


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.3.0.0.alpha0+ (x64)
Build ID: 13279b94080d87dde51bc8b8c669212bf71cacca
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-01-23_04:38:36
Locale: ja-JP (ja_JP); UI-Language: en-US
Calc: threaded
Comment 1 raal 2019-01-25 20:29:31 UTC
no crash Version: 6.3.0.0.alpha0+
Build ID: 3fa4674615b747e219afe5bf0a9b689df3840439
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: x11;
Comment 2 Roman Kuznetsov 2019-01-26 07:25:03 UTC
no repro in

Версия: 6.1.4.2
ID сборки: 1:6.1.4-0ubuntu0.18.10.1
Потоков ЦП: 4; ОС:Linux 4.18; Отрисовка ИП: по умолчанию; VCL: gtk3_kde5; 
Локаль: ru-RU (ru_RU.UTF-8); Calc: group threaded

Possible win only bug, possible regression

himajin100000@gmail.com did you have a crash report after your crash?
Comment 3 baffclan 2019-01-26 07:44:28 UTC
Reproduce with master/Win-x86_64@42.

Version: 6.3.0.0.alpha0+ (x64)
Build ID: 82ed9aa096aea95c2a9fe0ca9c1d27b70dcbc8fa
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-01-24_02:04:07
Locale: ja-JP (ja_JP); UI-Language: en-US
Calc: threaded

Windows only?
Comment 4 baffclan 2019-01-26 07:57:55 UTC
no reproduce with master/Win-x86_64@42/2018-12-17_03:47:50.

Version: 6.3.0.0.alpha0+ (x64)
Build ID: 7176211382cc288750273e16ea7eb206854be33f
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-12-17_03:47:50
Locale: ja-JP (ja_JP); UI-Language: en-US
Calc: threaded
Comment 5 raal 2019-01-26 09:28:58 UTC
This seems to have begun at the below commit.
Adding Cc: to Jim Raykowski ; Could you possibly take a look at this one? Thanks

631f7b6f7e254e69e3dcb2607dc24bedd6d53a81 is the first bad commit
commit 631f7b6f7e254e69e3dcb2607dc24bedd6d53a81
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Tue Jan 1 14:11:05 2019 -0800

    source sha:82df20eeb8f071aaf3780b111aaa27fbc1b2dc9a

author	Jim Raykowski <raykowj@gmail.com>	2018-12-09 23:16:18 -0900
committer	Markus Mohrhard <markus.mohrhard@googlemail.com>	2019-01-01 23:02:05 +0100
commit	82df20eeb8f071aaf3780b111aaa27fbc1b2dc9a (patch)
tree	805ecd0905cced32e79a209f9276e2e419412396
parent	b8d2d78974fcb3e95de87dd98103e5bc015b7687 (diff)
tdf#105225 Add palette selection to options charts default colors
Comment 6 Jim Raykowski 2019-01-29 05:43:11 UTC
Hi all,

The VM I set up to do lo windows development takes literally days to compile LO. All I can do for now is confirm the crash occurs on windows builds and not linux builds.
Comment 7 Julien Nabet 2019-01-29 13:29:28 UTC
On Win7 with master sources updated today + enable-dbgutil, I could reproduce this.

I noticed this on console:
warn:vcl.layout:4012:6084:C:\BLP\libo-core\include\vcl/builder.hxx:430: widget "table" not found in .ui
warn:vcl.layout:4012:6084:C:\BLP\libo-core\include\vcl/builder.hxx:432: .ui widget "table" needs to correspond to vcl type class SvxColorValueSet
Assertion failed: w, file C:\BLP\libo-core\include\vcl/builder.hxx, line 433
Comment 8 Julien Nabet 2019-01-29 13:41:19 UTC
I can't retrieve bt since I got an abort
Comment 9 Maxim Monastirsky 2019-01-29 14:05:20 UTC
(In reply to raal from comment #5)
> commit	82df20eeb8f071aaf3780b111aaa27fbc1b2dc9a (patch)
> tdf#105225 Add palette selection to options charts default colors

Looking at this commit, it seems that the optchartcolorspage.ui file has a reference to "svxlo-SvxColorValueSet", but actually is should be "svxcorelo-SvxColorValueSet" (because SvxColorValueSet is in the svxcore lib). Maybe someone here could try to modify the .ui file, and see if that helps?
Comment 10 Julien Nabet 2019-01-29 14:37:06 UTC
(In reply to Maxim Monastirsky from comment #9)
> (In reply to raal from comment #5)
> > commit	82df20eeb8f071aaf3780b111aaa27fbc1b2dc9a (patch)
> > tdf#105225 Add palette selection to options charts default colors
> 
> Looking at this commit, it seems that the optchartcolorspage.ui file has a
> reference to "svxlo-SvxColorValueSet", but actually is should be
> "svxcorelo-SvxColorValueSet" (because SvxColorValueSet is in the svxcore
> lib). Maybe someone here could try to modify the .ui file, and see if that
> helps?

I confirm I don't reproduce the crash with:
diff --git a/cui/uiconfig/ui/optchartcolorspage.ui b/cui/uiconfig/ui/optchartcolorspage.ui
index 5e8debc83454..ee23c1cc7450 100644
--- a/cui/uiconfig/ui/optchartcolorspage.ui
+++ b/cui/uiconfig/ui/optchartcolorspage.ui
@@ -146,7 +146,7 @@
                   </packing>
                 </child>
                 <child>
-                  <object class="svxlo-SvxColorValueSet" id="table:border">
+                  <object class="svxcorelo-SvxColorValueSet" id="table:border">
                     <property name="visible">True</property>
                     <property name="can_focus">True</property>
                     <property name="hexpand">True</property>
Comment 11 Caolán McNamara 2019-01-29 14:48:12 UTC
./bin/verify-custom-widgets-libs can be used under Linux to find what will crash on windows if the names are wrong
Comment 12 Commit Notification 2019-01-29 19:52:00 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/5d2dbcbd69a029d5f755111092df9d36ed1c1593%5E%21

Resolves: tdf#122977 widget claimed to be in wrong library

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2019-01-29 20:57:07 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/070c1349e23a2d7c86f333b39c38b273aa8a0a11%5E%21

Related: tdf#122977 widget claimed to be in wrong library

It will be available in 6.2.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Xisco Faulí 2019-01-30 11:24:19 UTC
Verified in

Version: 6.3.0.0.alpha0+
Build ID: b10a3c47a34a4b139e370bfc7d1bb164fb2fcbb2
CPU threads: 16; OS: Windows 6.3; UI render: default; VCL: win; 
Locale: en-GB (en_GB); UI-Language: en-US
Calc: threaded

@Caolán, thanks for fixing this!!
However, I don't understand why it has been backported to 6-2 if the original commit is only in master
Comment 15 Commit Notification 2019-01-30 12:48:54 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/20408e88a93a30bf29de60057d09f8a0ef2951c9%5E%21

add test for Options-Chart-Default colors tdf#122977

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.