Bug 105740 - Applied background color is not selected when opening Format > Cells > Background
Summary: Applied background color is not selected when opening Format > Cells > Backgr...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.2.5.1 release
Hardware: All All
: medium normal
Assignee: Eike Rathke
QA Contact:
URL:
Whiteboard: target:6.0.0 target:5.4.0.1 target:5.3.5
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Color-Picker-Dialog
  Show dependency treegraph
 
Reported: 2017-02-04 02:56 UTC by brucehohl
Modified: 2017-08-11 15:55 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description brucehohl 2017-02-04 02:56:04 UTC
Description:
Format > Cells > Background: Text description of background color no longer shown for a cell with a background color when Format > Cell > Background is opened.

Steps to Reproduce:
1. Add background color to a cell & note that the color description is displayed in text just below the color palette.
2. Close Format Cells.
2. Select the cell with the background color.
3. Re-open Format > Cells, Background tab. Observe that the text description is no longer shown.

Actual Results:  
Text description of color not shown in version 5.2.5.1.

Expected Results:
Text description of color should have been displayed as in version 5.2.4.2.


Reproducible: Always

User Profile Reset: No but tested on multiple PC - Windows & Linux.

Additional Info:
Display of text description of the color is a very useful feature as it allows the user to verify that the exact color wanted has been used - for professional looking results.

OK in LO 5.2.4.2; Not OK in LO 5.2.5.1.
This bug might have been introduced with the recent fix for bug 101588.


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:51.0) Gecko/20100101 Firefox/51.0
Comment 1 Xisco Faulí 2017-02-06 09:55:53 UTC
Confirmed in

Version: 5.4.0.0.alpha0+
Build ID: a296a69c984b17cfbcd249cf6bdc191d08dff2a6
CPU Threads: 1; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-02-06_00:00:55
Locale: es-ES (es_ES); Calc: group

but not in

Version: 5.3.0.0.beta2+
Build ID: 6238f71ddbdc766e733b1c808a4fa7d66f7bde87
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk2; Layout Engine: new; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 2 Aron Budea 2017-02-17 03:24:48 UTC Comment hidden (bibisection)
Comment 3 Aron Budea 2017-02-17 03:27:27 UTC
The bug is not only that the description is not shown, the color itself isn't selected in the color picker, either.
This issue started with the commit referenced below. Adding Cc: to Eike Rathke, please take a look.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=638f40d16c9e0b01e3cb0f53d9d5703a361b2100
author		Eike Rathke <erack@redhat.com>	2016-12-12 20:24:20 (GMT)
committer	Eike Rathke <erack@redhat.com>	2016-12-13 10:00:48 (GMT)

"Resolves: tdf#101588, do not prevent color de-selection tdf#96382 follow-up"
Comment 4 Heiko Tietze 2017-03-09 13:21:26 UTC
Lets collect the issues for missing palettes or access to a different area style in bug 105225.

*** This bug has been marked as a duplicate of bug 105225 ***
Comment 5 Heiko Tietze 2017-03-11 19:06:54 UTC
(In reply to Aron Budea from bug 105225 comment #13)
> Heiko, bug 105740 seems to be different (a regression), and not related to
> this.

Than let us set it to NEW.
Comment 6 Commit Notification 2017-06-20 22:03:15 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=aee66aa85e75f67135e5c6079a281e18402d261a

Resolves: tdf#105740 select without selecting.. tdf#101588 b0rk

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Eike Rathke 2017-06-20 22:10:17 UTC
Pending review
https://gerrit.libreoffice.org/39025 for 5-4
https://gerrit.libreoffice.org/39026 for 5-3
Comment 8 Commit Notification 2017-06-21 09:14:54 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=21cf4bb57665af0c7e2dad01729e8e18480c1b90&h=libreoffice-5-4

Resolves: tdf#105740 select without selecting.. tdf#101588 b0rk

It will be available in 5.4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2017-07-11 17:07:56 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1096d1c237a2c4fc7497dd073d0f62bb01ffe925&h=libreoffice-5-3

Resolves: tdf#105740 select without selecting.. tdf#101588 b0rk

It will be available in 5.3.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Cor Nouws 2017-08-11 15:05:11 UTC
OK in Version: 6.0.0.0.alpha0+
Build ID: 368b583b992f2e9cad46c2362c9529a07c36d7a9
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-08-10_02:55:46
Locale: nl-NL (nl_NL.UTF-8); Calc: group