Bug 86596 - 4.4.0.0.beta1 On my Gnome3 with installed libvclplug_gtklo.so not work drop down menus for toolbar buttons Undo, Redo, Font/Bkgr color, Highlighting etc.
Summary: 4.4.0.0.beta1 On my Gnome3 with installed libvclplug_gtklo.so not work drop d...
Status: RESOLVED DUPLICATE of bug 86198
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-23 01:13 UTC by Maxim Britov
Modified: 2015-03-24 06:46 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maxim Britov 2014-11-23 01:13:46 UTC
It may environment related, may not...

I'm on Gentoo ~amd64 with:
[IP-] [  ] x11-libs/gtk+-2.24.25:2
[IP-] [  ] x11-libs/gtk+-3.12.2:3
[IP-] [  ] gnome-base/gnome-shell-3.12.2:0

LO ebuild 4.3.2.1 works fine.
LO 4.4beta1 copied from rpms into /opt
When I install lodevbasis4.4-gnome-integration-4.4.0.0.beta1-1.x86_64 I found I can't use drop down menu for Undo/Redo, only work as button for single operation. I found some buttons doesn't work too, like Font / Background colours in Calc and Font Color / Highlighting in Writer.

When I removing libvclplug_gtklo.so than buttons work fine.
Comment 1 Maxim Britov 2015-01-03 23:39:00 UTC
Fixed for me with Gnome update from 3.12 to 3.14
Comment 2 Buovjaga 2015-01-13 16:48:48 UTC
WFM per comment 1.
Comment 3 Tohotom 2015-02-05 20:18:15 UTC
This bug is still present in version 4.4.0.3. 

Under Gnome 3.12 the workaround proposed in the the Description pretty much ruins desktop integration.

The bug also affects LO under Win 7 32bit, with a slight difference: the drop down menus will appear after approx. 5-10 seconds.
Comment 4 Buovjaga 2015-02-06 06:35:04 UTC
Tohotom: I can't reproduce on Win 7 64-bit 4.4.0.3 (32-bit build). What you are describing is a different issue anyways.

Would be cool to hear your experience with Gnome 3.14.

The REOPENED status is reserved for bugs that were assigned to a developer.

Set to NEEDINFO.
If the dropdowns work in Gnome 3.14, I would set this to WFM again.
The Windows issue would need a new report.
Comment 5 Tohotom 2015-02-06 16:01:10 UTC
I'm running Ubuntu Gnome 14.04, with Gnome Shell 3.12 via PPA, so unfortunately I'm stuck with 3.12 because I don't have the time right now to upgrade my system. I'll wait for GS 3.14 until April when Ubuntu 15.04 will come out. Until then I hope someone else could give more info on this issue.
Comment 6 Maxim Britov 2015-02-06 16:11:28 UTC
(In reply to Tohotom from comment #5)
> I'm running Ubuntu Gnome 14.04, with Gnome Shell 3.12 via PPA, so
> unfortunately I'm stuck with 3.12 because I don't have the time right now to
> upgrade my system. I'll wait for GS 3.14 until April when Ubuntu 15.04 will
> come out. Until then I hope someone else could give more info on this issue.

You may try to remove this file or chmod it to something 0600 root.root for test
/usr/lib/libreoffice/program/libvclplug_gtk3lo.so
Without this file LO should use gtk2 backend.
IMHO
Comment 7 Maxim Britov 2015-02-06 16:13:38 UTC
(In reply to Maxim Britov from comment #6)
> You may try to remove this file or chmod it to something 0600 root.root for
> test
> /usr/lib/libreoffice/program/libvclplug_gtk3lo.so
> Without this file LO should use gtk2 backend.
> IMHO

If you have libvclplug_gtklo.so for gtk2 :)
Comment 8 Tohotom 2015-02-06 16:45:56 UTC
Removing just libvclplug_gtk3lo.so did not change anything for me. Removing libvclplug_gtklo.so (or both of them), will make the drop down menus work, but it will break desktop integration (different font, windows, etc.).
Comment 9 Adolfo Jayme 2015-03-24 06:46:53 UTC

*** This bug has been marked as a duplicate of bug 86198 ***