Bug Hunting Session
Bug 86608 - "Tools - Color Replacer": cannot replace the color with Drawing
Summary: "Tools - Color Replacer": cannot replace the color with Drawing
Status: RESOLVED DUPLICATE of bug 55592
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: x86-64 (AMD64) All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-23 06:56 UTC by hoi
Modified: 2014-12-03 06:35 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
cannot replace the color with draw (129.94 KB, image/png)
2014-11-23 06:56 UTC, hoi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description hoi 2014-11-23 06:56:11 UTC
Created attachment 109883 [details]
cannot replace the color with draw

start Draw

1.draw a shape.
2.tools > the replacement of the color.
3.sellect a color in the shape.
4.sellect a color after the  replacemet.
5.But the button of the replacement is gray out. so I cannot put down the button.
Comment 1 hoi 2014-11-23 07:05:10 UTC
I tested LO4.4.0 beta1.
Comment 2 A (Andy) 2014-11-23 08:40:28 UTC
Reproducible with LO 4.4.0.0.beta1, Win 8.1

Steps Done:
1. Open DRAW
2. Draw a shape like a rectangle
3. Go to TOOLS -> COLOUR REPLACER
4. Click on the PIPETTE icon and then move the cursor on the shape to select its colour and then make a left mouse click to select it
5. Select any other colour for "Replace with"

Result: The REPLACE button is greyed out.  But I have also the same already in LO 4.3.4.1.
Comment 3 Julien Nabet 2014-11-27 21:18:33 UTC
I noticed that SvxBmpMaskSelectItem::StateChanged (svx/source/dialog/_bmpmask.cxx) is called only once and not when clicking on checkbox.
Therefore "IsExecReady" var stays to 0 and the aBtnExec (the Replace button) can't be enabled.
Comment 4 Maxim Monastirsky 2014-11-27 21:49:48 UTC
Well, the help talks about images, there is no mention of shapes, so I guess it never worked for shapes. Let's turn it into an enhancement request then.
Comment 5 Kevin Suo 2014-12-03 06:29:59 UTC
*** Bug 86960 has been marked as a duplicate of this bug. ***
Comment 6 Kevin Suo 2014-12-03 06:32:27 UTC
"oldest" in bibisect-42all repo is the first build I can reproduce. (LibreOffice 3.5.0 Build ID: d6cde02)
Comment 7 Kevin Suo 2014-12-03 06:33:28 UTC
*** Bug 55904 has been marked as a duplicate of this bug. ***
Comment 8 Kevin Suo 2014-12-03 06:35:38 UTC
There is an earlier feature request: Bug 55592.
Set as duplicate of bug 55592.

*** This bug has been marked as a duplicate of bug 55592 ***