Bug Hunting Session
Bug 86678 - TOOLBAR: Underlined letters in new drop downs not working
Summary: TOOLBAR: Underlined letters in new drop downs not working
Status: RESOLVED DUPLICATE of bug 84699
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha2
Hardware: Other Linux (All)
: highest normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: accessibility
Depends on:
Blocks: Writer-Toolbars
  Show dependency treegraph
 
Reported: 2014-11-25 01:55 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-06-27 14:44 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-11-25 01:55:39 UTC
In a number of new toolbar drop downs like the new color picker, line spacing, and insert table, there are underlined letters that should pick a particular button if you type the underscored letter, but unfortunately this does not work. This issue can only be found in 4.4 and master.

We do have drop downs with similar underlined letters that do work when pressed like new, paste special, and insert field.

Version: 4.4.0.0.alpha2+
Build ID: 797db638870f5c6192e72c0b4669b471788e16ea
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2014-11-20_03:50:17
Comment 1 tommy27 2014-11-25 06:30:53 UTC
I confirm it under Win8.1x64 using  4.5.0.0.alpha0+
Build ID: 84a6d8eeaab540e5b2ea3baffd919903dff8c247
TinderBox: Win-x86@39, Branch:master, Time: 2014-11-22_23:41:04
Locale: it_IT

if this bug is already present in 4.4.x as you reported the version number has to be changed accordingly so I'm editing that field
Comment 2 Yousuf Philips (jay) (retired) 2014-12-07 19:02:35 UTC
Kendy stated in a previous design meeting that the underlines should be removed to solve this issue, as they werent there previously in the insert table or line spacing drop downs.
Comment 3 V Stuart Foote 2014-12-07 20:55:02 UTC
Actually, it is a UX consistency and accessibility issue.

The hard coded menus have tilde "~", the .UI based menus and dialogs use underscore "_" to assign the key assigned as an accelerator--and that need to be announced in assistive technology interfaces.

So, the underline could be removed--especially if there is no action actually assigned to the accelerator, but that would not result in the UI/UX that is needed.

Consistent accelerators on menus and for button dialogs are fundamental to providing accessibility support.

Ideally every menu item should have an accelerator assigned, and to extent possible every button widget should have an accelerator so that the UI can be used efficiently without use of a mouse or with a dependency on a visual display.

Some would be global, some would be contextual to the dialog or panel that is active. Either way there are a lot within the UI that still need to be implemented.
Comment 4 Björn Michaelsen 2014-12-18 10:22:02 UTC Comment hidden (obsolete)
Comment 5 Adolfo Jayme 2014-12-18 21:03:08 UTC
This is a technical issue that requires no UX feedback. Please take care of not spamming the ux-advise list with bugs like this one.
Comment 6 V Stuart Foote 2014-12-18 22:01:27 UTC
Should this even be a MAB? 

Probably not, it is just that accelerators for some newly implemented menu items are broken in the UI (actually just not fully implemented--yet) question now is how to fix in a timely fashion.

Design/UX says either remove the offending accelerator assignments ("_"'s in the UI config files), or identify appropriate .uno command to associate and do it. Or some mix there of.
Comment 7 tommy27 2015-06-24 04:11:50 UTC
I retested under Win8.1 x64 and seems it works in LibO 4.4.3.2 and 5.1.0.0 alpha
I set status to WORKSFORME

feel free to revert it if you think I'mwrong
Comment 8 tommy27 2015-06-24 04:12:22 UTC
I retested under Win8.1 x64 and seems it works in LibO 4.4.3.2 and 5.1.0.0 alpha
I set status to WORKSFORME

feel free to revert it if you think I'm wrong
Comment 9 Yousuf Philips (jay) (retired) 2015-08-05 14:25:48 UTC
Issue is still there.

Version: 5.1.0.0.alpha1+
Build ID: 902255645328efde34ddf62227c8278e8dd61ff0
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2015-07-30_05:23:12
Locale: en-US (en_US.UTF-8)
Comment 10 tommy27 2015-08-10 13:39:43 UTC
I confirm it is FIXED under Windows (retested with LibO 4.4.5.1 and recent 5.1.0.0 alpha daily build).

so I change the hardware to Linux according to previous comment
Comment 11 Robinson Tryon (qubit) 2015-12-10 03:37:46 UTC Comment hidden (obsolete)
Comment 12 Maxim Monastirsky 2016-01-25 15:03:08 UTC
Looks to me as a duplicate of Bug 84699.

*** This bug has been marked as a duplicate of bug 84699 ***