Bug Hunting Session
Bug 86699 - Have popular CMIS pre-configured in LO custom dialog
Summary: Have popular CMIS pre-configured in LO custom dialog
Status: RESOLVED DUPLICATE of bug 86703
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: ux-advise (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on: 84642
Blocks: LO-File-Dialog
  Show dependency treegraph
 
Reported: 2014-11-25 11:37 UTC by Yousuf Philips (jay) (retired)
Modified: 2015-03-27 08:16 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-11-25 11:37:50 UTC
Many users, me included, are having difficulties getting access to popular CMIS like Google Drive and it would be useful to have these pre listed in the favourites section of LibO's custom dialog, so users can just click on it, type in their username and password and be on their way.
Comment 1 Joel Madero 2014-11-25 16:00:57 UTC
Thank you for reporting this enhancement request! I can confirm that this is a valid enhancement request on:
Version: 4.3.2.2 release
Platform: Ubuntu Linux 14.10 x64
+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
As I've been able to confirm the enhancement request I am marking as:

New (confirmed)
Enhancement

Note: This only confirms that it is a valid enhancement request and in no way guarantees that the enhancement will be implemented. Enhancements are completed by volunteers who implement it if they themselves want to. That being said we provide no guarantee or ETA.

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
Feel free to come say hi to QA at http://webchat.freenode.net/?channels=libreoffice-qa

LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free.

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 2 Julien Nabet 2014-11-25 20:39:00 UTC
Cédric: I noticed this commit:
http://cgit.freedesktop.org/libreoffice/core/commit/?id=39768755e8db5fb79d398373cdcde2cfd4e0f20a

Certainly I missed something since I don't use this kind of thing but it seems no LO release with this commit would show Google Drive and Alfresco Cloud urls.
(see also http://opengrok.libreoffice.org/xref/core/officecfg/registry/data/org/openoffice/Office/Common.xcu#571).
Any thoughts?
Comment 3 Cédric Bosdonnat 2014-11-26 09:14:25 UTC
(In reply to Julien Nabet from comment #2)
> Cédric: I noticed this commit:
> http://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=39768755e8db5fb79d398373cdcde2cfd4e0f20a
> 
> Certainly I missed something since I don't use this kind of thing but it
> seems no LO release with this commit would show Google Drive and Alfresco
> Cloud urls.
> (see also
> http://opengrok.libreoffice.org/xref/core/officecfg/registry/data/org/
> openoffice/Office/Common.xcu#571).
> Any thoughts?

These are enabled only when building with the client secret and id... which is what is done for the official TDF builds.
Comment 4 Julien Nabet 2014-11-26 19:06:42 UTC
Thank you Cédric for your feedback.
Indeed, I just had checked on LO Debian package (4.3.3 for Debian testing), it wasn't there, so Debian packaging dependent.
I checked on Win7 with LO 4.3.4, Google Drive is present.
Comment 5 Luke 2015-03-04 18:57:18 UTC
This is a generalization of Bug 84642. Implementing it would be a huge win for useability.
Comment 6 Heiko Tietze 2015-03-25 19:03:51 UTC
CMIS was discussed in https://docs.google.com/document/d/191XV116O7TQr5qzdou8JO1vNh5xXJtRujv8r07_SONE/edit and presented at blog post http://user-prompt.com/libreoffice-design-session-cmis-improvement/

Please double check the comments from there as well.
Comment 7 Yousuf Philips (jay) (retired) 2015-03-27 08:15:09 UTC
Closing this in favour of the other bug report.

*** This bug has been marked as a duplicate of bug 86703 ***