Download it now!
Bug 86714 - LibO freezes with 100% of cpu usage. Kill required.
Summary: LibO freezes with 100% of cpu usage. Kill required.
Status: RESOLVED DUPLICATE of bug 69060
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.4.1 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
: 104751 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-11-25 21:02 UTC by caralu1974
Modified: 2019-01-14 19:17 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Document1 (6.31 MB, application/vnd.oasis.opendocument.text)
2015-03-02 12:12 UTC, Gordo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description caralu1974 2014-11-25 21:02:12 UTC
I`ve editing on writer (Versión: 4.3.4.1 Id. de compilación: 430m0(Build:1))a .odt file of 273 pages and lots of tables, when I edit the file LO freezes and quit responding (Using 100% of one CPU) so I must kill it every time. Next I should recover it and lost some of the job.
Comment 1 caralu1974 2014-11-27 17:33:01 UTC
I`ve been testing a little about the problem, I start to save the changes every minute and the program keep running cool, but If I do not save the document and wait to the self program save it freezes. So i think this could refer to the manage of memory or something similar...
Comment 2 tommy27 2014-11-30 21:18:30 UTC
please upload a test file otherwise it will be impossible to debug.
once you have uplaoded that problematic file revert status to UNCONFIRMED
Comment 3 caralu1974 2014-12-02 00:22:11 UTC
I`ve tried, but the file is larger than is permited for the site.
The file is it: https://drive.google.com/file/d/0B64bLLUdl1GAWi1wNUl5cUpNd0k/view?usp=sharing
Comment 4 Gordo 2015-03-02 12:12:40 UTC
Created attachment 113823 [details]
Document1

Copied file from external site and uploaded here.

I set AutoRecovery on and auto save as well.
Typed in a word and waited.
I could see the AutoRecovery in action, but the document did not save.
After manual save file size went from 6.30MB to 3.79MB.
Comment 5 caralu1974 2015-03-02 20:02:52 UTC
Yes, after save the file its change from 6.6 Mb to 302.5 Kb but it lost several pages (Tables) "capitulo 29" complete and keep consuming 100% of CPU.
Today I'm using LibreOffice 3.5.4.2 Build ID: 350m1(Build:2)
I will test with the last beta version and write what happen then.
Thanks in advance!
Comment 6 Robinson Tryon (qubit) 2015-03-14 07:19:05 UTC
TESTING with 4.4.1.2 on Ubuntu 14.04

(In reply to caralu1974 from comment #0)
> ...when I edit the
> file LO freezes and quit responding (Using 100% of one CPU) so I must kill
> it every time.

Attachment 113823 [details] opens fine for me. Deleting a few sentences and re-saving (using Save-As) appears to work okay. Just scrolling around the document, I did experience some short-term freezes, but I'm not sure if that's a factor of editing the file, or just the fact that it's a 281-page document on a not-super-fast laptop.

(In reply to caralu1974 from comment #5)
> I will test with the last beta version and write what happen then.
> Thanks in advance!

Sounds great! I'll put the bug in NEEDINFO status until you can test w/the new version of LibreOffice:
Status -> NEEDINFO
Comment 7 caralu1974 2015-03-17 19:19:48 UTC
I have been testing today (17/mar/2015 17:11 UTC) and look that is working nice, I mean, till I have tested the file does not freezes LO the CPU rise till 26% and 158.0 Mb of RAM. I hope this does not happen again, but i will keep testing for a couple of days, cause today i just expend just 10 or 15 minutes testing.

Versión: 4.4.1.2
Id. de compilación: 40m0(Build:2)
Comment 8 QA Administrators 2015-10-14 19:50:38 UTC Comment hidden (obsolete)
Comment 9 caralu1974 2015-10-15 18:54:29 UTC
Today 15 - 10 -2015 I have tested again using LO Versión: 5.0.2.2
Id. de compilación: 00m0(Build:2) and still freezes whit the file in mention.
Comment 10 caralu1974 2015-10-15 19:00:24 UTC
(In reply to caralu1974 from comment #9)
> Today 15 - 10 -2015 I have tested again using LO Versión: 5.0.2.2
> Id. de compilación: 00m0(Build:2) and still freezes whit the file in mention.

I have an old machine with 2 Gb of RAM
Comment 11 tommy27 2015-10-15 21:10:01 UTC
I can load the test file under Win8.1 x64 in a few seconds using LibO 4.4.5.1 but the loading time is mush longer in LibO 5.0.2.1 where freeze happens for several seconds.

probably your performance is worse since you use an old computer with not much power

anyway, status NEW
Comment 12 caralu1974 2015-10-16 23:23:35 UTC
Today I`ve tested it again with a live Cd of Knoppix 6 using LO 3.6 and run well into my old machine.
I made some changes in the file, changes that  normally causes LO freeze but running 3.6 was normal.
Tahnks in advance to the developers!
Comment 13 caralu1974 2015-10-16 23:33:41 UTC
Sorry I wrote LO 3.6 and it is 3.3.0 and Knoppix 6.4.4.
Comment 14 caralu1974 2015-11-04 18:19:01 UTC
I`ve tested today again with Libreoffice Versión: 5.0.3.2
Id. de compilación: 1:5.0.3~rc2-0ubuntu1~trusty2 and the trouble is the same, 100 % of CPU usage and keep freezed, so LO must be killed.
Comment 15 QA Administrators 2016-11-08 11:54:30 UTC Comment hidden (obsolete)
Comment 16 Telesto 2016-12-20 19:25:46 UTC
*** Bug 104751 has been marked as a duplicate of this bug. ***
Comment 17 Telesto 2016-12-20 19:27:29 UTC
From bug 104751

Actual Results:  
File-opening takes around 33 seconds

Expected Results:
File-opening should take around 10 seconds


Reproducible: Always

User Profile Reset: No

Additional Info:
Around 34 seconds with
Version: 5.4.0.0.alpha0+
Build ID: 53edf60c4ce6ed32f87471e018878c40b788005a
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-18_06:57:59
Locale: nl-NL (nl_NL); Calc: CL

110 seconds with 
Version: 5.0.0.5
Build ID: 1b1a90865e348b492231e1c451437d7a15bb262b
Locale: en-US (nl_NL)

55 seconds Version: 5.1.0.3
Build ID: 5e3e00a007d9b3b6efb6797a8b8e57b51ab1f737
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; 
Locale: nl-NL (nl_NL)

Around 33 seconds with
Versie: 4.1.0.4 
Build ID: 89ea49ddacd9aa532507cbf852f2bb22b1ace28

but not in (around 10 seconds)
Versie 4.0.0.3 (Bouw-id: 7545bee9c2a0782548772a21bc84a9dcc583b89)

--
Callgrind output from 5.4 (attachment 129751 [details])
Comment 18 QA Administrators 2018-07-28 02:43:03 UTC Comment hidden (obsolete)
Comment 19 Telesto 2018-07-30 11:55:08 UTC
Repro with
Version: 6.2.0.0.alpha0+
Build ID: fa881095bc62c3646406c82a98d8503377288a54
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-07-22_03:27:00
Locale: nl-NL (nl_NL); Calc: CL
Comment 20 Xisco Faulí 2018-07-31 08:46:33 UTC
I can't reproduce it in

Version: 6.2.0.0.alpha0+
Build ID: 72b099d279e7096d41a04fe8c0dd493a5fc18a33
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded

time OOO_EXIT_POST_STARTUP=1 instdir/program/soffice /home/xisco/Baixades/Arabe_al_madrasa_org.odt 

real	0m8.377s
user	0m6.653s
sys	0m0.439s
Comment 21 Xisco Faulí 2018-07-31 08:50:59 UTC
it takes around 1 minute in

Versión: 6.1.0.2
Id. de compilación: b3972dcf1284967612d5ee04fea9d15bcf0cc106
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; 
Configuración regional: es-ES (es_ES); Calc: group threaded

thus, change it to WIN only...
Comment 22 Buovjaga 2019-01-14 19:17:39 UTC
This is now fixed! The slowness was due to embedded fonts.

*** This bug has been marked as a duplicate of bug 69060 ***