Bug Hunting Session
Bug 86731 - Spellcheck does not flag missing dictionary
Summary: Spellcheck does not flag missing dictionary
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
4.3.2.2 release
Hardware: Other All
: medium enhancement
Assignee: Vaibhav Rastogi
URL:
Whiteboard: target:6.3.0
Keywords: difficultyBeginner, easyHack, skillCpp
Depends on:
Blocks: Spell-Checking-Dialog
  Show dependency treegraph
 
Reported: 2014-11-26 09:21 UTC by Will Kemp
Modified: 2019-03-19 12:46 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
example file for testing (works if you don't have Somali dictionary) (8.11 KB, application/vnd.oasis.opendocument.text)
2019-03-19 12:44 UTC, Szymon Kłos
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Will Kemp 2014-11-26 09:21:25 UTC
When running spellcheck in Writer without the dictionary for the default language installed, spellcheck appears to check spelling and comes back with "The spellcheck is complete", rather than flagging an error.

To reproduce, change default language to any language you do not have the dictionary installed for, and run spellcheck.

It would be much more sensible if spellcheck flagged the fact that the relevant dictionary is not installed and it cannot check the spelling, rather than acting as if it has checked the spelling and found no errors.
Comment 1 Commit Notification 2019-01-24 17:12:53 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/33f6848dc5abe71471b08dc6a8946feaa2d75ffc%5E%21

tdf#86731 Don't show 'spelling complete' when dictionary is missing

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 2 Xisco Faulí 2019-02-05 17:31:05 UTC
A polite ping to Szymon Kłos:
Is this bug fixed? if so, could you please close it as RESOLVED FIXED ? Otherwise, Could you please explain what's missing?
Thanks
Comment 3 Szymon Kłos 2019-02-05 17:46:32 UTC
Done:
   "The spellcheck is complete" dialog is not shown.

Missing:
   It would be good to show "No dictionary is available" dialog. - this could be an easy hack, I think.
   Pointer: sw/source/uibase/dialog/SwSpellDialogChildWindow.cxx:420
            MessageDialog is used to show warning/info.
Comment 4 Xisco Faulí 2019-02-05 17:49:33 UTC
Hi Szymon Kłos,
Thanks for the code pointer. Let turn it into an easyhack then...
Comment 5 Vaibhav Rastogi 2019-03-18 03:44:49 UTC
A polite query regarding this bug. I have submitted a patch for this bug and it built successfully on review by sir Jenkins. A +1 is been shown against verified and its written that this change needs Code Review Label. It would be great if somebody could help me out as to what is to be done from my side.
Comment 6 Mike Kaganski 2019-03-19 12:21:39 UTC
@Szymon: I have reviewed the patch at https://gerrit.libreoffice.org/69366; I see the code looks reasonable - but since I cannot reproduce the problem myself, could you please review the patch?
Comment 7 Szymon Kłos 2019-03-19 12:44:21 UTC
Created attachment 150100 [details]
example file for testing (works if you don't have Somali dictionary)
Comment 8 Commit Notification 2019-03-19 12:45:48 UTC
Vaibhav committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/35027d2e9fff6e674609fe0659c1ebb8b79c2c1a%5E%21

tdf#86731: Add the dictionary not available message

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Szymon Kłos 2019-03-19 12:46:25 UTC
Fixed, Thank you Vaibhav Rastogi :)