Download it now!
Bug 86751 - FILESAVE: export RTF with Table of Contents corrupts the TOC
Summary: FILESAVE: export RTF with Table of Contents corrupts the TOC
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.7.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:rtf
Depends on:
Blocks: RTF
  Show dependency treegraph
 
Reported: 2014-11-26 20:07 UTC by Luke
Modified: 2017-01-04 01:56 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Simple DOCX with TOC (13.96 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-11-26 20:07 UTC, Luke
Details
RTF with TOC round trip (103.19 KB, image/png)
2014-11-26 20:10 UTC, Luke
Details
Simple RTF with TOC (58.28 KB, application/rtf)
2014-11-26 20:11 UTC, Luke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2014-11-26 20:07:08 UTC
Created attachment 110086 [details]
Simple DOCX with TOC

When you save a file with a TOC as a RTF, the resulting file will have a duplicated TOC. 

Steps to reproduce.
1) Open attachment 110084 [details] in Writer 4.2+
2) Save as RTF
3) Open in Word or OneDrive
4) Compare the original with the exported

It doesn't matter if the original is a DOC, DOCX, or RTF. The exported RTF file will have a corrupted TOC when opened in Word.
Comment 1 Luke 2014-11-26 20:10:48 UTC
Created attachment 110087 [details]
RTF with TOC round trip
Comment 2 Luke 2014-11-26 20:11:50 UTC
Created attachment 110088 [details]
Simple RTF with TOC
Comment 3 Tim Lloyd 2014-11-26 23:40:22 UTC
I don't see the same problem with XP however I do see a problem:

Open your toc.rtf document in Word 2007 
Click on the ToC and this takes us to the correct place
Update ToC and save
Now open toc.rtf in LO4.2.0.4
Click on the ToC and this takes us to the correct place
Close
Now open toc.rtf in LO4.4.0.0 beta1
Click on the ToC and I get a message:

"HYPERLINK#_Toc404771503" is not an absolute URL that can be passed to an external application to open it.

Same problem on Fedora 21 with 4.4.0.0 beta and with 4.3.3.2

Could someone pls advise whether I should open a new report for the problem I see or can this be generic problem with ToC in RTF docs? Starting around 4.2.7?
Comment 4 Luke 2014-11-27 00:33:47 UTC
@Tim Lloyd
I also ran into the 'The "HYPERLINK#_Tocxxx" is not an absolute URL' ERROR and filed it as Bug 86750.
Comment 5 Jacques Guilleron 2014-12-06 12:13:46 UTC
Hi Luke,

I reproduce with LO 4.2.7.0.0+
Build ID: 92216be6ce13990b8ea6b6264c656d2bc1746401
TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2014-07-14_16:21:42
& Windiows 7 Home Premium

I set Status to NEW.

Have a nice day,

Jacques
Comment 6 Luke 2014-12-10 01:40:02 UTC
Adding Michael and Miklos since they both recently worked on RTF TOC issues. You guys have done some amazing work. Thanks!
Comment 7 QA Administrators 2017-01-03 19:40:37 UTC Comment hidden (obsolete)
Comment 8 Luke 2017-01-04 01:56:11 UTC
Verified FIXED in 5.4.0.0.alpha0+ (x64)
Build ID: bf80bbb7b75febc2769d6b64e6981224982f8fe2