Bug 86768 - Incorrect glyph orientation on vertical layout mode on Mac
Summary: Incorrect glyph orientation on vertical layout mode on Mac
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other Mac OS X (All)
: high major
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: target:5.3.0
Keywords:
Depends on: HarfBuzz
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2014-11-27 07:35 UTC by aron
Modified: 2016-11-06 18:35 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
sample odt file (11.57 KB, application/vnd.oasis.opendocument.text)
2014-11-27 07:35 UTC, aron
Details
screen shot - mac.png (130.17 KB, image/png)
2014-11-27 07:35 UTC, aron
Details
screen shot - windows.png (96.36 KB, image/png)
2014-11-27 07:36 UTC, aron
Details
Illustration for explain this bug (97.65 KB, image/png)
2014-11-27 07:37 UTC, aron
Details
A free Mongolian font (315.54 KB, application/x-font-ttf)
2014-11-27 07:38 UTC, aron
Details
fix glyph rotation bug (1.05 KB, patch)
2015-10-01 09:09 UTC, aron
Details
text protrude from its bounding rect (19.52 KB, image/png)
2015-10-01 09:12 UTC, aron
Details

Note You need to log in before you can comment on or make changes to this bug.
Description aron 2014-11-27 07:35:07 UTC
Created attachment 110113 [details]
sample odt file

Some glyph (Mongolian, English) orientation are incorrect on Mac on vertical text direction mode. I create an illustration to explain it.
Selection highlighted area is not fit to glyph boundary.
Comment 1 aron 2014-11-27 07:35:50 UTC
Created attachment 110114 [details]
screen shot - mac.png
Comment 2 aron 2014-11-27 07:36:30 UTC
Created attachment 110115 [details]
screen shot - windows.png
Comment 3 aron 2014-11-27 07:37:20 UTC
Created attachment 110116 [details]
Illustration for explain this bug
Comment 4 aron 2014-11-27 07:38:18 UTC
Created attachment 110117 [details]
A free Mongolian font
Comment 5 Adolfo Jayme 2014-11-27 15:08:56 UTC
Thank you for your bug report.
Comment 6 Michael Stahl 2014-11-27 19:43:36 UTC
why is this bug tagged as "regression" without any indication that it has ever worked in a previous release?  it even has "Inherited from OOo" as version, indicating it's a bug that is many years old.

also if it's happening on Mac only it's probably a bug in VCL not Writer.
Comment 7 Khaled Hosny 2014-11-27 19:57:14 UTC
I don’t think this ever worked in Mac, at least that the impression I got last time I checked the VCL code in Mac since it did not implement any of the stuff the “unx” VCL implements for glyph orientation in vertical layout (which itself needs an overhaul, but that is a different story).
Comment 8 aron 2015-10-01 09:07:47 UTC
I very want to have this bug fixed soon.
I found a way to make glyphs orientation of Mongolian correct. 
This way will make English glyph  rotated in vertical layout, I know this is not expected for people who are native English. But this is the definitely correct way to show English on vertical layout for me.
The problem I could not solve is that the text protrude from their bounding rect.
Comment 9 aron 2015-10-01 09:09:41 UTC
Created attachment 119159 [details]
fix glyph rotation bug
Comment 10 aron 2015-10-01 09:12:42 UTC
Created attachment 119160 [details]
text protrude from its bounding rect