Download it now!
Bug 86860 - Border thickness 1.50 reverts to 0.75 when saved/reopened (.xls and .xlsx only)
Summary: Border thickness 1.50 reverts to 0.75 when saved/reopened (.xls and .xlsx only)
Status: RESOLVED DUPLICATE of bug 61148
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.3.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-29 19:47 UTC by mrelwood
Modified: 2017-06-24 13:22 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
ods file with 0.75 and 1.50 borders (8.30 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-06-24 13:19 UTC, leo3487
Details
same example but saved as xlsx (4.67 KB, application/zip)
2017-06-24 13:21 UTC, leo3487
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mrelwood 2014-11-29 19:47:35 UTC
If I set cells with borders of 1.50pt (or 1.25pt) thickness, the visible thickness is about double compared to the default 0.75. However, if I quit and open the spreadsheet again, the visible thicknesses are now same as with the 0.75, and when right-clicking to "Format Cells...", all borders appear to be of 0.75pt thickness.

Only when I set the borders to 1.75pt thick, is the thicker border stored and recalled on load.

If the thinner borders are all rounded to 0.75pt (or 1pt or whatever), I don't think there should even be a possibility to set the borders to the in-between thicknesses.

Happens with LibreOffice 4.3.3.2 and 4.3.4.1 on OSX 10.10. and 10.10.1.
Comment 1 tommy27 2014-11-30 04:27:26 UTC
not reproducibile under Win8 using LibO 4.3.3.2

(In reply to mrelwood from comment #0)
> ...
> Happens with LibreOffice 4.3.3.2 and 4.3.4.1 on OSX 10.10. and 10.10.1.

so the version fields has to indicate earlier version the bug appeared.


have you tried resetting the user profile?
https://wiki.documentfoundation.org/UserProfile
Comment 2 anthonyds12 2014-11-30 10:39:38 UTC
I tried it, but I can't reproduce it.
I'm also running 4.3.4.1 on OS X 10.10.1
Comment 3 Alex Thurgood 2014-11-30 11:34:34 UTC
@mrelwood : which border are you setting exactly ?

Please provide accurate steps as to how you about this, as the result might depend on the method used.
Comment 4 Alex Thurgood 2014-11-30 11:46:04 UTC
For example, if I apply the 4 border setting to a cell at 1.25pt then it appears visually thicker on screen compared to a default 0.75pt.


If I save the sheet, close LO, the re-open the sheet, my 1.25pt cell border shows approximately the same thickness as the cell with 0.75pt borders, except for right-edge border which appears to de displayed correctly. Note that the cell border properties of my 1.75pt cell are saved correctly, but not displayed as such on screen.

So, if there is a problem, it is with screen display, at least in my tested version 

Version: 4.5.0.0.alpha0+
Build ID: 1386c348f81738a9966d1217db89d1f603466317
Locale: fr_

osx 10.10.1

I'm pretty certain this is a dup, as border thickness display inconsistency has been reported before on bugzilla.
Comment 5 Alex Thurgood 2014-11-30 11:54:49 UTC
A quick search on bugzilla with keywords "libreoffice calc cell border" lists 100 potential existing reports, with what appears to be at least 3 very similar reports (haven't checked them all)
Comment 6 Alex Thurgood 2014-11-30 11:56:00 UTC
Not confirming absence of saved properties, merely visual inconsistency (different buggy behaviour)
Comment 7 mrelwood 2014-11-30 12:36:25 UTC
User profile reset did not help. The exact steps to reproduce:

- Reset user profile (rename folder ~/Library/Application Support(LibreOffice/4/user).
- Launch LibreOffice.
- In the launch screen, click "Calc Spreadsheet".
- Select any single cell, right-click to "Format Cells...".
- In the "Borders" tab, use the small arrow buttons to select Line Width "1.50 pt".
- Click the second Default for Line Arrangement (Set all four borders) and click "OK".
- Type "1.5" in the cell in question.

- Select another single cell (not adjacent), right click to "Format Cells".
- In the "Borders" tab, use the small arrow buttons to select Line Width "0.75 pt".
- Click the second Default for Line Arrangement (Set all four borders) and click "OK".
- Type "0.75" in the cell in question.

- Note that the border at the 1.5 cell is visibly thicker than in the 0.75 cell.
- Select the "1.5" cell, and right-click to "Format Cells...".
- Note that the border thickness is still 1.5.
- Save the Spreadsheet as .xls or .xlsx.
- Quit LibreOffice, and reopen the same Spreadsheet (in LibreOffice).

- Note that the border thicknesses now look the same.
- Right-click the "1.5" cell to "Format Cells...".
- At the "Borders" tab, note that the border thickness has now been changed to 0.75.

Saving in .ods format does not have this issue.
Comment 8 tommy27 2014-11-30 17:25:49 UTC
(In reply to mrelwood from comment #7)
> ....
> Saving in .ods format does not have this issue.

that's why I wasn't able to reproduce...
saving as .xls or .xlsx trigger the bug with border thickness lost after reopening the file.

so the bug is reproducible with Win8.1x64 too using 4.3.3.2 and 4.2.6.2
so it's not a new bug. we should dig bugzilla for potential duplicates as Alex suggested.
Comment 9 Alexander 2015-01-12 18:24:02 UTC
LibreOffice 4.3.3.2 same issue with borders while saving to xls or xlsx. When do they plan to fix it?
Comment 10 QA Administrators 2016-01-17 20:05:31 UTC Comment hidden (obsolete)
Comment 11 tommy27 2016-01-17 20:42:56 UTC
bug still present.
Win8.1 x64
LibO 5.0.4.2
Comment 12 Roeland 2016-07-18 17:59:23 UTC
This is a duplicate of  Bug 61148.

Comment 1 and 4 over there are relevant:

Steps to reproduce:
1. Create a file in LibreOffice Calc. Specify the line thickness of framing any cell 0.4pt, 0.5pt, 0.8pt, 2.0pt. Save the file as test_1.ods. Save the file as test_1.xls (Excel 97/2000/XP/2003) and close it.
2. Reopen test_1.xls in LibreOffice Calc. The thickness of the lines will not match the test_1.ods.

Tested with xls and xlsx and in both the border thickness is mostly changed:
0.75 stays 0.75 
1.00 changed to 0.75
1.25 changed to 0.75
1.50 changed to 0.75
1.75 stays 1.75
2.00 changed to 1.75
Comment 13 Bartosz 2016-08-11 07:52:57 UTC

*** This bug has been marked as a duplicate of bug 61148 ***
Comment 14 leo3487 2017-06-24 13:19:40 UTC
Created attachment 134248 [details]
ods file with 0.75 and 1.50 borders
Comment 15 leo3487 2017-06-24 13:21:09 UTC
Created attachment 134249 [details]
same example but saved as xlsx

As you can see, when save to xlsx, all borders return to 0.75
Comment 16 leo3487 2017-06-24 13:22:58 UTC
When save an xlsx file than contain borders 0.75 and 1.50, all 1.50 borders reset to 0.75