Bug 86891 - LibreOffice dialog for opening files is too wide and can’t be resized when not using clean profile
Summary: LibreOffice dialog for opening files is too wide and can’t be resized when no...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.4.0.0.beta1
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: LO-File-Dialog User-Profile
  Show dependency treegraph
 
Reported: 2014-12-01 04:45 UTC by Junichi Matsukawa
Modified: 2018-02-26 11:02 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
dialog_width (41.58 KB, image/png)
2014-12-01 04:45 UTC, Junichi Matsukawa
Details
registrymodifications.xcu (deleted)
2014-12-13 02:59 UTC, Yousuf Philips (jay) (retired)
Details
dialogue width too long (28.45 KB, image/jpeg)
2014-12-26 06:20 UTC, Junichi Matsukawa
Details
I tryed on LBO5.0.0beta3(win86)win7. Relapsed. (301.61 KB, image/png)
2015-06-12 07:28 UTC, Junichi Matsukawa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Junichi Matsukawa 2014-12-01 04:45:22 UTC
Created attachment 110279 [details]
dialog_width

It is not possible to reduce the width of the dialog of LibreOffice.
LBO4.4.0.0.beta1 86(32bit)windows7

1.tool-option-Libreoffice-general- check use Libreoffice dialog
2.file open
3.It is not possible to reduce the width of the dialog of LibreOffice.
Comment 1 Jacques Guilleron 2014-12-02 17:37:00 UTC
Hi jr4air,

I don't reproduce with 
LO 4.4.0.0.beta1 Build ID: 9af3d21234aa89dac653c0bd76648188cdeb683e Locale: fr_FR
& Windows 7 Home Premium
Did you try to rename your profile?
https://wiki.documentfoundation.org/Documentation/UserProfile#Resetting_the_User-Profile
Can you precise your Locale? This will make easier a try.

Jacques
Comment 2 Junichi Matsukawa 2014-12-06 02:18:08 UTC
Hi. Jacques.

I tryed your recomend.
I succeeded in repairing it.

Thank you for your nice support.

I have translated into Japanese this repair method and will post on my blog.

jr4air
Comment 3 Adolfo Jayme Barrientos 2014-12-09 16:29:06 UTC
Reopening the report, because the dialog’s size, although fixed by cleaning the user profile, should have the correct initial size in all cases. We should find the specific profile thing that is causing LibreOffice to miscalculate the dialog size.
Comment 4 Yousuf Philips (jay) (retired) 2014-12-13 02:59:42 UTC
Created attachment 110800 [details]
registrymodifications.xcu

Hi Adolfo,

This was happening to me as well, so do you need the full profile or just registrymodifications.xcu?
Comment 5 Junichi Matsukawa 2014-12-26 06:20:04 UTC
Created attachment 111356 [details]
dialogue width too long
Comment 6 Junichi Matsukawa 2014-12-26 06:23:28 UTC
1.I installed 4.4.0.1R1 on 4.3.4win7(86).
2.Recurrence of symptoms.
Comment 7 Junichi Matsukawa 2015-06-12 07:28:07 UTC
Created attachment 116479 [details]
I tryed on LBO5.0.0beta3(win86)win7.    Relapsed.
Comment 8 Yousuf Philips (jay) (retired) 2015-06-13 15:40:56 UTC
@Adolfo: Any update on this?
Comment 9 QA Administrators 2016-09-20 10:01:28 UTC Comment hidden (obsolete)
Comment 10 Junichi Matsukawa 2017-10-18 00:40:43 UTC
I tryed this URL.

https://wiki.documentfoundation.org/Documentation/UserProfile#Resetting_the_User-Profile

solved.

Thank you.

Junichi Matsukawa.
Comment 11 Yousuf Philips (jay) (retired) 2017-10-18 17:06:35 UTC
The user shouldnt need to reset their profile to solve this issue. I've provide my user profile in attachment 110800 [details] that should be analyzed to discover what the issue is.

Maxim: Can you have a look into this?
Comment 12 Maxim Monastirsky 2017-10-18 17:31:16 UTC
(In reply to Yousuf Philips (jay) from comment #11)
> Maxim: Can you have a look into this?
Can't reproduce in 5.4/master. But the list of the file name field is populated with the recent files list, and it contains files with a very long path, which might suggest it was a duplicate of Bug 83373.
Comment 13 Yousuf Philips (jay) (retired) 2017-10-18 19:45:12 UTC
(In reply to Maxim Monastirsky from comment #12)
> Can't reproduce in 5.4/master. But the list of the file name field is
> populated with the recent files list, and it contains files with a very long
> path, which might suggest it was a duplicate of Bug 83373.

Guess you are right, though not sure how the recent files list relates to this bug, as they arent shown in the dialog. :D
Comment 14 Maxim Monastirsky 2017-10-18 20:12:50 UTC
(In reply to Yousuf Philips (jay) from comment #13)
> though not sure how the recent files list relates to
> this bug, as they arent shown in the dialog. :D
They are in the list of the "File name" combobox. By default, the minimal width of a combobox is the same as the width of its list, unless you limit it somehow.
Comment 15 Xisco Faulí 2018-02-26 11:02:03 UTC
The content of attachment 110800 [details] has been deleted