Download it now!
Bug 86927 - Error writing content.xml
Summary: Error writing content.xml
Status: RESOLVED DUPLICATE of bug 86963
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.0.beta1
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: odf
Keywords: bisected, regression
Depends on:
Blocks:
 
Reported: 2014-12-02 09:46 UTC by b.o.c.k.y
Modified: 2014-12-09 14:15 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
File from 4.3.4.1 which cannot be saved again in 4.4.0.0 (22.81 KB, application/vnd.oasis.opendocument.text)
2014-12-03 08:04 UTC, b.o.c.k.y
Details

Note You need to log in before you can comment on or make changes to this bug.
Description b.o.c.k.y 2014-12-02 09:46:22 UTC
Hi there,

I opened a writer-document created with 4.3.4.1 in 4.4.0.0.beta1, edited it and tried to save it. But then i got this message:
"Fehler beim Speichern des Dokuments ...:
Schreibproblem.
Fehler beim Schreiben des Teildokuments content.xml"
Translated to english it should be something like this:
"Error saving document ...:
Writeproblem.
Error writing part content.xml"

I tried saving on different locations, but it didn't work.
Perhaps it's due to bibliografic indexes/tables, footnotes etc. It's an academic work, so i need all this stuff :D

it looks quite similar to https://bugs.freedesktop.org/show_bug.cgi?id=60769

Regards
Comment 1 Jacques Guilleron 2014-12-02 15:17:10 UTC
Hi b.o.c.k.y,

Without the document, it's hard to say something about. 
Can you join it as attachment if it contains no confidential information?
Did you try to open it with LO 4.3.4.1 again?

Regards,

Jacques
Comment 2 b.o.c.k.y 2014-12-03 08:04:21 UTC
Created attachment 110395 [details]
File from 4.3.4.1 which cannot be saved again in 4.4.0.0

Editing and saving is still possible in the older libreOffice version.
Saving in the new version is only possible if i delete a drawing created with libreOffice draw and copied into the document. So I deleted everything else from the file with the old version.
Saving the attached file with the newest version is not possible while the drawing stays in the document.
Comment 3 Michael Stahl (CIB) 2014-12-04 22:57:28 UTC
regression from:

commit 01fc08c0b5c57fef8ad3755672f4266d85e849a5
Author:     Miklos Vajna <vmiklos@collabora.co.uk>
AuthorDate: Thu Nov 20 16:44:21 2014 +0100

    fdo#85554 SwXShape: fix getting ZOrder property when doc contains TextBoxes


most likely duplicate of bug 86963
Comment 4 Jacques Guilleron 2014-12-09 14:15:45 UTC
Same behaviour as 86963; As suggested by Michael Stahl, I set Status for this report to Duplicate.

Jacques

*** This bug has been marked as a duplicate of bug 86963 ***