Download it now!
Bug 87010 - EDITING: Corruption of a link to another sheet after an unconnected drag and drop operation.
Summary: EDITING: Corruption of a link to another sheet after an unconnected drag and ...
Status: RESOLVED DUPLICATE of bug 79441
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.7.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 87008 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-12-04 17:49 UTC by Ken
Modified: 2014-12-06 19:04 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Simple before and after illustration pasted link corruption (21.74 KB, application/zip)
2014-12-04 17:49 UTC, Ken
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ken 2014-12-04 17:49:17 UTC
Created attachment 110465 [details]
Simple before and after illustration pasted link corruption

Hardware: AMD FX-4300 Quad-Core Processor x 2

The bug is shown if this procedure is followed:

1. Using "Copy" and "Paste special" I can create a link between a cell copied from Sheet1 and pasted in Sheet2.

2. In Sheet3 I drag and drop the content of any cell to another cell.

3. Save and close the file.

4. Open the file.

5. Look at the copied cell in Sheet2. The cell has lost the reference to Sheet1 and as a result is now copying a cell in it's own sheet (Sheet2)

attachment1 and attachment2 are "before & after" files.
Comment 1 raal 2014-12-05 11:34:15 UTC
*** Bug 87008 has been marked as a duplicate of this bug. ***
Comment 2 Jean-Baptiste Faure 2014-12-06 19:04:12 UTC
Not reproducible for me with version 4.4.0.0.beta2+.
I think that the problem has nothing to do with the action on the sheet 3, but that it is a duplicate of bug 86125 and bug 79441
Please could you give a try to version 4.2.8 RC2 where these bugs are fixed?
You can find it at http://dev-builds.libreoffice.org/pre-releases/

Please reopen if that does not fix the bug for you.

Best regards. JBF

*** This bug has been marked as a duplicate of bug 79441 ***