Bug 87043 - The SUBTOTAL() function in Calc does not ignore hidden rows as in Excel
Summary: The SUBTOTAL() function in Calc does not ignore hidden rows as in Excel
Status: RESOLVED DUPLICATE of bug 60477
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-06 04:47 UTC by Rajendra Parmar
Modified: 2015-01-26 14:51 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample file for test (8.73 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-12-06 05:23 UTC, m.a.riosv
Details
Subtotal() function does not ignore hidden rows - (10.77 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-01-26 14:51 UTC, Rajendra Parmar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rajendra Parmar 2014-12-06 04:47:31 UTC
The SUBTOTAL() function in Calc does not ignore hidden rows. This is very vital issue for all commercial operations. Only because of this simple reason, millions, like me, are not migrating from Excel to Calc.  Please, consider this issue in forth coming 4.4 version.

Rajendra Parmar
Comment 1 m.a.riosv 2014-12-06 04:57:57 UTC
Hi @Rajendra, thanks for reporting.

Please can you attach a sample file, without personal/confidential information, where to verify the issue.
Comment 2 m.a.riosv 2014-12-06 05:23:08 UTC
Created attachment 110499 [details]
Sample file for test

LibreOffice help:
""
SUBTOTAL
Calculates subtotals. If a range already contains subtotals, these are not used for further calculations. Use this function with the AutoFilters to take only the filtered records into account.
""
The function works with filtered records, not with manually hidden records.

This behaviour it's from ever, inherited from OpenOffice.
Comment 3 GerardF 2014-12-06 08:27:04 UTC
Calc only use only args 1 to 11, not 101 to 111.

*** This bug has been marked as a duplicate of bug 60477 ***
Comment 4 Rajendra Parmar 2015-01-26 14:51:05 UTC
Created attachment 112806 [details]
Subtotal() function does not ignore hidden rows -

Subtotal() function does not ignore hidden rows in CALC. Most users of spreadsheets, need such facility of and on. EXCEL offers this facility. To make the Libreoffice effectve and attract user to shift over to CALC from EXCEL, this change is must and need immediate attention.