Bug Hunting Session
Bug 87129 - Show tooltips for paintbrush CTRL and CTRL+SHIFT usage
Summary: Show tooltips for paintbrush CTRL and CTRL+SHIFT usage
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Clear-Formatting Toolbars-Tooltips
  Show dependency treegraph
 
Reported: 2014-12-09 02:19 UTC by Kevin Suo
Modified: 2017-06-09 00:52 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2014-12-09 02:19:12 UTC
The wiki help says:
https://help.libreoffice.org/Common/Copying_Attributes_With_the_Format_Paintbrush
> By default only the character formatting is copied ; to include paragraph 
formatting, hold down Ctrl when you click. To copy only the paragraph formatting,
 hold down Ctrl+Shift when you click.

This is a feature, done by the following commit:

  commit: 1574c76ec20d1da479ed7e9c85a6cefacc132dfe
  Author: Maxime de Roucy <mderoucy@linagora.com>
  Commit: Caolán McNamara <caolanm@redhat.com>

  Format paintbrush default behaviour
  Don't copy paragraph formats by default

I believe this feature is useful. But there are many many users who are not aware of this feature. When they want to format there paragraph and text with paintbrush, they click on the paintbrush icon, select the paragraph or text they want to apply the format, and wait, and finally don't get what they need. (See the many duplicates to bug 59029.)

Thus I am requesting to add a tooltip to this feature for CTRL and CTRL+SHIFT usage.

Steps to reproduce:

1. Select paragraph A.
2. Click the paintbrush toolbar icon.
3. Move your mouse to over the target paragraph/text you want to apply format for.
---> At step 3, a “Paint Bucket” will appear which indicates that you are ready to select the text.

The enhancement request is: 
Show a tooltip box next to the “Paint Bucket”, to tell the user how to apply format for "chars only", "chars and paragraph", and "paragraph only" by holding CTRL and CTRL+SHIFT.
Comment 1 sophie 2014-12-10 15:17:54 UTC
Hi, a valid request :) set to New - Sophie
Comment 2 Yousuf Philips (jay) (retired) 2017-06-07 21:09:19 UTC
We currently display the double-click behaviour of the button which would benefit most users and dont have sufficient space to also mention the ctrl and ctrl+shift behaviours of the button which are for advanced users. So WONTFIX for me.

UX-Team: Please reopen if you disagree.
Comment 3 Heiko Tietze 2017-06-07 21:56:08 UTC
We could introduce multiline tooltips. And definitely better feedback is needed since the cursor also don't tell what function is currently active.
Comment 4 Yousuf Philips (jay) (retired) 2017-06-09 00:52:30 UTC
(In reply to Heiko Tietze from comment #3)
> We could introduce multiline tooltips. And definitely better feedback is
> needed since the cursor also don't tell what function is currently active.

I think extended tooltips provide a sentence long summary that can contain all the info we want users to know. Ideally wrapped after a give number of characters if that isnt already done. Yep clicking modifier keys should likely alter the icon somehow, so please file a bug for that.