Bug 87183 - FILEOPEN: No checkbox symbol displayed for empty mail merge field on .doc import
Summary: FILEOPEN: No checkbox symbol displayed for empty mail merge field on .doc import
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.4.1 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:doc
Depends on:
Blocks: DOC
  Show dependency treegraph
 
Reported: 2014-12-10 06:38 UTC by Timon
Modified: 2021-03-01 11:27 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
In archive: .doc - original problem file, .pdf - pdf files exported in MSO 2007 and LibreOffice 4.3.4.1 to compare (247.20 KB, application/x-zip-compressed)
2014-12-10 06:38 UTC, Timon
Details
Simple test case (26.00 KB, application/msword)
2017-08-28 19:24 UTC, Luke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Timon 2014-12-10 06:38:34 UTC
Created attachment 110667 [details]
In archive: .doc - original problem file, .pdf - pdf files exported in MSO 2007 and LibreOffice 4.3.4.1 to compare

LibreOffice: 4.3.4.1 Build ID: bc356b2f991740509f321d70e4512a6a54c5f243

Try to open attached .doc file

In LibreOffice you'll see that there are no checkboxes in items 3.1 (where percentage is shown), 3.3 and 5.1. In 5.1 you'll see "MERGEFIELD punkt51 \* MERGEFORMAT" and "MERGEFIELD y \* MERGEFORMAT" instead of checkboxes.

But if you'll open the same document in MSO 2007 - they are present everywhere (see .pdf attachments)
Comment 1 raal 2014-12-10 13:15:27 UTC
I can confirm wit LO 4.3.4.1, win7
Comment 2 Xisco Faulí 2015-09-09 09:46:22 UTC
This issue is still present in

Version: 5.0.1.2
Build ID: 81898c9f5c0d43f3473ba111d7b351050be20261
Locale: es-ES (es_ES)

on Windows 7 (64-bit)
Comment 3 QA Administrators 2016-09-20 10:29:24 UTC Comment hidden (obsolete)
Comment 4 Timon 2016-09-20 10:47:20 UTC
Bug is still reproducible with LibreOffice Version: 5.2.2.1
Build ID: 3c2231d4aa4c68281f28ad35a100c092cff84f5d
CPU Threads: 2; OS Version: Windows 5.1; UI Render: default; 
Locale: ru-RU (ru_RU); Calc: group

Absolutely no changes. Everything is as it was when discovered.
Comment 5 Luke 2017-08-28 19:24:50 UTC
Created attachment 135832 [details]
Simple test case
Comment 6 QA Administrators 2018-08-29 02:42:24 UTC Comment hidden (obsolete)
Comment 7 Timon 2018-09-13 11:12:55 UTC
Bug is still reproducible with
LibreOffice Version: 5.4.7.2
Build ID: c838ef25c16710f8838b1faec480ebba495259d0
CPU Threads: 2; OS Version:Windows 5.1; UI Render: default; 
Locale: ru-RU (ru_RU); Calc: group

and

LibreOffice Version: 6.0.6.2
Build ID: 0c292870b25a325b5ed35f6b45599d2ea4458e77
CPU Threads: 2; OS Version:Windows 6.1; UI Render: default; 
Locale: ru-RU (ru_RU); Calc: group

Absolutely no changes. Everything is as it was when discovered.
Comment 8 QA Administrators 2019-09-14 02:48:07 UTC Comment hidden (obsolete)
Comment 9 Timon 2019-09-16 04:32:52 UTC
Bug is still reproducible in
LibreOffice Version: 6.3.2.1 (x64)
Build ID: db810050ff08fd4774137f693d5a01d22f324dfd
CPU Threads: 2; OS Version:Windows 6.1; UI Render: default; VCL: win;
Locale: ru-RU (ru_RU); UI-Language:: ru-RU
Calc: threaded
Comment 10 Svatopluk Vít 2021-03-01 11:27:20 UTC
Bug is still present 

Version: 7.1.1.1 (x64) / LibreOffice Community
Build ID: 575c5867c4cc13d7ae78f9ce39a54a52ed38c769
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Vulkan; VCL: win
Locale: cs-CZ (cs_CZ); UI: en-GB
Calc: threaded