Bug Hunting Session
Bug 87379 - FILEOPEN: Incorrect recognition of tables containing raws or lines with empty cells (after copying cells from RTF)
Summary: FILEOPEN: Incorrect recognition of tables containing raws or lines with empty...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX-Tables RTF-Paste RTF-Tables
  Show dependency treegraph
 
Reported: 2014-12-16 20:48 UTC by Yan Pas
Modified: 2018-10-08 16:20 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
file and screenshot (184.99 KB, application/x-rar-compressed)
2014-12-16 20:48 UTC, Yan Pas
Details
screenshot 5.3 (200.91 KB, image/png)
2017-04-24 21:46 UTC, Yan Pas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yan Pas 2014-12-16 20:48:59 UTC
Created attachment 110929 [details]
file and screenshot

Table is broken in LO. Screenshot and file are attached
Comment 1 Cor Nouws 2014-12-21 20:11:49 UTC
Hi Yan

thanks for the issue; I can confirm the problems:
 - diagonal line in first cell not shown
 - last column is wider (including last cell in row 2)
 - last row is to wide (not only showing the 6th column)

I guess this never worked correctly before (as far as you know) ??
Comment 2 Yan Pas 2014-12-21 20:23:18 UTC
Yes, I think so too. Word has a bit different type of empty cells i guess. In LO you can draw cell without content and borders. The problem appeared after copying cell from RTF. From classical doc as far as I remember tables displayed correctly or almost correctly
Comment 3 Cor Nouws 2014-12-21 20:45:32 UTC
(me loves clear summaries :) )
Comment 4 Matthew Francis 2015-04-11 09:41:35 UTC
Can't find a version that behaves better back to LO 3.3.0

-> Version: Inherited from OOo
Comment 5 tommy27 2016-04-16 07:23:29 UTC Comment hidden (obsolete)
Comment 6 Yan Pas 2016-04-20 13:44:42 UTC
V 5.1.1 and 5.0.5 Bug still presents. Linux
Comment 7 Telesto 2017-04-24 20:14:03 UTC
Table dimensions are ok now. However, the diagonal line in first cell not shown
Version: 5.4.0.0.alpha0+
Build ID: 4354f0e9ef4a5538729a2a6f2d1745e247f6c5cd
CPU threads: 4; OS: Windows 6.19; UI render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-04-21_06:05:57
Locale: nl-NL (nl_NL); Calc: CL
Comment 8 Bartosz 2017-04-24 21:37:27 UTC
The original issue was already solved in LibreOffice 5.2
Regarding diagonal line, there is separate ticket for that:
https://bugs.documentfoundation.org/show_bug.cgi?id=51665
Comment 9 Bartosz 2017-04-24 21:40:09 UTC
I just checked and the table dimension issue is still there on Ubuntu 16.10 and LibreOffice 5.4
Comment 10 Yan Pas 2017-04-24 21:46:54 UTC
Created attachment 132807 [details]
screenshot 5.3

I don't see any isuues with version 5.3 Win 10
Comment 11 Timur 2018-10-08 16:20:43 UTC
(In reply to Cor Nouws from comment #1)
>  - diagonal line in first cell not shown
Bug 51665 (as Bartosz wrote)
>  - last column is wider (including last cell in row 2)
No repro in 6.2+.
>  - last row is to wide (not only showing the 6th column)
No repro in 6.2+.

There are other issues with formula and well known floating table but this with table is WFM.