Download it now!
Bug 87500 - Freeze with English/Japanese mixture undo
Summary: Freeze with English/Japanese mixture undo
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: x86-64 (AMD64) Windows (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard: target:5.1.0 target:5.0.3 target:4.4.6
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-19 15:01 UTC by Naruhiko Ogasawara
Modified: 2016-10-25 19:21 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Naruhiko Ogasawara 2014-12-19 15:01:09 UTC
In Japanese envrionment (Japanese IM (input method) enabled),

Step 1. Set Japanese IM to direct input mode
Step 2. Type some English character (such as "a")
Step 3. Set Japanese IM to Hiragana input mode
Step 4. Type some Japanese Character (such as "あ")
Step 5. Undo

Problem: Writer is freezed.
Comment 2 TANAKA Hidemune 2014-12-22 12:11:42 UTC
This behavior has been observed with Windows 7 64bit. 
It does not occur with Linux.
In Windows, please check to install the IME.

https://www.coscom.co.jp/learnjapanese801/install_ime.html
Comment 3 TANAKA Hidemune 2014-12-22 12:15:38 UTC
The following Japanese environment might need. (May not be necessary)

http://www.froggie.sk/en/index.html
Comment 4 Robinson Tryon (qubit) 2014-12-27 05:45:31 UTC
Based on my understanding, there's confirmation of this problem, so Status -> NEW.
Comment 5 Matthew Francis 2015-04-01 10:27:45 UTC
@TANAKA Hidemune:

Could you possibly submit that patch through gerrit - see:
https://wiki.documentfoundation.org/Development/gerrit

Thanks
Comment 6 Mark Hung 2015-09-06 07:02:36 UTC
It doesn't need to be Japanese.
I can reproduce this with Chinese (ZH-TW).

Version:5.0.0.5
Build ID:1b1a90865e348b492231e1c451437d7a15bb262b
Locale:zh-TW (zh_TW)
Comment 7 Mark Hung 2015-09-07 23:42:37 UTC

*** This bug has been marked as a duplicate of bug 82293 ***
Comment 8 Mark Hung 2015-09-07 23:46:58 UTC
Sorry to bother. tdf#82293 looks related but not sure if it has the same root cause so I revert duplicate field again.
Comment 9 Commit Notification 2015-09-21 11:59:19 UTC
Mark Hung committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e7760d428bc82ccfcae14f1907b78f9f1013b88c

Fix tdf#87500 - Freeze with English/Japanese mixture undo.

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2015-09-26 11:47:53 UTC
Mark Hung committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2b136504538a0b32e6ca9ae8fae8c41c084f4394&h=libreoffice-5-0

Fix tdf#87500 - Freeze with English/Japanese mixture undo.

It will be available in 5.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2015-09-28 08:21:13 UTC
Mark Hung committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=71f8125f21344b5481502d24930bcb6e25369dea&h=libreoffice-4-4

Fix tdf#87500 - Freeze with English/Japanese mixture undo.

It will be available in 4.4.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.