Bug 87522 - LibreOffice Base is freezed when creating a report
Summary: LibreOffice Base is freezed when creating a report
Status: RESOLVED DUPLICATE of bug 88824
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.4.0.0.beta1
Hardware: x86-64 (AMD64) Windows (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-20 06:27 UTC by Naruhiko Ogasawara
Modified: 2015-02-06 10:54 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
backtrace (13.07 KB, text/plain)
2014-12-21 03:56 UTC, Naruhiko Ogasawara
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Naruhiko Ogasawara 2014-12-20 06:27:19 UTC
Environment:
- Windows 7 Professional SP1 64bit (Japanese)
- Java Runtime Environment 1.7.0_55 or 1.8.0_25 (32bit)

How to reproduce:
1. Launch Base, create new database with Database Wizard
2. Click "Reports" in the left pane
3. Click "Create Report in Design View..." or "Use Wizard to Create Report..."
4. Base freezed <-- PROBLEM

5. Launch Base, open the database created step 1 with "Open an existing database file" 
6. same as step 2 and 3
7. Base freezed <-- PROBLEM


NOTE: Similar bug of fdo #87241 (), but I can't reproduce this issue with 4.3.x, only 4.4.0 or master, so I filed it as a different bug.
Comment 1 Naruhiko Ogasawara 2014-12-20 06:35:40 UTC
Confirmed this issue with LibreOffice 4.4.0 beta1, beta2, RC1 and master (Version: 4.5.0.0.alpha0+ Build ID: 170616e9f2d30c1302bbb5a7a4b588bc05cd5cc9).
Couldn't reproduce it with LibreOffice 4.5.3.
Comment 2 tommy27 2014-12-20 09:37:17 UTC
take a look also at Bug 87241 which however has been filed against 4.3.5
Comment 3 Julien Nabet 2014-12-20 12:46:59 UTC
On pc Debian x86-64 with 4.4 branch sources updated today, I don't reproduce the hang (by creating a brand new Hsqldb base or by opening an existing one).

Would it be possible you attach gdb to the process and pinpoint the location of the hang? (see https://wiki.documentfoundation.org/Development/How_to_debug#Attaching_to_the_soffice.bin_process)
Comment 4 Naruhiko Ogasawara 2014-12-20 14:30:48 UTC
Sorry, I forgot to write that I couldn't reproduce this issue on my Ubuntu (14.10) system.  Some reports in Japanese mailing list are also Windows system, and not reproduced on Linux based system.

I'll try to back track in my Windows system.
Comment 5 Naruhiko Ogasawara 2014-12-21 03:56:34 UTC
Created attachment 111098 [details]
backtrace

Version: 4.5.0.0.alpha0+
Build ID: 170616e9f2d30c1302bbb5a7a4b588bc05cd5cc9
TinderBox: Win-x86@39, Branch:master, Time: 2014-12-12_01:58:46

on Windows 7 Professional 64bit (Japanese)
Comment 6 Jacques Guilleron 2014-12-26 16:07:44 UTC
Hi Naruhiko,

I reproduce using:
LO 4.4.0.0.beta1 Build ID: 9af3d21234aa89dac653c0bd76648188cdeb683e 
LO 4.4.0.0.beta2 Build ID: be92f32b8f21603a6b7a75dd645f7475bdee519d 
LO 4.4.0.1 Build ID: 1ba9640ddd424f1f535c75bf2b86703770b8cf6f 
LO 4.5.0.0.alpha0+ Build ID: 736b040cb158308e002d24cee8c33e794b2f59a1
TinderBox: Win-x86@39, Branch:master, Time: 2014-12-01_15:20:47 Locale: fr_FR
& Windows 7 Home premium
JRE 1.7.0_65. So it's not the same bug as Bug 87241, which raise with only
JRE 1.8.0_25

Regards,

Jacques
Comment 7 Alex Thurgood 2015-01-03 17:40:58 UTC
Adding self to CC if not already on
Comment 8 wabik 2015-01-15 08:05:55 UTC
Libre Office 4.4.0.2 also is infected by this bug ... freezes.
Comment 9 Lionel Elie Mamane 2015-01-30 19:58:22 UTC
Does it freeze when connecting to the database differently than when creating a report? For example, showing the list of tables, executing a query, ...

Does it freeze (with what backtrace) when doing that with a non-Java database? E.g. an ODBC connection?

Because the backtrace looks like it is stuck on waiting for HSQLDB, trying to connect to it. This may be a Java-related problem.
Comment 10 ribotb 2015-02-03 22:05:27 UTC
LO freezes when creating a report, but also freezes when OPENING and editing a report. It is very annoying !

No problem with LO 4.3.6

And no problem with reports created with the 'old' report builder (not Sun/Oracle Report Builder).

Bernard
Comment 11 Lionel Elie Mamane 2015-02-04 06:24:24 UTC
(In reply to ribotb from comment #10)
> LO freezes when creating a report, but also freezes when OPENING and editing
> a report. It is very annoying !

You may be experiencing bug 88824, which is now fixed, as opposed to this bug. (assuming this bug is distinct from bug 88824, which is not clear).

I'm not quite sure how to understand the relationship between this group of bugs... The backtrace in this bug makes me think of a Java problem (which reminds of bug 87241), but the symptoms are, as far as I can see, identical to bug 88824.

Naruhiko, could you please confirm whether the backtrace you attached was made in conditions where bug 87241 does not happen? E.g. with Java 1.7?

I wonder if the different comments claiming reproductions for this bug are not sometimes reproductions for one of the two other bugs.

To get a clearer picture, I think it would be useful to test in a version where bug 88824 has been fixed, and see whether this bug can still be reproduced, in a situation that clearly shows it is not bug 87241.
Comment 12 Naruhiko Ogasawara 2015-02-06 10:47:14 UTC
Hi Lionel,

> Naruhiko, could you please confirm whether the backtrace you attached was
> made in conditions where bug 87241 does not happen? E.g. with Java 1.7?

I might forget something because it's a little old report for me, anyway;

My environment that I got the backtrace had been installed Java 1.7 and Java 1.8, and I (probably) selected Java 1.7 in the Tools > Option > LibreOffice > Advanced
Because I got a report from other one who used Java 1.7 only.



NOW, I uninstalled ALL Java from my Windows, then installed JDK 7u75, and tried to reproduce with:

1) Version: 4.4.0.3
Build ID: de093506bcdc5fafd9023ee680b8c60e3e0645d7
Locale: ja_JP

2) Version: 4.5.0.0.alpha0+
Build ID: 130c49bdd008d444a767b3e0828ffa07fa039367
TinderBox: Win-x86@39, Branch:master, Time: 2015-02-06_07:35:24
Locale: ja_JP

as a result, 1) have still a problem, and 2) seems OK for me.
Comment 13 Lionel Elie Mamane 2015-02-06 10:54:12 UTC
(In reply to Naruhiko Ogasawara from comment #12)

> NOW, I uninstalled ALL Java from my Windows, then installed JDK 7u75, and
> tried to reproduce with:

> 1) Version: 4.4.0.3
> Build ID: de093506bcdc5fafd9023ee680b8c60e3e0645d7
> Locale: ja_JP

> 2) Version: 4.5.0.0.alpha0+
> Build ID: 130c49bdd008d444a767b3e0828ffa07fa039367
> TinderBox: Win-x86@39, Branch:master, Time: 2015-02-06_07:35:24
> Locale: ja_JP

> as a result, 1) have still a problem, and 2) seems OK for me.

Based on these tests, I'm going to mark this as a duplicate of bug 88824, since it looks like the fix for bug 88824 fixed this also.

*** This bug has been marked as a duplicate of bug 88824 ***