Bug Hunting Session
Bug 87532 - Italic arabic characters rendered as squares with windows fallback font
Summary: Italic arabic characters rendered as squares with windows fallback font
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.4.1 release
Hardware: Other Windows (All)
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: RTL-CTL Font-Substitution
  Show dependency treegraph
 
Reported: 2014-12-20 18:09 UTC by yousifjkadom
Modified: 2017-11-04 11:56 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Example on bug. (421.07 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-12-20 18:09 UTC, yousifjkadom
Details
example (12.71 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-10-03 09:47 UTC, yousifjkadom
Details
Only-Bold (12.68 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-10-03 10:01 UTC, yousifjkadom
Details
Capture (88.84 KB, image/png)
2016-10-03 10:01 UTC, yousifjkadom
Details
Screenshot of اقرأني.docx in 4.4 and 5.3 (223.48 KB, image/jpeg)
2016-10-04 11:35 UTC, Buovjaga
Details
Arial.docx (4.31 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-02-02 09:54 UTC, yousifjkadom
Details
TimeNewRoman.docx (4.35 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-02-02 09:55 UTC, yousifjkadom
Details
Arial-libreoffice (173.47 KB, image/png)
2017-02-02 09:57 UTC, yousifjkadom
Details
Arial-MSoffice (157.47 KB, image/png)
2017-02-02 09:57 UTC, yousifjkadom
Details
TimeNewRoman-libreoffice (171.53 KB, image/png)
2017-02-02 09:58 UTC, yousifjkadom
Details
TimeNewRoman-MSoffice (157.48 KB, image/png)
2017-02-02 09:59 UTC, yousifjkadom
Details

Note You need to log in before you can comment on or make changes to this bug.
Description yousifjkadom 2014-12-20 18:09:05 UTC
Created attachment 111085 [details]
Example on bug.

Hi. LebreOffice show errors in displaying document of Arabic contents that created by Microsoft Office if they have for example "sloping formating". Then they appearing as sequares or un-understandable sombyles.
 Please open the attached file with this & read.
 Please note that in addition to bug that I just mention, there is other bug: direction of writing appears from left to right while it is from right to left & appear from right to left in Microsoft office. Even if I change direction by LebreOffice the sombyles remain.
Comment 1 yousifjkadom 2014-12-21 21:08:45 UTC
 Hi. I discovered, just few minutes ago, that this bug not related to Arial font. It is also associated with Times New Roman font. These 2 fonts are widely used by Arabic users. Please include Times New Roman font in your future fix for this issue.
 Best
Comment 2 yousifjkadom 2014-12-21 21:11:43 UTC
 Sorry, I mean that this bug not related ONLY to Arial font. But also to other font, namely Times New Roman.
Comment 3 Buovjaga 2015-01-13 18:42:30 UTC
Boxes (second half of the first page) appear on Windows versions, but only on Linux 3.3.0. Other tested Linux versions are fine.

Win 7 64-bit 4.3.5.2 and Version: 4.5.0.0.alpha0+
Build ID: b3b4bbaf6cbd2226b659fea7d6ae473ccf84e9dd
TinderBox: Win-x86@39, Branch:master, Time: 2015-01-12_06:13:44

Ubuntu 14.10 64-bit
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

LibreOffice 3.5.0rc3 
Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735

Version: 4.3.3.2
Build ID: 430m0(Build:2)

Version: 4.5.0.0.alpha0+
Build ID: 7201fa0dddd7dd0352f69fd2b2b64efcb361ccad
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2015-01-11_23:28:55
Comment 4 yousifjkadom 2015-01-30 15:29:04 UTC
   Hi. I test version 4.4.0.3 Same error still existing. Bug not yet fixed.
Comment 5 Wolfgang Jäger 2015-03-23 11:56:36 UTC
LibreOffice V4.4.2.1, Win 8.1
The issue is afflicting many fonts. It is also present in documents newly created with LibreOffice Calc or Writer. 
(I encountered this issue trying to answer a forum request: http://ask.libreoffice.org/en/question/48105/when-i-receive-an-excel-file-with-arabic-letters-some-of-them-are-displayed-in-square-garbage-character-is-there-any-other-alternative/ .) 

During my experiments the font 'Arabic Typesetting' coming with Windows was not afflicted at all. It is rendering 'Italic' fine as far as I can see. I am told on the other hand that there is no Italic face available for this font.
Comment 6 yousifjkadom 2015-07-20 08:41:14 UTC
   Hi. I test version 5.0.0 RC3 & version 4.3.5 RC1 & issue is still existing without any improvement!! Is it such deficult to fix!
   Please is there a hope to fix it or not? And if yes, at which approximate time?
   If there is no hope for fix, please inform me because I use this formate "Bold", 'Italic" frequently.
Comment 7 yousifjkadom 2015-07-20 08:47:36 UTC
   Sorry, I mean version 4.4.5 RC1
Comment 8 yousifjkadom 2015-08-05 17:42:13 UTC
I tested it on version 5.0.0.5 & still not fixed!!
Comment 9 yousifjkadom 2015-09-26 16:28:44 UTC
I test version 5.0.2 Fresh. Bug still existing!! 
You fixed bug no. 89381 & put it as high priority, while 87532 is more important!!
In fact 87532 make LibreOffice useless for many Arabic users.

By the way, before few days I test Linux mint version 17.2 cinnamon x64 from DVD & test LibreOffice that come with it, it show no such bug. Also, Apach open office which LibreOffice is a modification from it show no such bug!!

If you really like to make Libreoffice move away MS Office among middle east & Arabic useser then just fix this bug. Please give attention to it.
Comment 10 yousifjkadom 2016-02-14 22:56:58 UTC
Hi. Now we reach version 5.1 Fresh release & till now no any fix for this bug.
It seam that this bug will remain for long time.

This bug + bug number 87533 are the most aggresive of all bugs for Arabic user & user of similar right to left language which use Arabic or Arabic like alphabet.

Please your kind attention for this bug. I note that version 5.1 add more locale for Arabic language which encorage me to remained you about this bug after I loss the hope for a fix.
Comment 11 yousifjkadom 2016-03-21 09:59:33 UTC
Hi. I test this issue on version 5.1.1 Fresh release on windows 7 SP1 X64 bit.

Bug is still existing without any fix!!

Please pay attantion to this bug. Of all bugs affecting Arabic language, this bug is most anouying one. I would like to convert priority of this bug to "Major" because it realy prevent many Arabic users from complete transition from Microsoft Office to LibreOffice. But I'm not allowed for this. Please admin do so & change it to "Major".

Best regards.
Comment 12 yousifjkadom 2016-04-30 05:51:27 UTC
Hi. Just a reminder from my side to developers team about this bug.

I read that there is a month of havy work on LibreOffice during May 2016:
https://blog.documentfoundation.org/blog/2016/04/28/coming-up-the-month-of-libreoffice/

So, plase consider fixing this bug during this month.
Comment 13 Buovjaga 2016-04-30 06:48:43 UTC
(In reply to yousifjkadom from comment #12)
> Hi. Just a reminder from my side to developers team about this bug.
> 
> I read that there is a month of havy work on LibreOffice during May 2016:
> https://blog.documentfoundation.org/blog/2016/04/28/coming-up-the-month-of-
> libreoffice/
> 
> So, plase consider fixing this bug during this month.

It's a month where we expect *you* to do heavy work, if you haven't done it before. The idea is to get new people on board. The old ones are doing heavy work all the time. There are about 8000 bugs, so you will have to think of something special. Either recruit some local Arabic coder who is willing to volunteer or pay for professional support.
Comment 14 yousifjkadom 2016-04-30 10:09:02 UTC
Hi Buovjaga

I like to take part actively but:

1) I'm not programer.

2) Regarding your suggestion to search for "local Arabic coder". I'm Iraqi & live in Iraq. In my country no programers available. To be oriented just know that I'm living in Baghdad (capital city) & searching in center of PC & laptops about a laptop with pre-installed Linux. Every one I asked about Linux, ask me "what is Linux?"!! I changed question saying "I wish for laptop with Ubuntu", & same answer: "what is Ubuntu?"! So, you can imagine the sutiution!

3) Regarding donation: I'm ready but problem is that:
- bitcoin not available in Iraq. Merchant not bring it to Iraq.
- paypal prohibited - according to USA lows - from dealing with Iraq.
- Iraqi Vesa cards are prohibited & not accepted by USA sites according to USA lows. For that reson I stop to renew my visa card because practically it is useless.

----------------------
Do you accept cashU? I can donate you if you accept cashU. 
www.cashu.com

Also, I can get Google play gift cards (used by some peoples inside Iraq who created account outside Iraq) or iTune gift cards. I can - if it is of usefulness to you - buy such gift cards of these types, then copy them by scanner & finally send them to you by e-mail.

If you accept any of these method inform me please.
Comment 15 Buovjaga 2016-04-30 14:45:46 UTC
(In reply to yousifjkadom from comment #14)
> 1) I'm not programer.

I'm not a programmer either, yet I have managed to put thousands of hours into improving LibreOffice by roaming around Bugzilla.
Comment 16 yousifjkadom 2016-06-23 17:36:42 UTC Comment hidden (no-value)
Comment 17 yousifjkadom 2016-06-24 10:59:59 UTC Comment hidden (no-value)
Comment 18 yousifjkadom 2016-06-24 11:04:30 UTC
Bug still existing in version 5.1.4
Comment 19 yousifjkadom 2016-10-01 17:51:15 UTC
Bug still existing in Windows version 5.2.2 Fresh release of LibreOffice
Comment 20 Urmas 2016-10-02 14:50:42 UTC
I doubt it can be fixed.
Bold and italics are not used for Arabic text. That's why Times New Roman and Arial do not contain Arabic glyphs in bold/italic versions.
Some applications use Windows GDI that imitates them by skewing/overlaying the basic font.
LO draws the fonts directly, so it cannot use that.
Comment 21 yousifjkadom 2016-10-02 16:27:10 UTC
To dear Urmas:

Dear I'm now using Linux Fedora for 90% of my work. The remaining 10% on Windows OS only when I like to edit PDF. So, this bug no further irritate me. But for majority of Arabic users, they use Windows OS & this bug is killer for them.

Only 3 things I would to ask: 

1) how LibreOffice displaying italic Arabic correctly ?

2) why you including "bold" in this bug ??!! Bold Arabic displayed correctly by LibreOffice on Windows OS.

3) FROM POINT "2" above, how LibreOffice displaying Arabic text in bold arial & bold time new Roman correctly on Windows ?? Only if you use italic the bug will appear, but if you use "bold" without italic every thing will be O.K
Comment 22 Buovjaga 2016-10-03 07:58:56 UTC
I confirm some boxes still in 5.2, but NOT ANYMORE in 5.3!!!

Please test with a fresh version: http://dev-builds.libreoffice.org/daily/master/Win-x86@42/current/

Win 7 Pro 64-bit, Version: 5.2.1.2 (x64)
Build ID: 31dd62db80d4e60af04904455ec9c9219178d620
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
Locale: fi-FI (fi_FI); Calc: CL

Win 7 Pro 64-bit Version: 5.3.0.0.alpha0+
Build ID: 3d9231dd4945dcd6c3d53ba11152049d382b975f
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-09-28_02:14:14
Locale: fi-FI (fi_FI); Calc: CL
Comment 23 yousifjkadom 2016-10-03 09:46:05 UTC
Hi. I testet version 5.3.0.0 alpha from link you gave me. In link 2 version msi & sdk.msi I tested with non-sdk version (120 MB).

Bug still existing without any improvement. Look for attachment docx. named example. It containing 4 lines:

1st with italic Arabic arial

2nd with italic bold Arabic arial

3rd with italic Arabic time new Roman

4th with italic bold Arabic time new Roman. 

All these 4 lines appeared to me as sequers !!

Please see this file, & if word appear normal without sequers then this my be related to effects of locale ??!!! My Windows OS system locale is Arabic (UAE) but with English UI of OS.

Locale of LibreOffice 5.3 is Arabic (UAE)with English UI

My system is Windows 7 ultimate SP1 X64
Comment 24 yousifjkadom 2016-10-03 09:47:55 UTC
Created attachment 127787 [details]
example
Comment 25 yousifjkadom 2016-10-03 09:51:17 UTC
Also, the old attachment "Example on bug" appeared to me by version 5.3 with same sequers (boxes). How it appear to you normal ?? Please reopen it again.
Comment 26 yousifjkadom 2016-10-03 10:00:08 UTC
Now open attach file "Only-Bold" It contain 2 lines:

1st with bold Arabic arial (NO italic)

2nd with bold Arabic time new roman (also NO italic)

Look how appearing normal without this bug. So, please correct title of this bug. It is not related to Bold. It is only related to italic. And if there is no bold for Arabic, so how LibreOffice display them normaly !!! Please look for attached screenshot (Capture).
Comment 27 yousifjkadom 2016-10-03 10:01:01 UTC
Created attachment 127788 [details]
Only-Bold
Comment 28 yousifjkadom 2016-10-03 10:01:40 UTC
Created attachment 127789 [details]
Capture
Comment 29 Buovjaga 2016-10-04 11:35:01 UTC
Created attachment 127807 [details]
Screenshot of اقرأني.docx in 4.4 and 5.3

Huh, now I updated 5.3 build and the boxes are back in اقرأني.docx :(
It seems there might be a regression blipping in and out.

example.docx is fine in 5.2 and 5.3.

Win 7 Pro 64-bit Version: 5.3.0.0.alpha0+
Build ID: 7da2f3ce9f7b049c177a735a146dae84a764d3f7
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-10-04_03:49:06
Locale: fi-FI (fi_FI); Calc: CL
Comment 30 yousifjkadom 2016-10-05 18:24:35 UTC Comment hidden (off-topic)
Comment 31 Buovjaga 2016-10-05 18:40:09 UTC Comment hidden (off-topic)
Comment 32 Yousuf Philips (jay) (retired) 2016-10-06 05:25:32 UTC
Boxes appear in attachment 111085 [details] and attachment 127787 [details].

Workaround: Use windows bundled arabic fonts like Traditional Arabic and Simplified Arabic.

Version: 5.3.0.0.alpha0+
Build ID: 36efdec23b86fe28c79fe672bb6862fb57b6e09a
CPU Threads: 4; OS Version: Windows 6.29; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-10-05_02:20:01
Locale: en-US (en_US); Calc: CL
Comment 33 yousifjkadom 2017-02-02 09:53:15 UTC
Hi. I test issue on Windows X64 version 5.3.0 of LibreOffice on Windows 7 SP1 OS.

Bug disappear completely BUT THERE IS NOW OTHER BUG !! No more sequares on italic but on italic neither arial font appear arial nor time new roman appear time new roman !!

Please look to following attached files (2 docx & 4 screenshots) as following:

Arial.docx : show that the sequares no more appear when writing in Arabic "arial" italic. But please compare following screenshots:

Arial-libreoffice (screenshot for "Arial.docx" as appear in libreOffice) &

Arial-MSoffice (screenshot for "Arial.docx" as appear in MS office)

Look for difference: in MS office correct font displaysment while wrong display of arial font in LibreOffice.

--------------------

TimeNewRoman.docx : show that the sequares no more appear when writing in Arabic "time new Roman" italic. But compare following 2 screenshots:

TimeNewRoman-libreoffice (screenshot for "TimeNewRoman.docx" as appear in libreoffice) &

TimeNewRoman (screenshot for "TimeNewRoman.docx" as appear in MSoffice)

Look for difference: in MS office correct font displaysment while wrong display of time new Roman font in LibreOffice.

Please your kind fix ! I do not know if it is better to open new bug or post it here. If it is better to open new bug then please separate this post as new bug.

Best
Comment 34 yousifjkadom 2017-02-02 09:54:34 UTC
Created attachment 130832 [details]
Arial.docx
Comment 35 yousifjkadom 2017-02-02 09:55:24 UTC
Created attachment 130833 [details]
TimeNewRoman.docx
Comment 36 yousifjkadom 2017-02-02 09:57:06 UTC
Created attachment 130834 [details]
Arial-libreoffice
Comment 37 yousifjkadom 2017-02-02 09:57:49 UTC
Created attachment 130835 [details]
Arial-MSoffice
Comment 38 yousifjkadom 2017-02-02 09:58:39 UTC
Created attachment 130836 [details]
TimeNewRoman-libreoffice
Comment 39 yousifjkadom 2017-02-02 09:59:33 UTC
Created attachment 130837 [details]
TimeNewRoman-MSoffice
Comment 40 Buovjaga 2017-02-02 10:08:20 UTC
It is better to open a new bug as this is already so long. Please create it. You don't have to upload the attachments again - just refer to them like

attachment 130832 [details] Arial.docx

You see the link is created automatically when you copy the text and number.