Bug Hunting Session
Bug 87592 - 'Slide Master', 'Master Slide', or 'Master Page'
Summary: 'Slide Master', 'Master Slide', or 'Master Page'
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Heiko Tietze
URL:
Whiteboard: target:6.0.0
Keywords:
Depends on:
Blocks: Master-Slide
  Show dependency treegraph
 
Reported: 2014-12-22 13:24 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-08-28 12:08 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-12-22 13:24:35 UTC
In Impress, we use both Slide Master and Master Pages in the interface and many people also refer to it as Master Slides, so it would be good to standardize on one naming.

View > Master > Side Master
Sidebar > Master Pages [tab]
Comment 1 Cor Nouws 2014-12-23 09:55:42 UTC
This has been mentioned quite often, Strange that there is no issue for it already, so great you did it. Thanks,
Cor
Comment 2 Yousuf Philips (jay) (retired) 2014-12-23 12:15:56 UTC
iWork Keynote calls them Master Slides and MS Powerpoint calls them Slide Masters.

http://support.apple.com/en-us/HT3718

https://support.office.com/en-us/article/What-is-a-slide-master-fe403992-0715-407a-b218-e0258c06f5de?ui=en-US&rs=en-US&ad=US
Comment 3 Heiko Tietze 2014-12-30 09:39:37 UTC
Calligra Stage uses "Master Slide".
Comment 4 Robinson Tryon (qubit) 2016-08-24 23:14:24 UTC Comment hidden (obsolete)
Comment 5 sophie 2017-07-27 09:34:07 UTC
Hi all, thanks for working on that, it has always been confusing, the functionality is not so easy to understand at first, so consistent naming is important. Master Slide(s) would be the best in my opinion :) Sophie
Comment 6 Heiko Tietze 2017-07-27 12:47:26 UTC
Decision to go with Master Slide confirmed in the design meeting.
Comment 7 Yousuf Philips (jay) (retired) 2017-07-27 21:46:26 UTC
If the decision is to go with Master Slide, then i'm assuming we also need to change Notes Master and Handout Master to Master Notes and Master Handout.
Comment 8 Heiko Tietze 2017-07-28 09:16:34 UTC
(In reply to Yousuf Philips (jay) from comment #7)
> If the decision is to go with Master Slide, then i'm assuming we also need
> to change Notes Master and Handout Master to Master Notes and Master Handout.

"Master Notes" and "Master Handout" sounds strange to me. @Cor, @Sophie do you also think we should change those terms?
Comment 9 Commit Notification 2017-08-05 22:02:11 UTC
heiko tietze committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8fe86fb89b00b31c73fccbb9bf343818a0a1f537

tdf#87592 Consistent terminology for Master Slides

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Heiko Tietze 2017-08-28 12:08:27 UTC
*** Bug 87638 has been marked as a duplicate of this bug. ***