Bug 87597 - PERSONAS: Search should use English, not localized category names
Summary: PERSONAS: Search should use English, not localized category names
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
4.4.0.0.beta2
Hardware: Other All
: medium normal
Assignee: Muhammet Kara
QA Contact:
URL:
Whiteboard: target:5.3.0
Keywords: difficultyInteresting, easyHack, skillCpp, topicUI
Depends on:
Blocks:
 
Reported: 2014-12-22 15:50 UTC by Stanislav Horacek
Modified: 2017-02-14 08:57 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stanislav Horacek 2014-12-22 15:50:58 UTC
Choose Tools - Options - Personalization - Own Theme.
In Select Firefox Theme dialog, click one of the Categories button, e.g. Nature.
For English localization, you will retrieve all 9 themes (they're searched for "Nature" keyword). However, for e.g. Czech localization, you will get no theme, because they're searched for "Příroda" keyword (Czech translation of "Nature").

I think the English keyword should be used to get always any result.

The feature is new in 4.4. Tested in 4.4 beta2 and RC1, Ubuntu 14.04.
Comment 1 Robinson Tryon (qubit) 2014-12-23 22:32:57 UTC
Severity -> enhancement
Comment 2 Cor Nouws 2014-12-23 22:35:11 UTC
I think this is a bug, since it prevents to find themes..

Maybe the text on the button can be localised and then the search string send to the server English?

thanks for the issue Stanislav!
Cor
Comment 3 QA Administrators 2016-01-17 20:02:22 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.4 or later)  https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT:

- Update the version field
- Reply via email (please reply directly on the bug tracker)
- Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2016-01-17
Comment 5 Muhammet Kara 2016-08-10 12:48:44 UTC
I have submitted a patch for this bug,[0] and I appreciate reviews/comments.

[0] https://gerrit.libreoffice.org/28027