Bug 87650 - EDITING, FILESAVE, FORMATTING: draw arrow in calc with anchoring cell, didnt anchoring when saving
Summary: EDITING, FILESAVE, FORMATTING: draw arrow in calc with anchoring cell, didnt ...
Status: RESOLVED DUPLICATE of bug 67712
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2014-12-23 20:15 UTC by vlb
Modified: 2015-12-15 11:03 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
anchoring block arrow in calc (14.25 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-12-23 20:15 UTC, vlb
Details

Note You need to log in before you can comment on or make changes to this bug.
Description vlb 2014-12-23 20:15:30 UTC
Created attachment 111237 [details]
anchoring block arrow in calc

LO 4.3.3.2 ubuntu and windows

When i have draw block arrows in calc and anchoring to a cell, itΕ› oke.
But when i insert rows the block arrows go to the right cell, but when i save the file and reopen the file the block arrows are not to the right cell.

To reproduce in the tet file:
1) open the attachment file
2) select row 2:4 and insert tree rows
3) save the file
4) close and reopen the file and see the block arrows are not right to the cell
Comment 1 raal 2014-12-28 15:40:52 UTC
I can confirm with Version: 4.5.0.0.alpha0+
Build ID: 7f476fea47f06a7f8cc961dd4f6595a524346fa5
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2014-12-27_23:36:28

Works good with LO 3.5, regression
Comment 2 Michael Weghorn 2015-01-10 22:46:41 UTC
bibisect result:

# bad: [423a84c4f7068853974887d98442bc2a2d0cc91b] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# bad: [e02439a3d6297a1f5334fa558ddec5ef4212c574] source-hash-6b8393474974d2af7a2cb3c47b3d5c081b550bdb
git bisect bad e02439a3d6297a1f5334fa558ddec5ef4212c574
# skip: [8f4aeaad2f65d656328a451154142bb82efa4327] source-hash-1885266f274575327cdeee9852945a3e91f32f15
git bisect skip 8f4aeaad2f65d656328a451154142bb82efa4327
# skip: [866567b8f6f645b3fd67aff5e493460c63c5bfa4] source-hash-62f5fc1d2f14f8164c3dd6eca5494a8c1b01301b
git bisect skip 866567b8f6f645b3fd67aff5e493460c63c5bfa4
# good: [4d807eab897e451d5ab8352cdd952823281bcb7b] source-hash-05a0b08606ac77cf7d3e294998138610b53b1b6d
git bisect good 4d807eab897e451d5ab8352cdd952823281bcb7b
# good: [2e2d1aeff80dcbe390f6c3fbc54d6c8de81b0a0e] source-hash-64ab96cd15e52da88781e720d6f031dbcd0ba902
git bisect good 2e2d1aeff80dcbe390f6c3fbc54d6c8de81b0a0e
# bad: [ec6ba885d9d4142060cebdef210d26f0b2ef5045] source-hash-1ce6d6d4133865d9616e12228be2c04cbba1976c
git bisect bad ec6ba885d9d4142060cebdef210d26f0b2ef5045
# good: [366ddd523d5f458b9d5c357934a8fa931e9f2d62] source-hash-32ca77577f781010aa4549016adaebff1a5a3624
git bisect good 366ddd523d5f458b9d5c357934a8fa931e9f2d62
# good: [85835eaea0e00bbe3138486781a507e436bc9263] source-hash-6978ddbf4738b4c53b9d2edbe6d5ad6a061d0d0f
git bisect good 85835eaea0e00bbe3138486781a507e436bc9263
# bad: [89dc8a802d1625e0efd88ba0fb720b22be87f3f0] source-hash-da03bb1ee6a69d2f4fef4c3ca0adc0ba9588bd19
git bisect bad 89dc8a802d1625e0efd88ba0fb720b22be87f3f0
# bad: [6b0fcfdf08f741216af030aceb20152a2b327f35] source-hash-310fb291ccfb817a3503785af143828682c0c1f1
git bisect bad 6b0fcfdf08f741216af030aceb20152a2b327f35
# good: [5e90d936616ff95724eaa3e3a0a7c7a9747e9b44] source-hash-ba446dd58a4ad324d242afcd5b28d3b4dff5a881
git bisect good 5e90d936616ff95724eaa3e3a0a7c7a9747e9b44
# bad: [a7e54955e9f49e8b59dfd8c4533785a680b1796c] source-hash-5da10275a7475efdbfd9de14ea58cf8f4c6c1582
git bisect bad a7e54955e9f49e8b59dfd8c4533785a680b1796c
# first bad commit: [a7e54955e9f49e8b59dfd8c4533785a680b1796c] source-hash-5da10275a7475efdbfd9de14ea58cf8f4c6c1582
Comment 3 Matthew Francis 2015-01-13 13:17:17 UTC
The behaviour seems to have changed as of the below commit.

Adding Cc: to nopower@novell.com; Any chance you could have a look at this? Thanks


commit 2b1aa949539d2fcbb3d349be3c279996630d83fc
Author: Noel Power <noel.power@suse.com>
Date:   Tue Feb 19 17:29:32 2013 +0000

    fdo#56276 - resize/reposition rotated shapes in a sensible way
    
    Change-Id: Ifa4f848da21838591daa1f57fb42dfd3f4fa8044
Comment 4 Andras Timar 2015-04-13 16:09:22 UTC

*** This bug has been marked as a duplicate of bug 67712 ***
Comment 5 Robinson Tryon (qubit) 2015-12-15 11:03:17 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]