Download it now!
Bug 87699 - calc export chart as svg looses x-axis labels
Summary: calc export chart as svg looses x-axis labels
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.3.4.1 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 89029 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-12-25 10:13 UTC by cm20
Modified: 2016-10-23 18:50 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
png export as it should look (55.96 KB, image/png)
2014-12-25 10:13 UTC, cm20
Details
svg export (30.90 KB, image/png)
2014-12-25 10:13 UTC, cm20
Details
svg_export_with_horizontal_labels (43.73 KB, image/png)
2014-12-25 12:00 UTC, cm20
Details
data with chart (go to around row 4200) (89.39 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-04-01 05:31 UTC, cm20
Details
without x-axis. created with lo5.1.2 and data file 114514: data with chart (go to around row 4200) (19.82 KB, image/svg+xml)
2016-04-26 07:13 UTC, cm20
Details
svg export (66.28 KB, image/png)
2016-10-23 18:31 UTC, cm20
Details

Note You need to log in before you can comment on or make changes to this bug.
Description cm20 2014-12-25 10:13:07 UTC
Created attachment 111319 [details]
png export as it should look

linux opensuse thumbleweed
libreoffice base Version: 4.3.5.2.0+ Build ID: 430m0(Build:2)

in calc
exporting a chart as SVG looses x-axis labels

please have a look on the attachments
- thrueen_tagesproduktion.png = png export as it should look
- thrueen_tagesproduktion_svg2png.png = export as svg (and opened in gimp and saved as png)

thanks
Comment 1 cm20 2014-12-25 10:13:47 UTC
Created attachment 111320 [details]
svg export
Comment 2 A (Andy) 2014-12-25 11:05:08 UTC
Reproducible with LO 4.4.0.0.beta1 and 4.3.4.1 (Win 8.1).

All axes labels and the legend get lost.
Comment 3 cm20 2014-12-25 11:58:17 UTC
precision:

when major intervall is increased, so that labels can be written horizontal, the lables will be exported in SVG output.

see attachment: svg_export_with_horizontal_labels

thanks
Comment 4 cm20 2014-12-25 12:00:33 UTC
Created attachment 111323 [details]
svg_export_with_horizontal_labels
Comment 5 Markus Mohrhard 2015-03-28 00:23:08 UTC
*** Bug 89029 has been marked as a duplicate of this bug. ***
Comment 6 cm20 2015-04-01 05:31:50 UTC
Created attachment 114514 [details]
data with chart (go to around row 4200)
Comment 7 cm20 2015-04-01 05:35:12 UTC
Comment on attachment 114514 [details]
data with chart (go to around row 4200)

in attachment lo_bug_thrueen_tag_monat.ods there are the data and 2 charts (go to around row 4200) with different x axises. the one with inclined axis will be not showed when exporting the graph as svg.
thanks
Comment 8 tommy27 2016-04-16 07:27:29 UTC Comment hidden (obsolete)
Comment 9 Linus Drumbler 2016-04-16 19:44:17 UTC
Can no longer reproduce on Xubuntu 14.04 with LibreOffice Calc 5.1.2.2 (1:5.1.2~rc2-0ubuntu1~trusty0). Marking case as fixed, but feel free to re-open if you can still reproduce.
Comment 10 raal 2016-04-17 05:52:40 UTC
correct status, thanks for testing
Comment 11 cm20 2016-04-26 07:01:43 UTC
IT IS NOT RESOLVED!

with Version: 5.0.4.2 Build ID: 00m0(Build:2)

please open attached lo_bug_thrueen_tag_monat.ods

export the 2nd chart as svg.

opended the svg in inkscape, there is NO X axis.

thanks
Comment 12 cm20 2016-04-26 07:11:05 UTC
it also does not work with the latest stable 5.1.2
see attach test_5-1-2.svg
thanks
Comment 13 cm20 2016-04-26 07:13:06 UTC
Created attachment 124637 [details]
without x-axis. created with lo5.1.2 and data file 114514: data with chart (go to around row 4200)
Comment 14 Buovjaga 2016-10-21 17:06:47 UTC
Correcting status.

stof999: is this still happening with 5.2.2 btw.?
Comment 15 cm20 2016-10-23 18:31:14 UTC
Created attachment 128194 [details]
svg export

with Version: 5.3.0.0.alpha1+
it seems to work (see attachment untitled_1_line_export_from_svg.png).
thanks a lot
lgstof
Comment 16 cm20 2016-10-23 18:32:13 UTC
thanks
Comment 17 Buovjaga 2016-10-23 18:50:00 UTC
Great to hear. Tweaking status to WFM.