Bug Hunting Session
Bug 87785 - Sidebar settings not remembered after reopening
Summary: Sidebar settings not remembered after reopening
Status: RESOLVED DUPLICATE of bug 67770
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.4.0.1 rc
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Sidebar-UI-UX
  Show dependency treegraph
 
Reported: 2014-12-28 08:55 UTC by tomaskeb
Modified: 2016-10-24 15:45 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tomaskeb 2014-12-28 08:55:51 UTC
1) Hide some of the sidebar buttons (e.g. Gallery, Navigator)
2) Hide the sidebar using the View menu
3) Reopen the sidebar using the View menu. Its layout is reset and the buttons are visible again -- yet I think the setting should be remembered.

Also, the sidebar doesn’t remember the last active section. When I select e.g. Styles and formatting, hide the sidebar and show it again, it is set to the direct formatting tab.

(I know I could use just the sidebar buttons to hide most of it, but for me it’s better to hide it completely to have more screen space for the document.)
Comment 1 Cor Nouws 2014-12-28 10:37:27 UTC
Thanks, can confirm this

Strangely the query https://bugs.freedesktop.org/buglist.cgi?list_id=509160&product=LibreOffice&query_format=advanced&short_desc=side%20bar%20remember&short_desc_type=allwordssubstr  doesn't show a similar report..

Maybe it's in here https://bugs.freedesktop.org/show_bug.cgi?id=65138 but hard to tell without looking at them all ..
Comment 2 tomaskeb 2014-12-28 16:11:27 UTC
It is a question if the sidebar buttons should be customizable at all: E.g. the user hides the 'Gallery' button, closes the sidebar using the 'View' menu and then open the gallery using the 'View' menu...

If the buttons layout were to be remembered, the gallery should logically show without its appropriate button... which is questionable.
Comment 3 V Stuart Foote 2014-12-28 16:50:20 UTC

*** This bug has been marked as a duplicate of bug 67770 ***