Bug 87916 - FORMATTING: Shape text options not enabled
Summary: FORMATTING: Shape text options not enabled
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.5.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-31 16:36 UTC by Mike Sapsard
Modified: 2018-02-08 22:24 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot showing defect in file/dosplay and format setting (161.37 KB, image/png)
2014-12-31 16:36 UTC, Mike Sapsard
Details
Screenshot showing text does not flow to shape. (26.97 KB, image/png)
2017-01-03 21:01 UTC, Mike Sapsard
Details
Failed text flow in shape in Write (35.63 KB, image/png)
2018-02-06 09:01 UTC, Mike Sapsard
Details
Correct text flow in shape in Draw (46.75 KB, image/png)
2018-02-06 09:02 UTC, Mike Sapsard
Details
Write test file showing text flow (10.49 KB, application/vnd.oasis.opendocument.text)
2018-02-07 09:46 UTC, Mike Sapsard
Details
Draw file showing correct text flow in shape (10.93 KB, application/vnd.oasis.opendocument.graphics)
2018-02-07 09:50 UTC, Mike Sapsard
Details
Write screenshot after clicking away from object (19.14 KB, image/png)
2018-02-07 10:50 UTC, Mike Sapsard
Details
Mikes test file with some extra content (47.50 KB, application/vnd.oasis.opendocument.text)
2018-02-08 13:08 UTC, Cor Nouws
Details
Screen shot of Mikes test file with some extra content (84.49 KB, image/png)
2018-02-08 13:11 UTC, Cor Nouws
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Sapsard 2014-12-31 16:36:55 UTC
Created attachment 111586 [details]
Screenshot showing defect in file/dosplay and format setting

Text in a shape cannot be formatted corrctly. Many options do not show in format dialog.
Comment 1 Cor Nouws 2014-12-31 17:38:33 UTC
Comment on attachment 111586 [details]
Screenshot showing defect in file/dosplay and format setting

correct mime type
Comment 2 Buovjaga 2015-01-16 16:58:34 UTC
This seems to have changed in 4.5 alpha (not yet in 4.4 rc2 at least).
Now you can select word wrap text and fit shape and can't even select fit to frame.

Mike: can you try with a 4.5 alpha build to see, if the options are good for you? Setting to NEEDINFO until then.

http://dev-builds.libreoffice.org/daily/master/
https://wiki.documentfoundation.org/Installing_in_parallel/Linux

I tested with:
Win 7 64-bit Version: 4.5.0.0.alpha0+
Build ID: 4c93c341be1425401112eed3581e8b8a6308880d
TinderBox: Win-x86@42, Branch:master, Time: 2015-01-16_01:53:40

Ubuntu 14.10 64-bit Version: 4.5.0.0.alpha0+
Build ID: 0ffa3abc7d6c0437ece30cfb1430d28ffcc9f5c1
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2015-01-15_22:47:16
Comment 3 Gordo 2015-05-24 19:13:56 UTC
On the Drawing toolbar, the Rectangle and the Basic Shape Rectangle offer different options in Text for versions up to 4.4.3.2.  This has been fixed in master except for the Rectangle in the Menu.

I could not get these options enabled in master and on the Basic Shapes in 4.4.3.2:
Fit width to text
Fit height to text
Fit to frame
Adjust to contour

Windows Vista 64
Version: 5.1.0.0.alpha1+
Build ID: 891304bb0ad3af9d8d73f947f25477abf57485a4
TinderBox: Win-x86@39, Branch:master, Time: 2015-05-24_00:17:01
Comment 4 A (Andy) 2015-11-20 16:23:11 UTC
For me reproducible with LO 5.0.3.2, Win 8.1
Comment 5 QA Administrators 2017-01-03 19:35:59 UTC Comment hidden (obsolete)
Comment 6 Mike Sapsard 2017-01-03 20:48:25 UTC Comment hidden (obsolete)
Comment 7 Buovjaga 2017-01-03 20:59:32 UTC Comment hidden (obsolete)
Comment 8 Mike Sapsard 2017-01-03 21:01:44 UTC
Created attachment 130126 [details]
Screenshot showing text does not flow to shape.

Test with 5.2.3.2 and Linux Mint 18.1.
Comment 9 QA Administrators 2018-01-05 03:41:30 UTC Comment hidden (obsolete)
Comment 10 Cor Nouws 2018-02-04 15:44:48 UTC
works fine for me in Version: 6.1.0.0.alpha0+
Build ID: c7f74bbab4c666a8b3b865dbd58b3666f1f63052
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-02-03_00:22:13
Locale: nl-NL (nl_NL.UTF-8); Calc: group

@mike: please post a test file if there still is a problem. And test a recent version, at least 6.0.3 please.

Mind that in your latest screen shot, it may be that the text flows in the frame, not in the shape?
Comment 11 Mike Sapsard 2018-02-06 09:01:31 UTC
Created attachment 139622 [details]
Failed text flow in shape in Write
Comment 12 Mike Sapsard 2018-02-06 09:02:43 UTC
Created attachment 139623 [details]
Correct text flow in shape in Draw
Comment 13 Mike Sapsard 2018-02-06 09:06:03 UTC
Flowing text in shape works in Draw 6.0.0.3, but not in Write 6.0.0.3. See Images.
Also dialogs are different. One is 'Text...' the other is 'Text attributes'.
Comment 14 Cor Nouws 2018-02-06 20:09:19 UTC
@Mike: I asked for a test file, not for a screen print. Hence I'll not be able to reproduce and will I close the issue.
Comment 15 Mike Sapsard 2018-02-07 09:46:55 UTC
Created attachment 139653 [details]
Write test file showing text flow

Write file shows that text does not flow to contour shape.
Comment 16 Mike Sapsard 2018-02-07 09:50:02 UTC
Created attachment 139656 [details]
Draw file showing correct text flow in shape

Draw file showing text flow in shape.
Comment 17 Mike Sapsard 2018-02-07 10:50:00 UTC
Created attachment 139659 [details]
Write screenshot after clicking away from object

@Cors I just noticed this after sending the requested files, so added it for information. 

If I copy and paste a text filled shape from Draw into Write it works correctly. This has been the behaviour since I first reported the bug. 

It does suggest that it is an internal file problem and that writer can read correctly but does not write correctly.
Comment 18 Cor Nouws 2018-02-08 13:08:44 UTC
Created attachment 139692 [details]
Mikes test file with some extra content
Comment 19 Cor Nouws 2018-02-08 13:11:38 UTC
Created attachment 139693 [details]
Screen shot of Mikes test file with some extra content

Thanks Mike.
I open you file. 
Text clearly follows shape.
I insert a shape. No word wrap of text in shape.
I choose Format > Text box and Shape > Text attributes, set the property, and it works.

Can you please explain what I do different than you :) ?
Comment 20 Mike Sapsard 2018-02-08 14:41:43 UTC
Cor, I think we are doing the same things.

With the (Write) file that you sent me, I tried rotating my tree shape and discovered that the text stays parallel to the 'top' which is the first line I drew. I looked for some way to rotate the text within the shape, but could not find one. 

The only way that I can make the text flow in an irregular polygon (in Write) as I expect, is to create the object and enter the text in Draw and then to copy and paste the completed shape into Write.

I expect both Write and Draw to work in the same way, especially as they have very similar dialogs.

It seems to me (I guess) that:

1)Write and Draw use the same library code to display the shape and the text.

2)Write and Draw set different parameters when writing the text parameters to the file. Write sets the text parallel to the first line drawn (of a polygon). Draw sets the text parallel to the top of the page.

3)When copied and pasted, all of the data in the object is transferred and displayed correctly.
Comment 21 Cor Nouws 2018-02-08 22:24:47 UTC
Hi Mike,

(In reply to Mike Sapsard from comment #20)
> Cor, I think we are doing the same things.

 :)

> I expect both Write and Draw to work in the same way, especially as they
> have very similar dialogs.

However, Draw and Writer still differ in the drawing layer.
I know devs are working on this, but for the moment, what you see, is is what it is.
Closing again.