Download it now!
Bug 87921 - incorrect insertion of this .svg file (top-bottom inverted)
Summary: incorrect insertion of this .svg file (top-bottom inverted)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.4.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:svg, regression
Depends on:
Blocks: SVG-Import
  Show dependency treegraph
 
Reported: 2014-12-31 18:37 UTC by Frederic Parrenin
Modified: 2017-08-07 19:07 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
.svg file to reproduce the problem (482.93 KB, image/svg+xml)
2014-12-31 18:37 UTC, Frederic Parrenin
Details
screenshot (89.91 KB, image/png)
2015-01-01 11:32 UTC, tommy27
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frederic Parrenin 2014-12-31 18:37:04 UTC
Created attachment 111590 [details]
.svg file to reproduce the problem

The attached svg image is not correctly imported into LibreOffice Writer.
The image is top-bottom reversed.
Comment 1 Frederic Parrenin 2014-12-31 19:57:59 UTC
I forgot to mention that this svg has been produced by inkscape.
Comment 2 tommy27 2015-01-01 11:32:47 UTC
Created attachment 111606 [details]
screenshot

tested under Win8.1 x64

inserting that .svg using the "Insert/Image from File" menu in LibO Writer results in upside down and mirrored image.  see screenshot.

issue present is LibO 4.3.5 and recent 4.4.0.0 alpha and in older releases too (tested up to 4.0.4) but not present in 3.6.7 where the image is correctly rendered

hence this is a 4.0.x regression.
Comment 3 Rostislav 'R.Yu.' Okulov 2015-01-01 20:26:03 UTC
# bad: [423a84c4f7068853974887d98442bc2a2d0cc91b] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e                                                                                          
# good: [a71a4447320f177181c9cff9f7c6fd93802cbd8e] source-hash-9afb6e1e38c362a768e8e981f7b03cf8bcaf22cf                                                                                         
git bisect start 'last43onmaster' 'last36onmaster'                                                                                                                                              
# bad: [f2554751603ad8537257b3cf52d6171056c76eeb] source-hash-f42768fe0b60ecbbe9c68d775329bf28c0690131                                                                                          
git bisect bad f2554751603ad8537257b3cf52d6171056c76eeb                                                                                                                                         
# bad: [c826604de689fbabd8b1b8ea41396694e99a23d4] source-hash-32acb98b3fb6acb4712f7195cf5ea1bd69c9c6b4                                                                                          
git bisect bad c826604de689fbabd8b1b8ea41396694e99a23d4                                                                                                                                         
# good: [bb53f5537f5dd98997a2148f6a8eafb10d449831] source-hash-93effcb0a2eade8309c53b74d0ea22e8a2217661                                                                                         
git bisect good bb53f5537f5dd98997a2148f6a8eafb10d449831                                                                                                                                        
# good: [7fa43e1a1b181ccdcb395c16788a66c591b63045] source-hash-41c2b0375773b2d2945d75e255ea6bb6c7fd378d                                                                                         
git bisect good 7fa43e1a1b181ccdcb395c16788a66c591b63045                                                                                                                                        
# bad: [5b352a8b3b7a2225e56a9143b5c0046f8eeb4a52] source-hash-3c70c8e449253b4219c12ee4ef50384030a474ef                                                                                          
git bisect bad 5b352a8b3b7a2225e56a9143b5c0046f8eeb4a52                                                                                                                                         
# good: [feb021119814d5b098a8a2bbfb60d382956edab2] source-hash-9d7c1dcbbbce69bebec54d85004a0da5074775cd                                                                                         
git bisect good feb021119814d5b098a8a2bbfb60d382956edab2                                                                                                                                        
# good: [366ddd523d5f458b9d5c357934a8fa931e9f2d62] source-hash-32ca77577f781010aa4549016adaebff1a5a3624                                                                                         
git bisect good 366ddd523d5f458b9d5c357934a8fa931e9f2d62
# good: [65831911b71b1982c9c2c759fd80b8e9404e9641] source-hash-3a9e1e71d9a28b2c6bc96757e629b231d2276d9d
git bisect good 65831911b71b1982c9c2c759fd80b8e9404e9641
# bad: [251dbe932a666e83c91816fcf755a4c3be51e078] source-hash-fff4d120866a0be3cd8185f2c67bb9f59b1a6a3f
git bisect bad 251dbe932a666e83c91816fcf755a4c3be51e078
# good: [e0ee036caac97248ebe4463ca07edc5fb60941dc] source-hash-fd84daf696a368c2c7561b5253b32a63ecdeca4a
git bisect good e0ee036caac97248ebe4463ca07edc5fb60941dc
# first bad commit: [251dbe932a666e83c91816fcf755a4c3be51e078] source-hash-fff4d120866a0be3cd8185f2c67bb9f59b1a6a3f

251dbe932a666e83c91816fcf755a4c3be51e078 is the first bad commit
commit 251dbe932a666e83c91816fcf755a4c3be51e078
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Wed Oct 16 00:02:27 2013 +0000

    source-hash-fff4d120866a0be3cd8185f2c67bb9f59b1a6a3f
    
    commit fff4d120866a0be3cd8185f2c67bb9f59b1a6a3f
    Author:     Eike Rathke <erack@redhat.com>
    AuthorDate: Wed Dec 19 12:51:37 2012 +0100
    Commit:     Eike Rathke <erack@redhat.com>
    CommitDate: Wed Dec 19 12:54:30 2012 +0100
    
        added [hr-HR] D.M.Y. date acceptance pattern (dot after year)
    
        Change-Id: Ie212f2e91b3ef262997bcd125817769ae24c16c3

:100644 100644 4d127a508d6cb2bcfaeafb639df27047b8dfb295 b49febf84dac59eb75b5f7baacd2d9acbcbfffa2 Mautogen.log
:100644 100644 1338821b9fdfa960b1b2f4e06e8e5f72df8656ff 10a6a6f8e875c90d330c14cb1875af45d65ff426 Mccache.log
:100644 100644 e03cbb41cb383266fbb5ea3d0233dd860d56e082 bfcfa4afbb53315678bdfa5c0ccd017badc3cae8 Mcommitmsg
:100644 100644 7568a63fa9d5a27dd1df818e340f80a803a03a42 b387500ee67a8cde2a01a843dfe8c6a0d579e259 Mdev-install.log
:100644 100644 952dbcfbbd670205a8f0884dd7d6fd9bcd45b3c7 9897c74f5f8dd3a523b605e747bec4ff8992a2f6 Mmake.log
:040000 040000 29f5a9a0282cf2c19446f007715c1a0a0fc04020 31c714be7d2e4c57a8875f8c4b0f99e89762629b Mopt
Comment 4 Rostislav 'R.Yu.' Okulov 2015-01-01 20:28:32 UTC
Comment on attachment 111590 [details]
.svg file to reproduce the problem

edit mime type image/svg+xml
Comment 5 V Stuart Foote 2015-01-10 20:33:33 UTC
The SVG image (hindmarsh-AG2009-fig6.svg) opens visibly correct in Draw with File -> Open

but if the image is inserted into any module, the insert SVG filter is inverting the embedded PNG image.
Comment 6 Matthew Francis 2015-01-11 03:18:15 UTC
The behaviour seems to have changed as of the below commit.

Adding Cc: to wk661lo@gmail.com; Could you possibly have a look at this? Thanks


commit 3d969a60852d505cfa02a6b3410d4461718138ba
Author: Werner Koerner <wk661lo@gmail.com>
Date:   Thu Dec 13 21:38:02 2012 +0100

    fdo#58196 Viewing: Reenable mirroring for scaled-down images
    
    commit I6feb744712956a92d6140d079dc3a85ee8511930 (Stepwise
    rebuild bitmap rendering from scratch to avoid rendering bugs)
    missed horizontal and vertical flipping for images scaled down
    by more than about 60%.
    
    Change-Id: I68241792d2b43edde33f478c998d447debd8fd13
    Reviewed-on: https://gerrit.libreoffice.org/1332
    Reviewed-by: Michael Stahl <mstahl@redhat.com>
    Tested-by: Michael Stahl <mstahl@redhat.com
Comment 7 Frederic Parrenin 2015-06-18 02:30:55 UTC
On 4.4.4.2 on ubuntu 14.04, I can't even insert the svg picture.
I get an error message:  "image filter not found".
But I *can* import other svg images.
Comment 8 Frederic Parrenin 2015-06-18 05:25:17 UTC
This bug is not present in 5.0.0.0beta3 on ubuntu 14.04.
Comment 9 Adolfo Jayme 2015-08-13 14:03:46 UTC
The FIXED status is only used when a specific commit is identified as correcting a bug.
Comment 10 Xisco Faulí 2015-10-26 13:41:22 UTC
This issue is still present in 

Version: 5.0.2.2
Build ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe
Locale: es-ES (es_ES)

on Windows 7

when doing Insert -> Picture, thus REOPEN it
Comment 11 Robinson Tryon (qubit) 2015-12-10 04:27:26 UTC Comment hidden (obsolete)
Comment 12 Aron Budea 2016-08-16 03:19:00 UTC
It is actually worse now: nothing is shown. Precisely, there's a tiny little box that is actually empty when enlarged.

Versions where it's worse: 5.0.5.2, 5.2.0.4.
Versions where the original issue is present: 5.0.0.5, 5.1.0.3, 5.1.5.2.
It's somewhat messy...

Adjusting status to NEW, as no fix was committed for the issue in the first place.
Comment 13 Xisco Faulí 2016-08-30 14:54:13 UTC
@Aron,

it looks like the svg stopped getting displayed after my commit 7b7ffedfa6357b902a5e354d986dac39a3b2f462. I'll take a look. thanks
Comment 14 Xisco Faulí 2016-09-26 15:24:38 UTC
Adding Cc: to Xisco Fauli
Comment 15 Xisco Faulí 2017-08-07 19:07:23 UTC
image seems correct in

Version: 5.4.0.3
Build ID: 92c2794a7c181ba4c1c5053618179937228ed1fb
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

and in

Version: 6.0.0.0.alpha0+
Build ID: 3f16306964d5bb81dda3c681bcabbacadf424e7b
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

Closing as RESOLVED WORKSFORME